Compiler warning: initialization of pointer of type 'JSObject *' to null from a constant boolean expression [-Wbool-conversions]

RESOLVED DUPLICATE of bug 759504

Status

()

RESOLVED DUPLICATE of bug 759504
6 years ago
6 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
./dombindings_gen.cpp:1266:16: warning: initialization of pointer of type 'JSObject *' to null from a constant boolean expression [-Wbool-conversions]
        return false;
               ^~~~~

And many more warnings similar to this.
(Assignee)

Comment 1

6 years ago
Created attachment 628579 [details] [diff] [review]
Patch (v1)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #628579 - Flags: review?(bobbyholley+bmo)
(Assignee)

Updated

6 years ago
Component: DOM → XPConnect
QA Contact: general → xpconnect
Pretty sure David has a patch for this in another bug too...
This patch is missing a place.  See bug 759504.
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759504
(Assignee)

Updated

6 years ago
Attachment #628579 - Flags: review?(bobbyholley+bmo)
You need to log in before you can comment on or make changes to this bug.