Last Comment Bug 760079 - Attachment box should be wider
: Attachment box should be wider
Status: RESOLVED FIXED
[gs]
:
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: Trunk
: x86 Windows XP
: -- enhancement with 1 vote (vote)
: Thunderbird 17.0
Assigned To: Jim Porter (:squib)
:
Mentors:
https://getsatisfaction.com/mozilla_m...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 05:51 PDT by Vincent (caméléon)
Modified: 2012-08-02 23:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screenshot of the issue (46.37 KB, image/png)
2012-05-31 12:34 PDT, Vincent (caméléon)
no flags Details
Persist the attachment width (4.61 KB, patch)
2012-05-31 23:52 PDT, Jim Porter (:squib)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review

Description Vincent (caméléon) 2012-05-31 05:51:05 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848

Steps to reproduce:

from http://gsfn.us/t/2w3e0

When I add an attachment to an email a very small window appears in the top right hand side of the email. How can I make this window wider, not longer as I don't add many attachments just the attachment names are long


Actual results:

The attachment filename is very often truncated


Expected results:

The attachment box should be taller, or auto adapt to the attachment's filename.
We give too many space for email address, and not enough for the attachment's name.
Comment 1 :aceman 2012-05-31 07:50:38 PDT
For me on Win XP, the attachment box is resizable (drag the egde between the attachment box and the email addresses). Does it not work for the reporter?
Comment 2 Vincent (caméléon) 2012-05-31 07:52:33 PDT
Yes it works, but it is only a workaround, not a good fix for the issue.
Comment 3 :aceman 2012-05-31 11:18:20 PDT
So you want the attachment box to be permanently wider?
I'd suggest it just keeps the size permanently once you resize it. Which is not the case now, at each opening of the compose window the size is reset back.
Comment 4 Vincent (caméléon) 2012-05-31 12:34:55 PDT
Created attachment 628856 [details]
screenshot of the issue

hope that it is clearer with this screen-shoot. There is only the place for 11 characters for the file-name, it is really not sufficient!
Comment 5 Jim Porter (:squib) 2012-05-31 23:52:24 PDT
Created attachment 629087 [details] [diff] [review]
Persist the attachment width

(In reply to :aceman from comment #3)
> I'd suggest it just keeps the size permanently once you resize it. Which is
> not the case now, at each opening of the compose window the size is reset
> back.

This seems reasonable. Here's a patch.

bwinton, one note on the patch: I added a min-width to the attachmentBucket so that it won't shrink to 0px before collapsing. This way, when you open a new compose window after dragging the attachment bucket to collapse it, it'll still open with a sane width. 10em seems like the smallest reasonable value for this, though perhaps we could go a bit larger.
Comment 6 :aceman 2012-06-01 01:07:07 PDT
Cool. I almost had a patch for this:) I had the persist="width" parameter but it didn't work by itself. I didn't notice the resetting "document.getElementById("attachments-box").removeAttribute("width");" .

Maybe Seamonkey would want this too.

Wayne, can you take care (post status updates) of the GS topic?
Comment 7 Vincent (caméléon) 2012-06-01 01:50:37 PDT
any reason why we don't also change the default value? I don't understand why we need so much space for the address's box (which usually only contain one address per line) and so few for the attachment's box.
Comment 8 Blake Winton (:bwinton) (:☕️) 2012-06-01 08:59:12 PDT
Comment on attachment 629087 [details] [diff] [review]
Persist the attachment width

I would go much larger.  Twice as large doesn't seem unreasonable to me.

Actually, what I _really_ want it to do is remember the width it was at when I pressed the mouse button before collapsing, and return to that, instead of returning to the minimum width.  :(

I guess this is good for what it does, though, so ui-r=me, with a plea to implement the cooler behaviour I describe above.  ;)

And the code seems fine, so r=me, too.

Thanks,
Blake.
Comment 9 Jim Porter (:squib) 2012-06-02 12:58:32 PDT
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #8)
> Comment on attachment 629087 [details] [diff] [review]
> Persist the attachment width
> 
> I would go much larger.  Twice as large doesn't seem unreasonable to me.

How about 15em then? That's how big the attachment bucket is currently.

> Actually, what I _really_ want it to do is remember the width it was at when
> I pressed the mouse button before collapsing, and return to that, instead of
> returning to the minimum width.  :(

That probably necessitates a change in the <splitter> code, since we'd want that elsewhere too (e.g. the 3pane). I'll file a followup bug about this.
Comment 10 Blake Winton (:bwinton) (:☕️) 2012-06-04 08:06:54 PDT
Sure, 15em sounds fine.

Thanks,
Blake.
Comment 11 Jim Porter (:squib) 2012-08-02 23:43:18 PDT
Checked in: http://hg.mozilla.org/comm-central/rev/f060e51439c5

Note You need to log in before you can comment on or make changes to this bug.