Closed Bug 760090 Opened 10 years ago Closed 10 years ago

Find in Page buttons should have tap-down graphic assets

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox15+ verified, firefox16 verified)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox15 + verified
firefox16 --- verified

People

(Reporter: aaronmt, Assigned: sriram)

References

Details

(Keywords: polish, uiwanted)

Attachments

(1 file)

Currently the buttons dont have a button tap-down graphic assets because it looks like you're not really pressing them.

Tested via 

Samsung Galaxy Nexus (Android 4.0.4)
20120531040223
http://hg.mozilla.org/integration/mozilla-inbound/rev/ff2ad97929e8
Ian, thoughts?
Keywords: uiwanted
Will decide on tracking once UX has weighed in.
We do want tap-down background graphics here, and they should be orange -- for those who do not yet know, we are moving to a universal orange selection colour on all versions of Android.  

Adding Sriram, who has been orangifying our title bars and menus -- hopefully we can reuse some of those assets here. This would bee a good time to switch the search bar focus colour over to orange, as well.
Attached patch PatchSplinter Review
This reuses existing resource as background.
Attachment #631279 - Flags: review?(mark.finkle)
Attachment #631279 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/5b1e6a274426

Per the tree rules, please set the target milestone, assignee, etc when landing on inbound.
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Tracking for 15, please nominate for uplift to Aurora.
Comment on attachment 631279 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: The button won't have a highlight on press.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #631279 - Flags: approval-mozilla-aurora?
Depends on: 760970
Attachment #631279 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Find in Page buttons are having now the tap-down graphic assets both on Aurora and Nightly. The tap background is orange. 
Closing bug as verified fixed on:

Firefox 16.0a1 (2012-07-10)
Firefox 15.0a2 (2012-07-10)

Device: Galaxy Nexus
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.