The default bug view has changed. See this FAQ.

Custom menu button hard to press after recent redesign

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
major
VERIFIED FIXED
5 years ago
8 months ago

People

(Reporter: monreal, Assigned: sriram)

Tracking

15 Branch
Firefox 16
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15 fixed)

Details

Attachments

(5 attachments)

(Reporter)

Description

5 years ago
In recent builds featuring the redesigned UI, the menu button moved to the left of the new tab button and is very hard to press now. The touch target should be larger. Also, the target seems to be only on the left side of the button right now, as pressing on the middle/right activates the new tab button.
Agreed, running into this too on my Galaxy Nexus (Android 4.0.4). Sriram?
tracking-fennec: --- → ?
status-firefox15: --- → affected
OS: Linux → Android
Summary: Menu button hard to press after redesign → Custom menu button hard to press after recent redesign
Created attachment 629611 [details]
Nightly (06/03) - Touch Area

Attached is a screenshot with visible touch feedback enabled on Android 4.0.4 - the target sampled in the zone in the screenshot is overlaid over the menu button but triggers the 'new tab' button.
Created attachment 629612 [details]
Nightly (06/03) - Menu button down

More obvious with button-down highlight ...
(Assignee)

Comment 4

5 years ago
The width is 36dp on portrait mode. This should be 48dp to match the height of the action bar. Also, it should on top of the tabs-button (with a transparent background), to avoid accidental touches being delivered to tabs button (especially when hitting the curve).

Updated

5 years ago
Assignee: nobody → sriram

Updated

5 years ago
Duplicate of this bug: 761579

Updated

5 years ago
status-firefox16: --- → affected
Version: Firefox 15 → Firefox 16

Updated

5 years ago
Duplicate of this bug: 762236
(Assignee)

Comment 7

5 years ago
Created attachment 631272 [details] [diff] [review]
Patch (1/2): Menu button resize

This patch resizes the menu button to be square, and places it on top of the tabs button. The touch goes to menu button and not to tabs.
Attachment #631272 - Flags: review?(mark.finkle)
(Assignee)

Comment 8

5 years ago
Created attachment 631274 [details] [diff] [review]
Patch (2/2): Optimize the orange color

This patch optimizes the orange color used. I felt we are using way too many orange highlight, even though they don't come with a texture. The other problem is they are not scalable.

I'll attach a screenshot with differences soon.
Attachment #631274 - Flags: review?(mark.finkle)
(Assignee)

Comment 9

5 years ago
Created attachment 631275 [details]
Screenshot: Comparison

This shows the difference between the two.
Basically they both don't have any difference.
Ian's resource has a 1pixel yellow color on the top, that merges with the background's top 1px inside glow color.
Given the fact that this is going to be "under" the finger, and not going to be visible to the user much when he press, I guess we can use a gradient and kill 15 resources in the name of https://areweslimyet.com/
Attachment #631272 - Flags: review?(mark.finkle) → review+
Attachment #631274 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 10

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/b79284be046a
http://hg.mozilla.org/integration/mozilla-inbound/rev/c4b6f8f04f9a
https://hg.mozilla.org/mozilla-central/rev/b79284be046a
https://hg.mozilla.org/mozilla-central/rev/c4b6f8f04f9a

(Merged by Ed Morley)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
I know this is resolved already, but I just wanted to add that I am happy to see a gradient selection applied in code rather than with a bunch of different images. I too am a fan of efficiency. Sometimes. :)

Updated

5 years ago
status-firefox16: affected → ---
Verified fixed on Nightly 16.0a1 (2012-06-12)
Samsung Galaxy SII (2.3.4)
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Blocks: 739407
(Assignee)

Comment 14

5 years ago
Comment on attachment 631272 [details] [diff] [review]
Patch (1/2): Menu button resize

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Soft Menu button will be hard to press on Nexus.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #631272 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 15

5 years ago
Comment on attachment 631274 [details] [diff] [review]
Patch (2/2): Optimize the orange color

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: More resources will be used unnecessarily.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #631274 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Blocks: 760090
(Assignee)

Updated

5 years ago
Blocks: 763851
Comment on attachment 631272 [details] [diff] [review]
Patch (1/2): Menu button resize

[Triage Comment]
Little risk this early in the cycle.
Attachment #631272 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Attachment #631274 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 17

5 years ago
Pushed to aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/adebfe601696
https://hg.mozilla.org/releases/mozilla-aurora/rev/c15196a7217b

Updated

5 years ago
status-firefox15: affected → fixed
Version: Firefox 16 → Firefox 15
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.