Closed Bug 760111 Opened 8 years ago Closed 8 years ago

Disconnect Error in endurance test: testFlash_SWFVideoEmbed

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davehunt, Assigned: vladmaniac)

References

Details

(Whiteboard: [mozmill-test-failure][mozmill-endurance])

Attachments

(1 file)

The /testFlash_SWFVideoEmbed/test1.js test is failing regularly on Linux Ubuntu 32bit. See recent test failures:

http://mozmill-ci.blargon7.com/#/endurance/report/fdec829b93b19c73985be1d388361f7a
http://mozmill-ci.blargon7.com/#/endurance/report/fdec829b93b19c73985be1d38834c106

It doesn't fail every time though, and when it passes it's not with high memory usage. See a recent pass:

http://mozmill-ci.blargon7.com/#/endurance/report/fdec829b93b19c73985be1d388350ee1
I will attempt to replicate this on qa-masterblaster whilst watching the testrun.
This happened a lot lately. Can we please get this backed-out ASAP and investigated afterward?

http://mozmill-ci.blargon7.com/#/endurance/report/23e194f1171aa4baf774928b262b657c

Vlad, mind taking it?
Assignee: nobody → vlad.mozbugs
OS: Linux → All
Hardware: x86 → All
(In reply to Henrik Skupin (:whimboo) from comment #2)
> This happened a lot lately. Can we please get this backed-out ASAP and
> investigated afterward?
> 
> http://mozmill-ci.blargon7.com/#/endurance/report/
> 23e194f1171aa4baf774928b262b657c
> 
> Vlad, mind taking it?

Do we need to back out or just skip the test?
Status: NEW → ASSIGNED
Well, I meant skip. Sorry.
Attached patch skip the testSplinter Review
skip the test until further investigation results
Attachment #638304 - Flags: review?(hskupin)
Attachment #638304 - Flags: review?(dave.hunt)
So the test alone does not fail 

http://mozmill-crowd.blargon7.com/#/endurance/report/23e194f1171aa4baf774928b262fead9

The investigation plan is to run the test alone see if this triggers the disconnect, then run the whole testrun several times and if the error is echoed, then we might draw the conclusion that our test failure is run order dependent.
Running the whole testrun does not trigger the error 

http://mozmill-crowd.blargon7.com/#/endurance/report/23e194f1171aa4baf774928b26324d6e 

Moving fwd with loading the system by building b2g locally, that is cloning the github repo and doing some make commands and load the processor to more than 70%
Comment on attachment 638304 [details] [diff] [review]
skip the test

So I have checked this again and it's only failing on our suspicious Windows Vista VM which also has shown a couple of other failures lately. For now I will replace this VM with a fresh copy. Lets see if that helps.
Attachment #638304 - Flags: review?(hskupin)
Attachment #638304 - Flags: review?(dave.hunt)
Duplicate of this bug: 770518
Looks like we are ok now. Vlad where there any testrun with such a broken test? I don't think so. Lets wait one or two more days and then lets close as fixed.
(In reply to Henrik Skupin (:whimboo) from comment #10)
> Looks like we are ok now. Vlad where there any testrun with such a broken
> test? I don't think so. Lets wait one or two more days and then lets close
> as fixed.

I was indeed monitoring all endurance testrun since I am focused on that area at the moment. This was not a failure recently
On Windows this most likely depends on bug 770821. Not sure about the other platforms we got failures too.
Depends on: 770821
I forgot to install Flash on that machine. See the skipped tests:

http://mozmill-ci.blargon7.com/#/endurance/report/99ab6c49d005522227c5717d8a0ffb4e

I will do this now.
thanks Henrik
Depends on: 774595
No longer depends on: 770821
Does this failure still occur? 
I don't see it on mozmill-ci anymore
Fixed with Mozmill 1.5.15:

http://mozmill-crowd.blargon7.com/#/endurance/report/89726f6b98208a209e7ce2df1027ee7b
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.