Last Comment Bug 760169 - l10n for fennec native release 14
: l10n for fennec native release 14
Status: VERIFIED FIXED
[no-code]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 14 Branch
: x86 Mac OS X
: -- normal (vote)
: Firefox 14
Assigned To: Aki Sasaki [:aki]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 09:51 PDT by Karen Rudnitski [:kar]
Modified: 2012-07-13 14:08 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
+


Attachments
add ko and pt-BR to multilocale builds (514 bytes, patch)
2012-06-07 18:18 PDT, Aki Sasaki [:aki]
l10n: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
aki: checkin+
Details | Diff | Review

Description Karen Rudnitski [:kar] 2012-05-31 09:51:56 PDT
EN-US and current list of 13 locales (previously supported) should be supported for fennec GA (list: http://mxr.mozilla.org/mozilla-central/source/mobile/android/locales/maemo-locales). 

2-3 more locales are under investigation to also be included for the 'launch' list. Currently working with marketing to determine their markets priorities and timing.
Comment 1 Alex Keybl [:akeybl] 2012-05-31 10:15:33 PDT
Do we know what those 2-3 more locales are? I just want to verify we don't need bug 756450 for release. See https://bugzilla.mozilla.org/show_bug.cgi?id=756450#c2 for the list of affected languages.
Comment 2 Axel Hecht [:Pike] 2012-05-31 10:26:58 PDT
Current suspects are pt-BR and ko, they're not affected.

That doens't mean that we can slack on bug 756450, chofmann and I are not giving up easily on the rest of our localizations.
Comment 3 Karen Rudnitski [:kar] 2012-05-31 11:24:42 PDT
From speaking with marketing (David Slater), pt-BR and ko are excellent candidates if they can easily be put in without impacting schedule. The only other two possible candidates for future-proofing in the medium term are the two main Chinese locales, although unless you already have the libraries ready to go, these can wait until the next release.

Irina will be doing a last vet on this list, so I'll provide confirmation once I get her go-ahead that we've got ourselves covered.
Comment 4 Karen Rudnitski [:kar] 2012-06-01 10:58:01 PDT
For Rel 14, let's only add ko and pt-BR to the list of 13 + En-us languages, for a total of 16 locales for this first release. 

We will add other locales into the next round.

If there are any bugs relating to pt-BR logged, I'll suggest we remove this locale (it is lower priority) and bump it to the following round.
Comment 5 Alex Keybl [:akeybl] 2012-06-06 13:18:47 PDT
(In reply to Axel Hecht [:Pike] from comment #2)
> Current suspects are pt-BR and ko, they're not affected.
> 
> That doens't mean that we can slack on bug 756450, chofmann and I are not
> giving up easily on the rest of our localizations.

Axel - are we ready to add ko and pt-BR to our next beta build? If so, we should assign this to Aki.
Comment 6 Aki Sasaki [:aki] 2012-06-07 18:18:52 PDT
Created attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

This would land in central, aurora, and beta to avoid merge-day issues.
Comment 7 Axel Hecht [:Pike] 2012-06-08 04:51:54 PDT
Comment on attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

Review of attachment 631236 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, to both patch and branches.

To add, IMHO this should not land on ESR or release, but go there through the regular migrations.
Comment 8 Alex Keybl [:akeybl] 2012-06-08 10:04:39 PDT
> To add, IMHO this should not land on ESR or release, but go there through
> the regular migrations.

Agreed. Also, let's land this on nightly/aurora before beta.
Comment 9 Alex Keybl [:akeybl] 2012-06-08 10:04:52 PDT
Comment on attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

[Triage Comment]
Comment 10 Aki Sasaki [:aki] 2012-06-08 14:06:02 PDT
Comment on attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

http://hg.mozilla.org/integration/mozilla-inbound/rev/0ce4dcd14789
Comment 11 Aki Sasaki [:aki] 2012-06-08 18:48:18 PDT
I haven't landed on Aurora yet due to unstarred tests.
Comment 12 Ryan VanderMeulen [:RyanVM] 2012-06-09 19:17:17 PDT
(In reply to Aki Sasaki [:aki] from comment #10)
> Comment on attachment 631236 [details] [diff] [review]
> add ko and pt-BR to multilocale builds
> 
> http://hg.mozilla.org/integration/mozilla-inbound/rev/0ce4dcd14789

https://hg.mozilla.org/mozilla-central/rev/0ce4dcd14789
Comment 13 Aki Sasaki [:aki] 2012-06-11 09:56:29 PDT
Comment on attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

http://hg.mozilla.org/releases/mozilla-aurora/rev/fa957f477d69
Comment 14 Aki Sasaki [:aki] 2012-06-11 14:31:07 PDT
ko and pt-BR are in the mozilla-central multilocale nightlies.
Tonight's aurora nightlies should as well.

Alex: do you want to mark this bug as fixed since it's fixed in nightlies, or do you want to leave open until we land on mozilla-beta?
Comment 15 Axel Hecht [:Pike] 2012-06-11 15:22:41 PDT
Comment on attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

We want this on Beta, too.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: No Korean and Portuguese (Brazil) version on the market for 14
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch: None
Comment 16 Alex Keybl [:akeybl] 2012-06-11 16:58:43 PDT
We're OK to resolve this as fixed - it'll still show up in our release queries. Let's also take the change on Beta 14 already.
Comment 17 Aki Sasaki [:aki] 2012-06-11 19:34:00 PDT
Comment on attachment 631236 [details] [diff] [review]
add ko and pt-BR to multilocale builds

http://hg.mozilla.org/releases/mozilla-beta/rev/bb7ea7f62a6b
Comment 18 Adrian Tamas (:AdrianT) 2012-06-13 01:38:11 PDT
ko and pt-BR localization does not work on Firefox 14 beta 7 - issue is covered in the new bug 764300. The same issue can be seen on Nightly 16.0a1 2012-06-12 but not on Aurora 15.0a2 2012-06-12 on the Samsung Galaxy Nexus (Android 4.0.2)
Comment 19 Cristian Nicolae (:xti) 2012-07-10 01:18:04 PDT
ko and pt-BR were added to the latest Beta and Release builds (available on Google Play). Closing bug as verified fixed.

--
Device: Galaxy Nexus
OS: Android 4.0.4
Comment 20 Alex Keybl [:akeybl] 2012-07-13 14:08:06 PDT
Sending this to Aki, as he actually resolved.

Note You need to log in before you can comment on or make changes to this bug.