The default bug view has changed. See this FAQ.

Remove unneeded EGLContext creation in GLController.java

RESOLVED FIXED in Firefox 14

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Tracking

unspecified
mozilla15
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed, blocking-fennec1.0 +)

Details

(Whiteboard: [gfx][qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This is old and causing some sadness on platforms with a limited number of contexts
(Assignee)

Updated

5 years ago
Blocks: 754257
(Assignee)

Comment 1

5 years ago
Created attachment 628898 [details] [diff] [review]
Don't create an egl context we don't use

Note, there's a small behaviour change which causes us to call onSurfaceChanged even when mGL would've been NULL. In this case it should be safe and this should be cleaned up after kat's work in bug 758635.
Assignee: nobody → jmuizelaar
Attachment #628898 - Flags: review?(ajuma)
Blocks: 758635

Updated

5 years ago
Attachment #628898 - Flags: review?(ajuma) → review+
(Assignee)

Updated

5 years ago
Depends on: 757944
https://hg.mozilla.org/mozilla-central/rev/51d438f92407
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla15
Blocking because this fixed bug 754257.
blocking-fennec1.0: --- → +
status-firefox14: --- → affected
Duplicate of this bug: 754257
status-firefox15: --- → fixed
Whiteboard: [gfx]
(Assignee)

Comment 5

5 years ago
Comment on attachment 628898 [details] [diff] [review]
Don't create an egl context we don't use

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: We use an extra EGL context which is a problem for mobile devices with only 8 available contexts. Bug 754257 (a blocker) depends on this.
Testing completed (on m-c, etc.): Has been on m-c for a couple of days
Risk to taking this patch (and alternatives if risky): Mobile only, mostly removes some basically unused code.
String or UUID changes made by this patch: None
Attachment #628898 - Flags: approval-mozilla-beta?
Attachment #628898 - Flags: approval-mozilla-aurora?
Comment on attachment 628898 [details] [diff] [review]
Don't create an egl context we don't use

This is already on aurora (mozilla15). Approved for beta, please land ASAP.
Attachment #628898 - Flags: approval-mozilla-beta?
Attachment #628898 - Flags: approval-mozilla-beta+
Attachment #628898 - Flags: approval-mozilla-aurora?
http://hg.mozilla.org/releases/mozilla-beta/rev/58b048bf961c
status-firefox14: affected → fixed
Backed out of beta for burning the tree. This needs to be pushed along with bug 757944, which I should have noticed from the Depends line.

https://hg.mozilla.org/releases/mozilla-beta/rev/8a0592b3f4ff
status-firefox14: fixed → affected
Relanded with bug 757944:

https://hg.mozilla.org/releases/mozilla-beta/rev/092b84e7cd64
status-firefox14: affected → fixed

Updated

5 years ago
Whiteboard: [gfx] → [gfx][qa-]
You need to log in before you can comment on or make changes to this bug.