Last Comment Bug 760335 - Suppress Android gcc 4.4 warnings about "mangling of 'va_list' has changed in GCC 4.4"
: Suppress Android gcc 4.4 warnings about "mangling of 'va_list' has changed in...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Chris Peterson [:cpeterson]
:
Mentors:
https://groups.google.com/group/andro...
Depends on:
Blocks: 826133
  Show dependency treegraph
 
Reported: 2012-05-31 17:42 PDT by Chris Peterson [:cpeterson]
Modified: 2013-01-02 17:43 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
suppress-psabi-warnings.patch (2.61 KB, patch)
2012-05-31 17:45 PDT, Chris Peterson [:cpeterson]
vladimir: review+
Details | Diff | Splinter Review

Description Chris Peterson [:cpeterson] 2012-05-31 17:42:23 PDT
Android's gcc 4.4 dumps many "the mangling of 'va_list' has changed in GCC 4.4" warnings for system headers we don't control and va_list code that does not care about a stable name mangling ABI.

David Turner from the Android NDK team says [1]:

> there is no simple way to get rid of
> the warning that I know of (trust me I tried).
> The warning message comes from historical reasons. I believe it has been
> completely removed from the GCC 4.5 sources, but we're not using this yet.
> 
> For the record, the issue is that the mangling of 'va_list' has changed
> between gcc 4.2.1 and 4.4.0 (due to a late corrigenda to the ARM spec,
> previous versions of the toolchain mangled va_list the same a void*, which
> was wrong).
> 
> This however does *not* affect NDK-generated code because, very fortunately,
> none of the stable ABIs exposed by the NDK depend on this mangling (this has
> been checked carefully), so whichever toolchain you use, your code will run
> on all Android systems.

[1] https://groups.google.com/group/android-ndk/browse_thread/thread/9ab939743a968a83
Comment 1 Chris Peterson [:cpeterson] 2012-05-31 17:45:43 PDT
Created attachment 629013 [details] [diff] [review]
suppress-psabi-warnings.patch

Add gcc -Wno-psabi for Fennec's CXXFLAGS.
Comment 2 Vladimir Vukicevic [:vlad] [:vladv] 2012-06-01 10:01:15 PDT
Comment on attachment 629013 [details] [diff] [review]
suppress-psabi-warnings.patch

Yes please!
Comment 3 Chris Peterson [:cpeterson] 2012-06-01 12:03:02 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6a639340d3b6

Note You need to log in before you can comment on or make changes to this bug.