Closed Bug 760417 Opened 8 years ago Closed 5 years ago

When selecting "Pop out" for HTML5 videos, the window is opened in full screen mode and the "Full screen" button is still available on its right bottom side

Categories

(Core :: Audio/Video, defect, minor)

10 Branch
All
Linux
defect
Not set
minor

Tracking

()

RESOLVED INVALID

People

(Reporter: ioana_damy, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0

STR:
1. Launch Firefox.
2. Load http://www.youtube.com/html5 in the browser and join the HTML5 trial.
3. Load http://www.youtube.com/watch?v=kkGeOWYOFoA in the browser (or any other HTML5 youtube video).
4. Click on the "Full screen" button.
5. Right-click the video and select "Pop out".

The pop out window is opened directly in full screen mode but the "Full screen" button is still available on its right bottom side (issue visible in the attachment).

This issue reproduces the same way in the latest Aurora and Nightly builds (2012-05-31).
Summary: When selecting "Pop out" for HTML5 videos the window is opened directly in full screen mode and the "Full screen" button is still available on its right bottom side → When selecting "Pop out" for HTML5 videos, the window is opened in full screen mode and the "Full screen" button is still available on its right bottom side
Can you please check if this is a regression in Firefox 13 or if it happens in previous builds?
Last good nightly: 2011-11-08
First bad nightly: 2011-11-09

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=81dedcc49ac0&tochange=6d42793c4807
Keywords: regression
Version: 13 Branch → 10 Branch
Thanks Ioana, nothing stands out there as a bug which caused this, but someone from Engineering likely knows better than I.
This issue also reproduces on Firefox 10.0.5 ESR:
Mozilla/5.0 (X11; Linux x86_64; rv:10.0.5) Gecko/20100101 Firefox/10.0.5
In the regression window there's a merge from inbound to mozilla-central containing:

afca83588ca2	Chris Pearce — Bug 699885 part 3 - Update full-screen mochitests wait for focus. r=roc
de9859b56d6e	Chris Pearce — Bug 699885 part 2 - Exit DOM full-screen if we've changed tab or app by the time the request is granted. r=dao
bea7ecf9084e	Chris Pearce — Bug 699885 part 1 - Ensure we dispatch 'deactivate' event to chrome window when we lose focus while changing to full-screen mode. r=roc

These all involve full screen mode which seems related to the bug, or am I misreading the merge/regression window?
There's also:

f7355dc166cd	Chris Pearce — Bug 700151 - Enable DOM full-screen API by default in desktop Firefox. r=roc

Is it possible earlier builds don't see the bug due to the fact they didn't support the full screen API at all and some other code path was being taken?
"Pop out" while in fullscreen seems to work as expected for me in
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1

Can you test in the latest nightly please?
Reproducible on:
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/16.0 Firefox/16.0a1 (20120611030526)

Chris, this bug didn't reproduce on older versions either on Windows. It only reproduces on Linux.
Depends on: 1121280
Blocks: 1121280
No longer depends on: 1121280
This bug is no longer relevant because YouTube's HTML5 player no longer has a "Pop out" content menu item.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
(In reply to Chris Peterson [:cpeterson] from comment #9)
> This bug is no longer relevant because YouTube's HTML5 player no longer has
> a "Pop out" content menu item.

I think INVALID would be more appropriate in this case. WORKSFORME would suggest that the "Pop out" context menu still exists and is working without a fix on our end.
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.