Last Comment Bug 760607 - Update the Downloads Panel visual design
: Update the Downloads Panel visual design
Status: RESOLVED FIXED
[testday-20120601]
: access
Product: Firefox
Classification: Client Software
Component: Downloads Panel (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: Firefox 17
Assigned To: :Paolo Amadini
:
: :Paolo Amadini
Mentors:
Depends on: 782743 771284 787285
Blocks: 726447 776866
  Show dependency treegraph
 
Reported: 2012-06-01 11:09 PDT by [:Aleksej]
Modified: 2013-05-19 12:34 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Update the Downloads Panel visual design. (45.72 KB, patch)
2012-06-06 13:03 PDT, :Paolo Amadini
no flags Details | Diff | Splinter Review
Update the Downloads Panel visual design and icons. (38.73 KB, patch)
2012-07-12 07:53 PDT, :Paolo Amadini
mak77: review+
Details | Diff | Splinter Review

Description [:Aleksej] 2012-06-01 11:09:53 PDT
The icon is too small, so you can accidentally cancel a download you thought was completed if you try to open its containing folder.
Comment 1 :Paolo Amadini 2012-06-06 13:03:06 PDT
Created attachment 630682 [details] [diff] [review]
Update the Downloads Panel visual design.

This contains mock icons created by scaling up the icons we already had. Works
better than the current icons, while waiting for the final ones. This patch
also contains many other visual design enhancements.
Comment 2 :Paolo Amadini 2012-07-12 07:53:07 PDT
Created attachment 641464 [details] [diff] [review]
Update the Downloads Panel visual design and icons.

This includes a polished version of the icons.
Comment 3 Marco Bonardo [::mak] 2012-07-26 08:44:03 PDT
Comment on attachment 641464 [details] [diff] [review]
Update the Downloads Panel visual design and icons.

Review of attachment 641464 [details] [diff] [review]:
-----------------------------------------------------------------

I'm pretty sure most of the css values will require tweaking and polish before the end, so not going to nitpick on them for now, let's get the interaction and design almost right, and polish it hard before release.
Comment 4 :Paolo Amadini 2012-08-25 02:36:48 PDT
Now that Mac OS X arrow panels use light coloring (bug 771284), it's quite
possible that the new icons included in this patch will be less visible.

The icons, however, should be still usable given they have a border. To prevent
further delays in making the new panel design available to Nightly testers, I'm
going to land this patch as is, since we can easily follow up with new icons in
the next few days. If Stephen deosn't have time to invert the icons, we can
temporarily use the Windows icons instead.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-25 19:29:50 PDT
https://hg.mozilla.org/mozilla-central/rev/566171c7e609

Note You need to log in before you can comment on or make changes to this bug.