Sometime selects the wrong email account when replying to an email that was moved from its respective account folder to local folders.

RESOLVED DUPLICATE of bug 327713

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 327713
6 years ago
6 months ago

People

(Reporter: twentyex, Unassigned)

Tracking

(Blocks: 1 bug)

12 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

I wrote an email from account A. I moved it from the sent folder in account A to the local folder Archive.

I clicked reply on the email I just moved.


Actual results:

The reply email window opened up, but with account B as "From" instead of account A.

Account A and B each have separate POP and SMTP settings.


Expected results:

The reply email window should have opened up with account A as "From" and not with account B (because the email was originally sent from account A).
(Reporter)

Comment 1

6 years ago
Note that the bug happens frequently but not every time I reproduce the steps.
This bug occurs in different versons. I can not find any "system" behind this. 

If I receive a mail on account A the reply or the transfer must go out with the account a and with the reply address of account a. This depends only on the receiver account and not by the folder where is located the mail on what I reply or what I transfer.
Comment hidden (metoo)
You can't find already known bug for your problem in dependency tree for meta bug which is already set in "Blocks:" field of this bug?
If your problem is entirely different from any known bug, what is difference of your problem from already known bugs?
Comment hidden (metoo)
Whiteboard: dupme
(Reporter)

Comment 6

6 years ago
(In reply to WADA from comment #4)
> You can't find already known bug for your problem in dependency tree for
> meta bug which is already set in "Blocks:" field of this bug?
> If your problem is entirely different from any known bug, what is difference
> of your problem from already known bugs?

Yes, it seems to be similar to 699681.
(Reporter)

Updated

6 years ago
Severity: normal → major
(In reply to twentyex from comment #6)
> Yes, it seems to be similar to 699681.

Bug 699681 is meta bug for tracking of other bugs and is never for specific problem.
Read bugs listed in Dependency tree for that bug, please.
(Reporter)

Comment 8

6 years ago
(In reply to WADA from comment #7)
> Bug 699681 is meta bug for tracking of other bugs and is never for specific
> problem.
> Read bugs listed in Dependency tree for that bug, please.

Then probably this one: https://bugzilla.mozilla.org/show_bug.cgi?id=680500
(In reply to twentyex from comment #8)
> Then probably this one: https://bugzilla.mozilla.org/show_bug.cgi?id=680500

Nothing useful for problem analysis, fixing problem or improvement of Tb, is provided in that bug yet. Is your this bug also merely a complaint of "pre-set From: by Tb is different from your expectation"? (I can't think so.)

As I wrote in meta bug 699681 coment #11, there are known three major kinds of "pre-set From: by Tb is different from user's normal expectation".
Which is your case? Or entirely different from these three cases?
Failed to linkify, sorry for spam. meta bug 699681 comment #11
(Reporter)

Comment 11

6 years ago
(In reply to WADA from comment #10)
> Failed to linkify, sorry for spam. meta bug 699681 comment #11

It seems to be different from those three cases.

Comment 12

4 years ago
This bug still occurs.

Using 24.0.1

Comment 13

3 years ago
This is a big problem for me in 31.1 (Linux).  It happens to me consistently.

Comment 14

3 years ago
It worked fine until a few releases ago.
Comment hidden (spam)

Comment 16

3 years ago
This bug is still in existence.  If I receive an email, from a mailing list /or/ an individual, and click reply Thunderbird always sends from my default account not the one the mail was addressed to.  This is a menace as I often forget to check and get bounced emails from lists I am subscribed to.

As Mitch said above it worked fine until a few releases ago and then something was broken in an update.

Thunderbird version - 31.7.0
Flags: needinfo?(tech)

Updated

3 years ago
Flags: needinfo?(tech)
Comment hidden (spam)

Comment 18

3 years ago
Developers - I apologize for Peter who is obviously having a bad day.

The developers of this FREE program are not stupid.  

That said, it would be nice to get this bug fixed.
Comment hidden (spam)
Comment hidden (offtopic)

Comment 21

2 years ago
I have two accounts, one on my own domain, with several identities, and one on my ISP's email system with one identity. One of the identities on my domain is set a primary, and is the one I receive almost all my mail from. But when I Reply the identity on my ISP's system is used if the mail has been sent from a list or as a BCC. The correct from address is used when the mail was sent to me directly.

This is very annoying with list mail because if I forget to fix it before sending the reply the message bounces.

Comment 22

2 years ago
I have multiple email accounts in Thunderbird 38.7.1.  This bug consistently occurs when replying to a message from a Yahoo group list.  Instead of replying from the account where the message is located, Thunderbird will always have a reply address of the first account listed.  This has caused many bounces to my messages (since they come from the wrong address), which is very frustrating.

Thanks,
Mike

Updated

2 years ago
Summary: If you have multiple email accounts, Thunderbird sometime selects the wrong email account when replying to an email that was moved from its respective account folder to local folders. → Sometime selects the wrong email account when replying to an email that was moved from its respective account folder to local folders.
Whiteboard: dupme → [dupme]
Comment hidden (advocacy)

Comment 24

6 months ago
afaict comment 0 is about bug 327713.  Other comments may be about other bugs we have on file, so no need for further comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327713
You need to log in before you can comment on or make changes to this bug.