wrong security indicator appears after a session restore

NEW
Unassigned

Status

()

defect
7 years ago
7 years ago

People

(Reporter: marco, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Posted image Exclamation mark
When the Firefox session is restored, the exclamation mark is shown. When I load the page normally (or reload the restored page), the padlock is shown.

Maybe the problem is related to the forms in the page?

I'm using Firefox Aurora (14).
(Reporter)

Comment 1

7 years ago
Posted image Padlock

Updated

7 years ago
Version: unspecified → 14 Branch
Likely a problem with cached resources breaking the security state. IIRC we have other bugs on file for that. I don't think this is related to bug 742419 (though that may have made the issue more noticeable).
Bug 747090 if anything. But yeah, this just made the issue more visible, it couldn't really have caused it.
No longer blocks: 742419
Component: Location Bar → Selection
Product: Firefox → Core
QA Contact: location.bar → selection
Component: Selection → Security
QA Contact: selection → toolkit
Summary: Wrong security indicator → wrong security indicator appears after a session restore
(Reporter)

Comment 4

7 years ago
Bug 766985 should have fixed this, but I still experience the problem.
(Reporter)

Comment 5

7 years ago
Well, actually bug 766985 makes the addressbar show the globe icon instead of the exclamation mark: it's still incorrect, but at least it's better.
You need to log in before you can comment on or make changes to this bug.