If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Files >2GB not supported in Flash plugin (works in other browsers)

RESOLVED DUPLICATE of bug 634938

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 634938
5 years ago
5 years ago

People

(Reporter: lambin@gmail.com, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

In our custom Flash video player, we try to open a 2.9GB MP4 file (pseudostream).




Actual results:

Flash cannot open the file and fires a NetStream.Play.FileStructureInvalid exception.

You can reproduce this bug up to 15a1 (nightly for Windows), even with Firefox x86-64 15a1.



Expected results:

Flash should access the file correctly. It works under Opera & Chrome with the exact same plugin.
Other files <2GB works perfectly.

Might be related to bug 215450.

The URL of the video is http://online.nolife-tv.com/emission-30154 but you need to be logged in & have a "soutien" subscription to be able to access the file through the highest video quality ("TV"). We can create a few test accounts if needed.
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 634938
You need to log in before you can comment on or make changes to this bug.