Firefox startup crash in __delayLoadHelper2

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

13 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(firefox13+)

Details

(Whiteboard: [startupcrash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-3ecf5481-1d60-4548-b26e-c33de2120603 .
============================================================= 

Seen while looking at the explosive report for FF 13 b7. These crashes started in Beta 6. https://crash-stats.mozilla.com/report/list?signature=__delayLoadHelper2%20|%20xul.dll@0x2e3fb0%20|%20nsLayoutStatics::Initialize%28%29.

Frame 	Module 	Signature 	Source
0 	kernel32.dll 	RaiseException 	
1 	xul.dll 	__delayLoadHelper2 	delayhlp.cpp:325
2 	xul.dll 	xul.dll@0x2e3fb0 	
3 	xul.dll 	nsLayoutStatics::Initialize 	layout/build/nsLayoutStatics.cpp:256
4 	xul.dll 	Initialize 	layout/build/nsLayoutModule.cpp:372
5 	xul.dll 	nsComponentManagerImpl::KnownModule::Load 	xpcom/components/nsComponentManager.cpp:733
6 	xul.dll 	nsFactoryEntry::GetFactory 	xpcom/components/nsComponentManager.cpp:1738
7 	xul.dll 	nsComponentManagerImpl::CreateInstanceByContractID 	xpcom/components/nsComponentManager.cpp:1060
8 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1466
9 	xul.dll 	CallGetService 	obj-firefox/xpcom/build/nsComponentManagerUtils.cpp:94
10 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid_with_error 	obj-firefox/xpcom/build/nsCOMPtr.cpp:141
11 	xul.dll 	nsAppStartupNotifier::Observe 	embedding/components/appstartup/src/nsAppStartupNotifier.cpp:100
12 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3525
13 	msvcr100.dll 	msvcr100.dll@0x8b581 	
14 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
15 	msvcr100.dll 	_initterm 	f:\dd\vctools\crt_bld\self_x86\crt\src\crt0dat.c:872
16 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
17 	xul.dll 	mozilla::net::AssociateApplicationCacheEvent::Run 	netwerk/protocol/http/HttpChannelChild.cpp:161
18 	firefox.exe 	_SEH_epilog4 	
19 	kernel32.dll 	GetCodePageFileInfo 	
20 	kernel32.dll 	BaseProcessStart 	
21 	firefox.exe 	pre_c_init 	crtexe.c:261
(Reporter)

Updated

6 years ago
tracking-firefox13: --- → ?

Comment 1

6 years ago
Some crashes with a similar signature started in Beta 5: https://crash-stats.mozilla.com/report/list?signature=__delayLoadHelper2+|+xul.dll%400x2e3f60+|+nsLayoutStatics%3A%3AInitialize%28%29

It's probably related to an extension, but it happens too soon to have installed extensions in crash reports.
Crash Signature: [@ __delayLoadHelper2 | xul.dll@0x2e3fb0 | nsLayoutStatics::Initialize()] → [@ __delayLoadHelper2 | xul.dll@0x2e3fb0 | nsLayoutStatics::Initialize()] [@ __delayLoadHelper2 | xul.dll@0x2e3f60 | nsLayoutStatics::Initialize()]
OS: Windows NT → Windows XP

Updated

6 years ago
tracking-firefox13: ? → +
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
delayhlp.cpp is not our code.  Is it system code, or some binary extension?

Comment 3

6 years ago
(In reply to Boris Zbarsky (:bz) from comment #2)
> delayhlp.cpp is not our code.  Is it system code, or some binary extension?

It's the compiler support code for delay-loading DLLs.

Comment 4

6 years ago
Seems like this is happening while we're loading our audio components?
Component: Layout → Video/Audio
QA Contact: layout → video.audio
We stopped delayloading gkmedias in bug 740919 (which is in mozilla 14) so unless we're going to chemspill for this there's probably nothing to do here.

Updated

6 years ago
Depends on: 740919

Comment 6

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120528154913

I couldn't reproduce this issue in Firefox 13b6. 
Marcia, could you please provide some extra STR? Maybe, some links that were opened in the moment of the crash? I've restarted the browser with several websites opened in different tabs (youtube, metacafe, vimeo, some random radio stations) and it works for me. I encountered the same behavior with the latest beta (FF 19b1), no crash seen.
Flags: needinfo?(mozillamarcia.knous)
This bug was filed from crash-stats - I never was able to reproduce the issue.

(In reply to Alexandra Lucinet [QA] from comment #6)
> Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0
> Build ID: 20120528154913
> 
> I couldn't reproduce this issue in Firefox 13b6. 
> Marcia, could you please provide some extra STR? Maybe, some links that were
> opened in the moment of the crash? I've restarted the browser with several
> websites opened in different tabs (youtube, metacafe, vimeo, some random
> radio stations) and it works for me. I encountered the same behavior with
> the latest beta (FF 19b1), no crash seen.
Flags: needinfo?(mozillamarcia.knous)

Comment 8

6 years ago
Thanks Marcia for your reply. Could anyone please give me some links that were opened in the moment of the crash?
Flags: needinfo?

Comment 9

6 years ago
I don't see crashes with these two crash signatures in recent builds.
Let's close it as workforme.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?
Keywords: regression, regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.