Last Comment Bug 761279 - VS 2012 RC compiler chokes on nsTArray's Init()
: VS 2012 RC compiler chokes on nsTArray's Init()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Jim Mathies [:jimm]
:
Mentors:
Depends on:
Blocks: VC11 764362 elm-merge
  Show dependency treegraph
 
Reported: 2012-06-04 12:44 PDT by Jim Mathies [:jimm]
Modified: 2012-06-13 13:28 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.09 KB, patch)
2012-06-04 12:49 PDT, Jim Mathies [:jimm]
benjamin: review+
Details | Diff | Review

Description Jim Mathies [:jimm] 2012-06-04 12:44:16 PDT
crash:

f:\mozilla\firefox\elm-fx-dbg\dist\include\nsTArray.h(1322) : fatal error C1001: An internal error has occurred in the compiler.
(compiler file 'msc1.cpp', line 1444)
 To work around this problem, try simplifying or changing the program near the locations listed above.
Please choose the Technical Support command on the Visual C++
 Help menu, or open the Technical Support help file for more information
Internal Compiler Error in c:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\BIN\cl.exe.  You will be prompted to send an error report to Microsoft later.
Comment 1 :Ehsan Akhgari (out sick) 2012-06-04 12:48:14 PDT
Is this in an optimized build?
Comment 2 Jim Mathies [:jimm] 2012-06-04 12:49:37 PDT
Created attachment 629893 [details] [diff] [review]
patch

This only happens in locations where we have component extensions enabled - new compiler functionality which seems to be a bit buggy. I played around with a number of variations, this was the most minimalist change I found.

What I'd like to do is land this on mc and file a follow up bug on testing with the final. If they have this fixed I would then back this change out.
Comment 3 Jim Mathies [:jimm] 2012-06-04 12:50:42 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #1)
> Is this in an optimized build?

Nope, debug. I have yet to do a full release build. That's next.
Comment 4 Benjamin Smedberg [:bsmedberg] 2012-06-05 10:32:10 PDT
Comment on attachment 629893 [details] [diff] [review]
patch

Please add a comment explaining why this is multiple steps so that people wonder why there's more spaghetti than necessary.
Comment 6 Matt Brubeck (:mbrubeck) 2012-06-13 13:28:54 PDT
https://hg.mozilla.org/mozilla-central/rev/7f07a489b92a

Note You need to log in before you can comment on or make changes to this bug.