Last Comment Bug 761419 - Build failure in content/media/gstreamer/nsGStreamerReader.cpp when using clang
: Build failure in content/media/gstreamer/nsGStreamerReader.cpp when using clang
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Paul Adenot (:padenot)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 15:49 PDT by Paul Adenot (:padenot)
Modified: 2012-06-22 03:43 PDT (History)
2 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Possible patch. (1.26 KB, patch)
2012-06-04 16:01 PDT, Paul Adenot (:padenot)
kinetik: review+
Details | Diff | Splinter Review
(Added r=kinetik) (1.27 KB, patch)
2012-06-21 14:15 PDT, Paul Adenot (:padenot)
no flags Details | Diff | Splinter Review

Description Paul Adenot (:padenot) 2012-06-04 15:49:27 PDT
Compilation fails when enabling gstreamer and using clang (version 3.0-6ubuntu3), with the following error :

http://pastebin.mozilla.org/1655529
Comment 1 Paul Adenot (:padenot) 2012-06-04 16:01:29 PDT
Created attachment 629982 [details] [diff] [review]
Possible patch.

Possible patch. Untested because of bug 761409.
Comment 2 Paul Adenot (:padenot) 2012-06-05 11:02:12 PDT
Comment on attachment 629982 [details] [diff] [review]
Possible patch.

I could test that applying the patch from bug 761030, seems to do fine.
Comment 3 Matthew Gregan [:kinetik] 2012-06-05 23:13:09 PDT
Comment on attachment 629982 [details] [diff] [review]
Possible patch.

Thanks!
Comment 4 Matthew Gregan [:kinetik] 2012-06-05 23:14:07 PDT
Pasting the error here for anyone searching for this problem:

content/media/gstreamer/nsGStreamerReader.cpp:194:5: error: constant expression evaluates to -3 which cannot be narrowed to type 'guint' (aka 'unsigned int')
    ~GST_PLAY_FLAG_AUDIO, ~GST_PLAY_FLAG_VIDEO};
Comment 5 Paul Adenot (:padenot) 2012-06-21 14:15:52 PDT
Created attachment 635463 [details] [diff] [review]
(Added r=kinetik)
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-06-21 17:49:32 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0da00a304a4a
Comment 7 Ed Morley [:emorley] 2012-06-22 03:43:44 PDT
https://hg.mozilla.org/mozilla-central/rev/0da00a304a4a

Note You need to log in before you can comment on or make changes to this bug.