All users were logged out of Bugzilla on October 13th, 2018

New addon page overflows when text wrapped

VERIFIED FIXED in Firefox 15

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: darktrojan, Assigned: darktrojan)

Tracking

unspecified
mozilla16
Points:
---
Bug Flags:
in-testsuite -
in-litmus -
in-moztrap -

Firefox Tracking Flags

(firefox15 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Created attachment 630043 [details]
screenshot

This is caused entirely by XUL line wrapping, bug 492645. We could either work around it or wait for that bug to get fixed.
(Assignee)

Comment 1

6 years ago
I can fix this by removing the overflow:hidden on #addon-container.

Comment 2

6 years ago
(In reply to Geoff Lankow from comment #1)
> I can fix this by removing the overflow:hidden on #addon-container.
Without regressing bug 595656?
Blocks: 595656
(Assignee)

Comment 3

6 years ago
I'll override it with the page's stylesheet.
(Assignee)

Comment 4

6 years ago
Created attachment 630421 [details] [diff] [review]
fix
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #630421 - Flags: review?(bmcbride)
Comment on attachment 630421 [details] [diff] [review]
fix

Review of attachment 630421 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/themes/gnomestripe/mozapps/extensions/newaddon.css
@@ +22,5 @@
>    -moz-box-flex: 3;
>  }
>  
>  #addon-container {
> +  overflow: visible; /* bug 761489 */

The bug number is easy enough to find in HG history - if it warrants a comment, it should be a direct description of why it's needed.
Attachment #630421 - Flags: review?(bmcbride) → review+
(Assignee)

Comment 6

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ec43f1c0d12
No longer depends on: 492645
Flags: in-testsuite-
Flags: in-moztrap-
Flags: in-litmus-
Target Milestone: --- → mozilla16
(Assignee)

Comment 7

6 years ago
Comment on attachment 630421 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 595656
User impact if declined: new addon page may become unusable if the buttons overflow off the bottom
Testing completed (on m-c, etc.): manually tested
Risk to taking this patch (and alternatives if risky): virtually none
String or UUID changes made by this patch: none
Attachment #630421 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/4ec43f1c0d12
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Attachment #630421 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

6 years ago
Duplicate of this bug: 763919
Able to see the issue on Nightly 2012-06-05.
Verified fixed on FF 15b5 on Win 7, Ubuntu 12.04 and Mac OS X 10.6.
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.