Closed Bug 595656 Opened 9 years ago Closed 8 years ago

Add-ons view rounded border corners sometimes cut off by content

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla15
Tracking Status
blocking2.0 --- -

People

(Reporter: micmon, Assigned: Unfocused)

References

Details

Attachments

(4 files)

Attached image Screenshot
The list view is displayed with a small border radius. This looks nice most of the time, but not always. The attached screenshot shows the problem.

This is most likely a Linux platform bug.
Duplicate of this bug: 596990
It's visible on all platforms. I wonder if this is a core issue.
blocking2.0: --- → ?
OS: Linux → All
Hardware: x86 → All
Summary: List view corners not displayed correctly sometimes → Add-ons view rounded border corners sometimes cut off by content
Duplicate of this bug: 597206
Depends on: 597927
Filed a separate layout bug (bug 597927). If that can't be fixed for 4.0, we can add a margin to the richlistboxes (and the browser element in the discover view).
One or the other must be fixed for final (though adding margin would suck a lot)
blocking2.0: ? → final+
You should just be able to use 'overflow:hidden'.  If you can't, please reopen bug 597927.
Attached patch patch rev 1Splinter Review
Setting overflow: hidden only works if the container can be scrollable which decks aren't, however we can wrap the deck in a box which is to fix this.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #477602 - Flags: review?(bmcbride)
Note this also takes the chance to correct the indentation of the categories list.
Whiteboard: [has patch][needs review Unfocused]
Scrolling up on the Get Add-ons pane seems to cause this weird painting issue. It fixes itself after a 3-4 seconds though. Is this a known issue?
Comment on attachment 477602 [details] [diff] [review]
patch rev 1

r=me, dependent on how bad the issue in comment 9 is deemed to be. It doesn't seem huge to me, since its only the Get Add-ons pane when scrolling up, and disappears in a few seconds. It could probably be hacked around here (with margins - see comment 4), but it looks like something that should really be fixed in the platform.
Attachment #477602 - Flags: review?(bmcbride) → review+
Whiteboard: [has patch][needs review Unfocused] → [has patch]
That issue is actually pretty bad. We need a layout bug filed on it at least.
(In reply to comment #11)
> That issue is actually pretty bad. We need a layout bug filed on it at least.

Reopening bug 597927?
No, a new bug. Bug 597927 was about stuff not being clipped correctly. Here the clipping is probably correct, but scrolling is busted.
(In reply to comment #9)
> Created attachment 478953 [details]
> Re-painting issue screenshot
> 
> Scrolling up on the Get Add-ons pane seems to cause this weird painting issue.
> It fixes itself after a 3-4 seconds though. Is this a known issue?

Blair can you please file a new bug if you still see this issue? I can't reproduce it on my boxes.
I can still reproduce this issue when accessing get add-ons.  It appears on all four corners of the get add-ons page for me.

BUILD: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101008 Firefox/4.0b8pre ID:20101008041525

~B
To be clear, I do not have the scrolling issue. I have the same issue described in https://bugzilla.mozilla.org/attachment.cgi?id=474530 but in get add-ons.

~B
Filed bug 602892. I think I'm going to land this anyway. If we don't get the platform fix then we'll have to tidy this up some other way.
Landed: http://hg.mozilla.org/mozilla-central/rev/ce3d483c2d4e
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [has patch]
Target Milestone: --- → mozilla2.0b8
the bug is still there (on 09.10.10 nightly), if you scroll down the content - the rounded corners get cut off + the garbage appears at top left and top right of the content area if you scroll it up and down. The garbage consist of rounded corners drawn many times.
Depends on: 603120
Filed bug 603120 on the vertical scrollbars being invisible in the AOM after the landing of this bug.
Depends on: 603149
(In reply to comment #9)
> Created attachment 478953 [details]
> Re-painting issue screenshot
> 
> Scrolling up on the Get Add-ons pane seems to cause this weird painting issue.
> It fixes itself after a 3-4 seconds though. Is this a known issue?

Filed Bug 603149
No longer depends on: 603149
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101023 Firefox/4.0b8pre

Dave, I assume there is no need for an automated test?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus-
Flags: in-testsuite? → in-testsuite-
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Depends on: 623615
the fix for this has been disabled in bug 623615
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
blocking2.0: final+ → -
Assignee: dtownsend → nobody
Duplicate of this bug: 659465
Duplicate of this bug: 662054
Attached patch Re-enable fixSplinter Review
Bug 716439 fixed bug 623615, so we can re-enable this now.
Assignee: nobody → bmcbride
Status: REOPENED → ASSIGNED
Attachment #624627 - Flags: review?(dtownsend+bugmail)
Attachment #624627 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/mozilla-central/rev/c0065b9d90bf
Status: ASSIGNED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → FIXED
Depends on: 761489
You need to log in before you can comment on or make changes to this bug.