Last Comment Bug 761496 - Cannot launch multiple different native applications on linux - all apps launch the 1st app
: Cannot launch multiple different native applications on linux - all apps laun...
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Web Apps (show other bugs)
: 15 Branch
: x86_64 Linux
: -- normal
: Firefox 16
Assigned To: Marco Castelluccio [:marco]
: Jason Smith [:jsmith]
:
Mentors:
: 761677 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 21:06 PDT by Jason Smith [:jsmith]
Modified: 2016-02-04 15:00 PST (History)
7 users (show)
mcastelluccio: in‑moztrap+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1002 bytes, patch)
2012-06-06 13:11 PDT, Marco Castelluccio [:marco]
felipc: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Jason Smith [:jsmith] 2012-06-04 21:06:53 PDT
Steps:

1. Go to apps.mozillalabs.com/appdir
2. Install two distinct apps
3. Launch both apps in succession

Expected:

Each app should be launched in different windows running content specific to each app.

Actual:

Launching the 2nd app launches another window of the 1st app originally launched.

Example:

Install LucidChart and Mozilla QA WebRT Tester. Launch LucidChart. Launch Mozilla QA WebRT Tester.

Result - LucidChart is launched twice

Linux OS: Ubuntu 11
Comment 1 Yann Brelière 2012-06-05 02:02:30 PDT
I think this might be related to this bug: https://bugs.launchpad.net/unity/+bug/692462
Comment 2 Jason Smith [:jsmith] 2012-06-05 08:12:13 PDT
(In reply to Yann Brelière from comment #1)
> I think this might be related to this bug:
> https://bugs.launchpad.net/unity/+bug/692462

Sounds like it. Can someone confirm what happens with this bug on a build with the most recent fix applied to that unity bug?
Comment 3 Jason Smith [:jsmith] 2012-06-05 09:52:35 PDT
*** Bug 761677 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Overholt [:overholt] 2012-06-06 08:50:52 PDT
Just to bring information from my dupe (sorry about that):  this isn't Unity-specific as it happens to me with GNOME 3 on Fedora, too.
Comment 5 Marco Castelluccio [:marco] 2012-06-06 13:11:17 PDT
Created attachment 630689 [details] [diff] [review]
Patch
Comment 6 :Felipe Gomes (needinfo me!) 2012-06-06 14:02:29 PDT
Comment on attachment 630689 [details] [diff] [review]
Patch

ok, so it was the same problem as bug 747409
Comment 7 Jason Smith [:jsmith] 2012-06-06 14:03:44 PDT
(In reply to Felipe Gomes (:felipe) from comment #6)
> Comment on attachment 630689 [details] [diff] [review]
> Patch
> 
> ok, so it was the same problem as bug 747409

Can someone file a bug to refactor common functionality here? The code here makes me think there's code duplication going on here.
Comment 8 :Felipe Gomes (needinfo me!) 2012-06-06 15:17:41 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8061c23ff32b
Comment 9 Ed Morley [:emorley] 2012-06-07 05:48:18 PDT
https://hg.mozilla.org/mozilla-central/rev/8061c23ff32b
Comment 10 Jason Smith [:jsmith] 2012-06-07 08:08:59 PDT
Marco - Feel free to nominate this bug to uplift to Aurora.
Comment 11 Marco Castelluccio [:marco] 2012-06-07 10:08:54 PDT
Comment on attachment 630689 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This is a simple improvement for the webapps support on Linux.
User impact if declined: Linux users won't be able to launch multiple different applications.
Testing completed (on m-c, etc.): The same fix has already been tested in the Windows version.
Risk to taking this patch (and alternatives if risky): There isn't any risk in this patch. If it isn't uplifted to Aurora, Linux users won't be able to launch multiple different applications.
String or UUID changes made by this patch: None.
Comment 12 Jason Smith [:jsmith] 2012-06-08 11:16:24 PDT
Verified on Nightly.
Comment 13 Alex Keybl [:akeybl] 2012-06-11 13:57:53 PDT
(In reply to Jason Smith [:jsmith] from comment #10)
> Marco - Feel free to nominate this bug to uplift to Aurora.

Is this needed on FF15? All other basecamp work appears to be landing in FF16.
Comment 14 Jason Smith [:jsmith] 2012-06-11 13:59:41 PDT
(In reply to Alex Keybl [:akeybl] from comment #13)
> (In reply to Jason Smith [:jsmith] from comment #10)
> > Marco - Feel free to nominate this bug to uplift to Aurora.
> 
> Is this needed on FF15? All other basecamp work appears to be landing in
> FF16.

Note - desktop web runtime applies to k9o, not basecamp.

The uplift to Aurora needed if we intend to support linux web apps for FF 15, as this breaks basic smoke test functionality (and it's a low risk patch).
Comment 15 Alex Keybl [:akeybl] 2012-06-11 14:00:44 PDT
(In reply to Jason Smith [:jsmith] from comment #14)
> Note - desktop web runtime applies to k9o, not basecamp.
> 
> The uplift to Aurora needed if we intend to support linux web apps for FF
> 15, as this breaks basic smoke test functionality (and it's a low risk
> patch).

But basecamp is a subset of k90 that ships first, so why would we take this in FF15? Has product weighed in on when web app support needs to first land?
Comment 16 :Felipe Gomes (needinfo me!) 2012-06-11 14:20:55 PDT
Most of the webapps work landed for FF15, except for a few bugs marked as blockers which will then be discussed by product/release drivers if we can uplift those fixes or not. This bug should probably be marked as one of those blockers, but since it's a very simple patch we just straight nominated it to aurora.
Comment 17 Jason Smith [:jsmith] 2012-06-11 16:23:08 PDT
Alex - We currently have code active for desktop web runtime in FF 15, including basic linux web apps support. We're currently going to remain in Aurora and make the determination if we should or shouldn't remain on the FF 15 near the end of beta.

We were looking to uplift this patch, given the low risk to high value benefit this has to the current implementation of web apps on linux on FF 15 on Aurora.

Does this make sense?
Comment 18 Alex Keybl [:akeybl] 2012-06-15 16:04:45 PDT
(In reply to Jason Smith [:jsmith] from comment #17)
> Does this make sense?

Yes, thanks for the clarification.
Comment 19 :Felipe Gomes (needinfo me!) 2012-06-18 16:34:17 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/f6989dfe70bb
Comment 20 Marco Castelluccio [:marco] 2012-06-24 09:28:30 PDT
I've added the "Launch multiple applications" test case.
It depends on other test cases, let me know if this is acceptable or if test cases should be completely self-contained.

Note You need to log in before you can comment on or make changes to this bug.