crash in RapportTanzan13 with Trusteer Rapport and LastPass

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, reproducible})

13 Branch
All
Mac OS X
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox13+)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-200100f1-550f-431e-8fc8-675952120604 .
============================================================= 

Seen while looking at crash stats. https://crash-stats.mozilla.com/report/list?signature=RapportTanzan13.dylib@0x76e0. Low volume Mac crash which started showing up first using 2012051611 build and is in Beta 7 and the final build.

Should keep an eye on this one as well as check for any signatures on the Windows side.

Frame 	Module 	Signature 	Source
0 		@0x11b225800 	
1 	RapportTanzan13.dylib 	RapportTanzan13.dylib@0x76e0 	
2 	RapportTanzan13.dylib 	RapportTanzan13.dylib@0x777d 	
3 	XUL 	Atomize 	js/src/jsatom.cpp:481
4 	XUL 	js_Atomize 	js/src/jsatom.cpp:576
5 	XUL 	WorkerThreadRunnable::Run 	
6 		@0x11a9dcc07 	
7 	RapportTanzan13.dylib 	RapportTanzan13.dylib@0x14b36 	
8 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:657
9 	XUL 	NS_ProcessNextEvent_P 	obj-firefox/x86_64/xpcom/build/nsThreadUtils.cpp:245
10 	XUL 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:289
11 	libnspr4.dylib 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:187
12 	libSystem.B.dylib 	_pthread_start 	
13 	libSystem.B.dylib 	thread_start 	
14 	libnspr4.dylib 	PR_JoinThread 	nsprpub/pr/src/pthreads/ptthread.c:577

Updated

6 years ago
Summary: crash in RapportTanzan13 → crash in RapportTanzan13 with Trusteer Rapport

Comment 1

6 years ago
It's #1 top crasher in 13.0 on Mac OS X.
tracking-firefox13: --- → ?
Keywords: topcrash
(Reporter)

Comment 2

6 years ago
Looks as if Last Pass is involved:

RapportTanzan13.dylib@0x76e0|EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE (48 crashes)
     85% (41/48) vs.   9% (71/767) support@lastpass.com (LastPass Password Manager, https://addons.mozilla.org/addon/8542) (1.90.6)
     54% (26/48) vs.  10% (74/767) foxmarks@kei.com (Xmarks (formerly Foxmarks), https://addons.mozilla.org/addon/2410)
         21% (10/48) vs.   4% (34/767) 4.0.5
         33% (16/48) vs.   5% (38/767) 4.0.6
          0% (0/48) vs.   0% (1/767) 4.0.7
          0% (0/48) vs.   0% (1/767) 4.1.0
     40% (19/48) vs.  10% (77/767) {23fcfd51-4958-4f00-80a3-ae97e717ed8b}
          0% (0/48) vs.   1% (6/767) 2.1.2.126
         40% (19/48) vs.   9% (71/767) 2.1.2.145
     31% (15/48) vs.   2% (18/767) {CE6E6E3B-84DD-4cac-9F63-8D2AE4F30A4B} (CoolPreviews, https://addons.mozilla.org/addon/2207) (3.5)
     31% (15/48) vs.   4% (29/767) {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7} (WOT, https://addons.mozilla.org/addon/3456)
          0% (0/48) vs.   0% (1/767) 20110704
         31% (15/48) vs.   4% (28/767) 20120515
     31% (15/48) vs.   6% (47/767) personas@christopher.beard (Personas, https://addons.mozilla.org/addon/10900) (1.6.2)
     27% (13/48) vs.   4% (29/767) {AE93811A-5C9A-4d34-8462-F7B864FC4696} (StumbleUpon, https://addons.mozilla.org/addon/138) (4.11)
     25% (12/48) vs.   2% (17/767) {EF522540-89F5-46b9-B6FE-1829E2B572C6} (GooglePreview, https://addons.mozilla.org/addon/189) (5.5)
     27% (13/48) vs.   5% (38/767) firefox@ghostery.com (Ghostery, https://addons.mozilla.org/addon/9609) (2.7.2)
     23% (11/48) vs.   1% (11/767) {dd7515c0-0820-4234-806b-74197fa5955c} (Peers - Instant Search, https://addons.mozilla.org/addon/6589) (2)
     38% (18/48) vs.  17% (127/767) {b9db16a4-6edc-47ec-a1f4-b86292ed211d} (Video DownloadHelper, https://addons.mozilla.org/addon/3006) (4.9.9)
     23% (11/48) vs.   2% (18/767) {75623d5d-4683-402a-b610-ac4bab767c86} (Google Assistant - Surf Canyon, https://addons.mozilla.org/addon/6549)
          4% (2/48) vs.   1% (9/767) 3.3.7
         19% (9/48) vs.   1% (9/767) 3.3.8
Summary: crash in RapportTanzan13 with Trusteer Rapport → crash in RapportTanzan13 with Trusteer Rapport and LastPass
(Reporter)

Comment 3

6 years ago
I can reproduce this on Mac 10.6. You get in a crash death cycle when this happens so a pretty bad user experience.

STR:

1. Install Trusteer Rapport
2. Install Last Pass.
3. Launch Firefox 13.
4. Crash.

https://crash-stats.mozilla.com/report/index/cd54498a-437c-42ea-9d5d-3257a2120606

Comment 4

6 years ago
Looks very similar to bug 681521. Including Benjamin and roc here as well.
Whiteboard: [startupcrash]
(Reporter)

Comment 5

6 years ago
I have one profile where it is crashing consistently. I can start in Safe Mode and when I disable addons everything is OK.

I am not yet able to reproduce it in the new profile I created, even after adding LastPass.
Whiteboard: [startupcrash]
Is this a regression like bug 681521 is?

Marcia, you could then try bisecting to figure out exactly when it regressed. You should probably back up your bad profile first though in case one of the older builds fixes it :-).
I'm also able to reproduce this as Marcia did in comment 3. Let me back up my profile and see if I can trace this back to a particular build.
Simply trying to start Firefox with the profile which is in the death-spiral state

13.0: crash
13.0b7: crash
13.0b6: crash
13.0b5: crash
13.0b4: crash
12.0: crash
11.0: crash

I'm thinking that once a profile is in this state, it can't get out of it by simply going back to a known-good version. That probably makes this evermore serious.
Keywords: reproducible
Starting from a clean profile with Trusteer installed and following the steps in comment 3:

13.0: crash
13.0b7: crash
13.0b6: crash
13.0b5: crash
13.0b4: crash
12.0: crash
11.0: crash

Seems to indicate this is not a regression in Firefox 13.
Maybe one of those extensions did an update recently which is triggering this?
Trying different versions of LastPass with a clean profile in Firefox 11.0:

Firefox 13 + LastPass 1.90.6: crash
Firefox 11 + LastPass 1.90.4: crash
Firefox 9 + LastPass 1.80.0: crash

Seems to indicate this is not caused by a recent LastPass update.
Stopping Rapport allows me to start Firefox again.
Starting Rapport causing me to crash again.

I also found this article on their support site:
http://www.trusteer.com/support/en/solve-issue

-----
My browser is crashing

Platforms: Windows, Mac

This is a very rare scenario. Rapport blocks unauthorized browser add-ons from accessing the browser. Some add-ons are badly designed and do not handle blocked requests properly. As a result the add-on crashes and causes the browser to crash (as the add-on is part of the browser's process).

We are constantly testing Rapport against hundreds of browser add-ons. However, due to the huge number of add-ons you might be running an add-on that was not tested with Rapport and does not properly handles Rapport's blocking activity.

If your browser is crashing or closes on its own and you also have Symantec Endpoint Protection installed, please visit this page. Otherwise, click here to learn how to contact support

If you cannot open your browser, stop Rapport by:

Windows: going to Start->All Programs->Trusteer Rapport->Stop Rapport.
Mac: going to System Preferences -> Other -> Rapport -> Stop Rapport
-----
How long has this been the #1 topcrasher on Mac?

Was it a recent Rapport update which started this?
I'm trying to track down version info and release notes to see if their latest version is a recent update but I've been unsuccessful so far.
Do we have any contacts at Trusteer we can reach out to?

Comment 16

6 years ago
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) (away June 9-19) from comment #13)
> How long has this been the #1 topcrasher on Mac?
Since the release of Firefox 13.0b7. Firefox 12 is unaffected.

> Was it a recent Rapport update which started this?
It's correlated to one version of Trusteer Rapport:
    100% (124/124) vs.  18% (216/1233) RapportTanzan13.dylib
          0% (0/124) vs.   0% (1/1233) 5719D0AF72DF36E591F0C76F73AA66D40
          0% (0/124) vs.   1% (18/1233) D0FF4DF6BE3AD356D2B35F2EBE7E85E10
        100% (124/124) vs.  16% (197/1233) FBC415931F75D09B71484665DE6A437B0
Based on DLL correlations on Windows, there are currently two versions in use:
         1% (456/63566) 3.5.1108.78
         0% (234/63566) 3.5.1201.76
(In reply to Scoobidiver from comment #16)
> Since the release of Firefox 13.0b7. Firefox 12 is unaffected.
> Based on DLL correlations on Windows, there are currently two versions in
> use:
>          1% (456/63566) 3.5.1108.78
>          0% (234/63566) 3.5.1201.76

That seems odd to me since the version available is Rapport 3.6 and I was able to reproduce back to Firefox 9.

Note that we have other crasher bugs correlated to Rapport:
699776, 696057, 716390, 681521, 714761, 713672, 700176
Can you reproduce this crash with all NPAPI plugins disabled?
Marcia, would you mind testing this? I don't have access to a Mac right now. I can retest later on tonight if necessary.
Marcia, also, would you mind testing this in a debug build? Then we should be able to get better stacks.

Updated

6 years ago
Keywords: qawanted
I heard back from the devs. They said they disabled the feature that was causing the crashes and they're investigating the problem.
(In reply to Jorge Villalobos [:jorgev] from comment #21)
> I heard back from the devs. They said they disabled the feature that was
> causing the crashes and they're investigating the problem.

That's great news! Thanks Jorge. Let's watch to see if this starts falling off the top crash list over the weekend.

Updated

6 years ago
tracking-firefox13: ? → +
(Reporter)

Comment 23

6 years ago
A current crash stats query for FF 13 shows about 350 crashes in these two signatures on Mac.
(Reporter)

Updated

6 years ago
Crash Signature: [@ RapportTanzan13.dylib@0x76e0] [@ RapportTanzan13.dylib@0x168a9] → [@ RapportTanzan13.dylib@0x76e0] [@ RapportTanzan13.dylib@0x168a9] [@ @0x0 | RapportTanzan13.dylib@0x13342]

Comment 24

6 years ago
With combined signatures, it's #44 top browser crasher in 13.0 on Mac.
Keywords: topcrash
1 crash in reports on 13.  nothing else.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.