Last Comment Bug 761621 - interfaces inheriting a builtinclass-interface should be builtinclass too
: interfaces inheriting a builtinclass-interface should be builtinclass too
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (vacation Aug 25-28)
:
Mentors:
Depends on: 762007
Blocks: 661980 761613
  Show dependency treegraph
 
Reported: 2012-06-05 08:13 PDT by Olli Pettay [:smaug] (vacation Aug 25-28)
Modified: 2012-06-06 11:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (8.94 KB, patch)
2012-06-05 12:09 PDT, Olli Pettay [:smaug] (vacation Aug 25-28)
khuey: review+
Details | Diff | Splinter Review
Trying some webapp hackery (8.76 KB, patch)
2012-06-06 06:21 PDT, Olli Pettay [:smaug] (vacation Aug 25-28)
no flags Details | Diff | Splinter Review

Description Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-05 08:13:07 PDT
.
Comment 1 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-05 08:22:01 PDT
Hmm, there is 
+                IDL_tree_property_get(
+                  IDL_INTERFACE(iter).ident, "builtinclass")) {
+                IDL_tree_error(interface_tree,
+                               "%s is not [builtinclass] but extends "
+                               "[builtinclass] interface %s",
+                               IDL_IDENT(IDL_INTERFACE(interface_tree).ident).str,
+                               IDL_IDENT(IDL_INTERFACE(iter).ident).str);
+                return FALSE;

But I don't get that error with the patch for bug 761613
Comment 2 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-05 11:04:45 PDT
Hmm, we don't have that error anymore in the python implementation.
Comment 3 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-05 11:28:36 PDT
Either do builtinclass implicitly, or error if inheriting builtinclass.
Comment 4 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-05 11:40:32 PDT
Yeah, I think implicit is bad. We should make it an error if a non-builtin inherits a builtin. That's what I was trying to implement, but maybe I went wrong somewhere. Possibly the problem is that it's not implemented correctly in the python XPIDL parser that we recently switched to.
Comment 5 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-05 12:09:17 PDT
Created attachment 630264 [details] [diff] [review]
patch

https://tbpl.mozilla.org/?tree=Try&rev=308af20708c2

Compiles at least locally.
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-05 12:13:55 PDT
Comment on attachment 630264 [details] [diff] [review]
patch

Review of attachment 630264 [details] [diff] [review]:
-----------------------------------------------------------------

I'm just assuming you got all the interfaces.  The xpidl.py changes are fine.
Comment 7 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-06 06:21:21 PDT
Created attachment 630541 [details] [diff] [review]
Trying some webapp hackery

This needs the patch for Bug 762007
Comment 8 Olli Pettay [:smaug] (vacation Aug 25-28) 2012-06-06 11:19:20 PDT
https://hg.mozilla.org/mozilla-central/rev/5fb42dae7200

Note You need to log in before you can comment on or make changes to this bug.