Last Comment Bug 762007 - mozIDOMApplicationMgmt inherits builtinclass so it must be implemented in C++, or changed to not inherit builtinclass
: mozIDOMApplicationMgmt inherits builtinclass so it must be implemented in C++...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 765287
Blocks: 761621
  Show dependency treegraph
 
Reported: 2012-06-06 05:51 PDT by Olli Pettay [:smaug]
Modified: 2013-04-04 13:53 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP (849 bytes, patch)
2012-06-06 06:20 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review
WIP2 (2.49 KB, patch)
2012-06-06 08:07 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review
patch (2.49 KB, patch)
2012-06-06 09:25 PDT, Olli Pettay [:smaug]
fabrice: review+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2012-06-06 05:51:51 PDT

    
Comment 1 Olli Pettay [:smaug] 2012-06-06 06:00:17 PDT
for now, could we just change  mozIDOMApplicationMgmt to not inherit nsIDOMEventTarget?
Comment 2 Olli Pettay [:smaug] 2012-06-06 06:01:00 PDT
...since the implementation doesn't seem to implement nsIDOMEventTarget anyway.
Comment 3 Olli Pettay [:smaug] 2012-06-06 06:20:46 PDT
Created attachment 630540 [details] [diff] [review]
WIP
Comment 4 Olli Pettay [:smaug] 2012-06-06 07:14:49 PDT
Why are webapp implementation bugs DOM bugs?
Comment 5 Jason Smith [:jsmith] 2012-06-06 07:22:54 PDT
(In reply to Olli Pettay [:smaug] from comment #4)
> Why are webapp implementation bugs DOM bugs?

Core --> DOM:Mozilla Extensions is where bugs go for issues related to underlying mozapps API. Checking the changelog for the file being worked on, this file seems to be attached to that.

Firefox --> Web Apps is front-end work for the end user for the install lifecycle for apps natively (e.g. install app, launch app).

Myk's description a little while back summarizes it as:

"The webapp runtime for Firefox, which comprises: the stub executable launcher (i.e. the binary and related files that Firefox creates for each webapp you install to your local computer) and the XUL shell (i.e. the XULRunner application that the launcher uses to load a webapp and provide it with native integration APIs). Note: bugs about Gecko's navigator.mozApps DOM API (i.e. the API that web pages use to request webapp installation) go in Core / DOM: Mozilla Extensions; bugs about Firefox's webapp installer (i.e. the feature that creates a launcher when the user approves an installation request) go in Firefox / Web Apps. "
Comment 6 Jason Smith [:jsmith] 2012-06-06 07:23:32 PDT
(In reply to Jason Smith [:jsmith] from comment #5)
> "The webapp runtime for Firefox, which comprises: the stub executable
> launcher (i.e. the binary and related files that Firefox creates for each
> webapp you install to your local computer) and the XUL shell (i.e. the
> XULRunner application that the launcher uses to load a webapp and provide it
> with native integration APIs). Note: bugs about Gecko's navigator.mozApps
> DOM API (i.e. the API that web pages use to request webapp installation) go
> in Core / DOM: Mozilla Extensions; bugs about Firefox's webapp installer
> (i.e. the feature that creates a launcher when the user approves an
> installation request) go in Firefox / Web Apps. "

Note - this is pulled from Firefox --> Webapp Runtime
Comment 7 Olli Pettay [:smaug] 2012-06-06 08:07:54 PDT
Created attachment 630573 [details] [diff] [review]
WIP2

Need to fix the test, and also the event interface.
Comment 8 Olli Pettay [:smaug] 2012-06-06 09:25:20 PDT
Created attachment 630593 [details] [diff] [review]
patch
Comment 9 Olli Pettay [:smaug] 2012-06-06 11:19:02 PDT
https://hg.mozilla.org/mozilla-central/rev/794751c0c8f4

Note You need to log in before you can comment on or make changes to this bug.