Last Comment Bug 761688 - JS error at shutdown when calling nsIControllers.removeController from convbrowser.xml
: JS error at shutdown when calling nsIControllers.removeController from convbr...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Thunderbird 16.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
Depends on:
Blocks: 738778
  Show dependency treegraph
 
Reported: 2012-06-05 10:15 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-06-15 04:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (3.26 KB, patch)
2012-06-05 10:15 PDT, Florian Quèze [:florian] [:flo]
clokep: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Florian Quèze [:florian] [:flo] 2012-06-05 10:15:55 PDT
Created attachment 630211 [details] [diff] [review]
Patch

We have this JS error when closing Thunderbird if no conversation log has been displayed.

JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIControllers.removeController]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://chat/content/convbrowser.xml :: destroy :: line 243"  data: no]

The cause is that the controller is only added when the document of the conversation is loaded; which never happens if the convbrowser used to display logs is never used.
Comment 1 Patrick Cloke [:clokep] 2012-06-05 10:33:21 PDT
Comment on attachment 630211 [details] [diff] [review]
Patch

Review of attachment 630211 [details] [diff] [review]:
-----------------------------------------------------------------

This change looks good.
Comment 2 Florian Quèze [:florian] [:flo] 2012-06-07 07:29:18 PDT
http://hg.mozilla.org/comm-central/rev/e7896b8dd498
Comment 3 Florian Quèze [:florian] [:flo] 2012-06-12 02:24:40 PDT
Comment on attachment 630211 [details] [diff] [review]
Patch

[Approval Request Comment]
I would like to take this cleanup patch on aurora for Tb15, but it's not strictly required as nothing is visibly broken.
Comment 4 Florian Quèze [:florian] [:flo] 2012-06-15 04:01:28 PDT
https://hg.mozilla.org/releases/comm-aurora/rev/ab0ab330eb2f

Note You need to log in before you can comment on or make changes to this bug.