The default bug view has changed. See this FAQ.

Wrong |played| value when seeking back in the media.

RESOLVED FIXED in mozilla16

Status

()

Core
Audio/Video
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: padenot, Assigned: padenot)

Tracking

unspecified
mozilla16
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
STR:
- Load a video
- Play for some time
- Seek back in the stream

Expected:
- |played| should be [0.00, time we seeked from].

Actual result:
- |played| is [0.00, time we seeked to].

This is caused by the |nsTimeRanges::Normalize| method, which has a bug, it does not handle ranges contained in other ranges.
(Assignee)

Updated

5 years ago
Summary: Wrong |played| value when seeking bad in the media. → Wrong |played| value when seeking back in the media.
(Assignee)

Comment 1

5 years ago
Created attachment 630227 [details] [diff] [review]
Patch v0 : fix the bug and add a test.
Attachment #630227 - Flags: review?
(Assignee)

Updated

5 years ago
Attachment #630227 - Flags: review? → review?(chris.double)

Updated

5 years ago
Attachment #630227 - Flags: review?(chris.double) → review+
(Assignee)

Comment 2

5 years ago
Created attachment 630403 [details] [diff] [review]
Adding r=chris.double
Attachment #630227 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Keywords: checkin-needed

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/849da4232313
Keywords: checkin-needed
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/849da4232313
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Depends on: 768583
You need to log in before you can comment on or make changes to this bug.