Last Comment Bug 761890 - [Skia] Fix Skia bugs which prevent Azure canvas tests from passing
: [Skia] Fix Skia bugs which prevent Azure canvas tests from passing
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 15 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Nick Cameron [:nrc]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 765038
Blocks: 746883
  Show dependency treegraph
 
Reported: 2012-06-05 19:40 PDT by Nick Cameron [:nrc]
Modified: 2012-06-15 06:00 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch 1: build Skia under Windows (241.50 KB, patch)
2012-06-05 21:56 PDT, Nick Cameron [:nrc]
gwright: review-
Details | Diff | Splinter Review
patch 2: changes to Skia font handling (5.57 KB, patch)
2012-06-05 22:04 PDT, Nick Cameron [:nrc]
ncameron: review+
Details | Diff | Splinter Review
patch 3: Fixing Skia/Azure font things on the (9.07 KB, patch)
2012-06-05 22:06 PDT, Nick Cameron [:nrc]
ncameron: review+
Details | Diff | Splinter Review
patch 1: build Skia under Windows (241.50 KB, patch)
2012-06-05 22:21 PDT, Nick Cameron [:nrc]
gwright: review+
Details | Diff | Splinter Review
patch 4: tests which now pass (7.56 KB, patch)
2012-06-07 16:01 PDT, Nick Cameron [:nrc]
ncameron: review+
Details | Diff | Splinter Review
patch 5: tweaks to other tests (12.56 KB, patch)
2012-06-07 16:02 PDT, Nick Cameron [:nrc]
ncameron: review+
Details | Diff | Splinter Review
patch 5: tweaks to other tests (12.62 KB, patch)
2012-06-13 21:26 PDT, Nick Cameron [:nrc]
ncameron: review+
Details | Diff | Splinter Review

Description Nick Cameron [:nrc] 2012-06-05 19:40:24 PDT

    
Comment 1 Nick Cameron [:nrc] 2012-06-05 21:56:34 PDT
Created attachment 630439 [details] [diff] [review]
patch 1: build Skia under Windows
Comment 2 Nick Cameron [:nrc] 2012-06-05 22:04:55 PDT
Created attachment 630442 [details] [diff] [review]
patch 2: changes to Skia font handling

Moved from Bug 746883 and rebased. Carrying r=gw280
Comment 3 Nick Cameron [:nrc] 2012-06-05 22:06:13 PDT
Created attachment 630443 [details] [diff] [review]
patch 3: Fixing Skia/Azure font things on the

Moved from Bug 746883 and rebased carrying r=gw280
Comment 4 George Wright (:gw280) (:gwright) 2012-06-05 22:12:14 PDT
Comment on attachment 630439 [details] [diff] [review]
patch 1: build Skia under Windows

Review of attachment 630439 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good otherwise, please run it through try first for all platforms.

::: gfx/skia/update.sh
@@ +50,5 @@
>  cp $1/src/ports/*.cpp ./src/ports/
>  cp $1/src/svg/*.cpp ./src/svg/
>  cp $1/src/svg/*.h ./src/svg/
> +cp $1/src/sfnt/*.cpp ./src/svg/
> +cp $1/src/sfnt/*.h ./src/svg/

Need to update the target directory here
Comment 5 Nick Cameron [:nrc] 2012-06-05 22:21:04 PDT
Created attachment 630448 [details] [diff] [review]
patch 1: build Skia under Windows

Fixed. Running on Try right now.
Comment 6 Nick Cameron [:nrc] 2012-06-06 03:07:55 PDT
Try push (builds): https://tbpl.mozilla.org/?tree=Try&rev=5ff61477b1a4
Comment 7 Nick Cameron [:nrc] 2012-06-07 15:58:36 PDT
Try push: https://tbpl.mozilla.org/?tree=Try&rev=173cfa8a92ad
Comment 8 Nick Cameron [:nrc] 2012-06-07 16:01:05 PDT
Created attachment 631195 [details] [diff] [review]
patch 4: tests which now pass

moved from Bug 746883, guarded with azureSkia rather than making pass, carrying r=gw280,jmuizelaar
Comment 9 Nick Cameron [:nrc] 2012-06-07 16:02:05 PDT
Created attachment 631196 [details] [diff] [review]
patch 5: tweaks to other tests

Moved from bug 746883, carrying r=ggw280,jmuizelaar
Comment 11 Matt Brubeck (:mbrubeck) 2012-06-11 23:29:15 PDT
Sorry, I had to back this out on inbound because of a reftest.list syntax error and a leak in debug reftests:
https://hg.mozilla.org/integration/mozilla-inbound/rev/253d5996845e
Comment 12 Jesse Ruderman 2012-06-12 23:34:57 PDT
> #fails with Skia due to Skia bug 568

This confuses my after-fix tool.  I'd prefer a hyperlink into their bug tracker.
Comment 13 Nick Cameron [:nrc] 2012-06-12 23:48:52 PDT
(In reply to Jesse Ruderman from comment #12)
> > #fails with Skia due to Skia bug 568
> 
> This confuses my after-fix tool.  I'd prefer a hyperlink into their bug
> tracker.

http://code.google.com/p/skia/issues/detail?id=568
Comment 14 Nick Cameron [:nrc] 2012-06-13 21:21:07 PDT
Another Try push: https://tbpl.mozilla.org/?tree=Try&rev=5b27bac1b664
Comment 15 Nick Cameron [:nrc] 2012-06-13 21:26:05 PDT
Created attachment 633009 [details] [diff] [review]
patch 5: tweaks to other tests

Added a hyperlink in a comment for Jesse (comment 11), carrying r=gw280,jmuizelaar
Comment 16 Nick Cameron [:nrc] 2012-06-13 21:29:48 PDT
Trying again to land: https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=8c1c326ed100

Note You need to log in before you can comment on or make changes to this bug.