Firefox 13 compile error: No rule to make target `../../../xpcom/idl-parser/ xpidl.py', needed

RESOLVED DUPLICATE of bug 736961

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 736961
6 years ago
6 years ago

People

(Reporter: wenew zhang, Unassigned)

Tracking

({verifyme})

13 Branch
x86
Windows 7
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: xpidl)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

download the source code firefox 13.tar.gz
under mozilla-build system build
./configure
make
then get this error



Actual results:

make[6]: *** No rule to make target `../../../xpcom/idl-parser/
xpidl.py', needed
 by `libs'.  Stop.
make[6]: Leaving directory `/z/mozilla-release/xpcom/typelib/xpidl'

make[5]: *** [export] Error 2
make[5]: Leaving directory `/z/mozilla-release/xpcom/typelib/xpidl'

make[4]: *** [export] Error 2
make[4]: Leaving directory `/z/mozilla-release/xpcom/typelib'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/z/mozilla-release/xpcom'
make[2]: *** [export_tier_platform] Error 2
make[2]: Leaving directory `/z/mozilla-release'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/z/mozilla-release'
make: *** [default] Error 2
(Reporter)

Updated

6 years ago
Keywords: verifyme
OS: Mac OS X → Windows 7
Whiteboard: xpidl
(Reporter)

Comment 1

6 years ago
It doesn't work either add MOZ_OBJDIR to mozconfig or user win32/release config file.
BTW,
./configure get error:
cl : Command line warning D9002 : ignoring unknown option '-print-multi-os-direc
tory'
cl : Command line error D8003 : missing source filename
configure: creating ./config.status
config.status: creating include/Makefile
config.status: creating include/ffi.h
config.status: creating Makefile
config.status: creating testsuite/Makefile
config.status: creating man/Makefile
config.status: creating libffi.pc
config.status: creating fficonfig.h
config.status: fficonfig.h is unchanged
config.status: linking src/x86/ffitarget.h to include/ffitarget.h
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing include commands
config.status: executing src commands
config/autoconf.mk is unchanged

Comment 2

6 years ago
Same failure here x86_64 linux.
Firefox-12 compiles flawless.
maybe bug 729752?

Comment 4

6 years ago
Do not think so, as it happens with a pristine archive with no sign of .pyc in the affected area.

Best i can tell it seems that MOZ_OBJDIR is being ignored.
Please verify there are no .pyc files anywhere ('find . -name "*.pyc"' should produce no results).  NOTE: that includes the source dirs, not just object dirs.

Everytime I've hit this error it was old pyc files (after some change a few months ago which changed some python stuff).

Comment 6

6 years ago
Could https://bugzilla.mozilla.org/show_bug.cgi?id=736961 be what is being observed?
(Reporter)

Comment 7

6 years ago
$ find . -name "*.pyc"
./config/expandlibs.pyc
./config/expandlibs_config.pyc
./config/Expression.pyc
./js/src/config/expandlibs.pyc
./js/src/config/expandlibs_config.pyc
./other-licenses/ply/ply/__init__.pyc
./other-licenses/ply/ply/lex.pyc
./other-licenses/ply/ply/yacc.pyc

Comment 8

6 years ago
No such problem any more if built outside the source tree in an separate build 
directory.

Up to Firefox-12 it was possible to build inside the source tree.

Thank you all for help and quick response.
(Reporter)

Comment 9

6 years ago
Please let me know howto fix,
Firefox 12 source code works fine,
only on firefox 13 got this error.
Mozilla-build last edition+VS c++ 2010

Comment 10

6 years ago
mkdir build; cd build;
../mozilla-release/configure --all-your-options ..; 
make; make install
(Reporter)

Comment 11

6 years ago
Thanks kladit@arcor.de,
i do as you say but get new error:

nsCycleCollectionParticipant.cpp
z:\mozilla-release\xpcom\glue\nsCycleCollectionParticipant.h(571) :
 fatal error C1084: Cannot read include file: 'z:\mozilla-release\x
pcom\glue\nscyclecollectionparticipant.h': Bad file descriptor
make[4]: *** [nsCycleCollectionParticipant.obj] Error 2
There is nsCycleCollectionParticipant.h but no nscyclecollectionparticipant.h on glue directory

Thanks All

Comment 12

6 years ago
Try to get the sources again.
There is no such bug in firefox-13.0.source.tar.bz2.

cksum firefox-13.0.source.tar.bz2
3949375785 79605635 firefox-13.0.source.tar.bz2


..
include "nsCycleCollectionParticipant.h"
..
"mozilla-release/xpcom/glue/nsCycleCollectionParticipant.cpp" line 38 of 105 --36%-- col 13

find mozilla-release -name "*rticipant.*" returns

mozilla-release/xpcom/glue/nsCycleCollectionParticipant.cpp
mozilla-release/xpcom/glue/nsCycleCollectionParticipant.h
mozilla-release/storage/test/unit/vacuumParticipant.js
mozilla-release/storage/test/unit/vacuumParticipant.manifest
mozilla-release/storage/public/mozIStorageVacuumParticipant.idl
(Reporter)

Comment 13

6 years ago
hi,i find download from ftp://ftp.mozilla.org/pub/firefox/releases/13.0/source/firefox-13.0.source.tar.bz2
all update on 1 june 2012

i take a default mozconfig below,

$ cat mozconfig
# This file specifies the build flags for Firefox.  You can use it by adding:
#  . $topsrcdir/browser/config/mozconfig
# to the top of your mozconfig file.
ac_add_options --enable-application=browser

after 10 hours make run,still get new error,
BTW,The same environment make FF 12 just 4-5 hours,
any reply is very apprecate
Thanks all

C:\Program Files\Microsoft Visual Studio 10.0\VC\Include\typeinfo(178) : warning
 C4275: non dll-interface class 'stdext::exception' used as base for dll-interfa
ce class 'std::bad_typeid'
        C:\Program Files\Microsoft Visual Studio 10.0\VC\Include\exception(218)
: see declaration of 'stdext::exception'
        C:\Program Files\Microsoft Visual Studio 10.0\VC\Include\typeinfo(177) :
 see declaration of 'std::bad_typeid'
z:\goseas10.0.2\build\dist\include\gfxFont.h(1980) : warning C4244: 'return' : c
onversion from 'double' to 'float', possible loss of data
ReadbackManagerD3D10.cpp
c:/mozilla-build/python/python2.7.exe -O z:/goSeas10.0.2/mozilla-release/build/c
l.py cl -FoReadbackManagerD3D10.obj -c -D_HAS_EXCEPTIONS=0 -I../../dist/stl_wrap
pers  -DIMPL_THEBES -DMOZ_ENABLE_D3D10_LAYER -DMOZILLA_INTERNAL_API -D_IMPL_NS_C
OM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XR
EAPI -DIMPL_NS_NET -DIMPL_THEBES  -DOSTYPE=\"WINNT6.1\" -DOSARCH=WINNT -DEXCLUDE
_SKIA_DEPENDENCIES  -DUNICODE -D_UNICODE -DNOMINMAX -D_CRT_RAND_S -DCERT_CHAIN_P
ARA_HAS_EXTRA_FIELDS -D_SECURE_ATL -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -D
OS_WIN=1 -DWIN32 -D_WIN32 -D_WINDOWS -DWIN32_LEAN_AND_MEAN  -DCOMPILER_MSVC -I..
/../../mozilla-release/ipc/chromium/src -I../../../mozilla-release/ipc/glue -I..
/../ipc/ipdl/_ipdlheaders  -I../../../mozilla-release/gfx/layers -I. -I../../dis
t/include -I../../dist/include/nsprpub  -Iz:/goSeas10.0.2/build/dist/include/nsp
r -Iz:/goSeas10.0.2/build/dist/include/nss        -TP -nologo -W3 -Gy -Fdgenerat
ed.pdb -wd4800 -we4553  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy -Iz:/goS
eas10.0.2/build/dist/include/cairo  -MD            -FI ../../dist/include/mozill
a-config.h -DMOZILLA_CLIENT /z/goSeas10.0.2/mozilla-release/gfx/layers/d3d10/Rea
dbackManagerD3D10.cpp
ReadbackManagerD3D10.cpp
C:\Program Files\Microsoft Visual Studio 10.0\VC\Include\stdlib.h(481) : fatal e
rror C1033: cannot open program database 'z:\goseas10.0.2\build\gfx\layers\gener
ated.pdb'
make[4]: *** [ReadbackManagerD3D10.obj] Error 2
make[4]: Leaving directory `/z/goSeas10.0.2/build/gfx/layers'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/z/goSeas10.0.2/build/gfx'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/z/goSeas10.0.2/build'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/z/goSeas10.0.2/build'
make: *** [default] Error 2

Comment 14

6 years ago
I also met same failure.
fc6 i386
gcc 4.1.2, python 2.7

Right after uncompressing tar.bz sources, xpcom/idl-parser/xpidl.py existed,
but after configuring and running make, it vanished.

configure option is
./configure --enable-application=browser --disable-necko-wifi --disable-elf-hack

Comment 15

6 years ago
In my case, this (https://groups.google.com/forum/#!topic/mozilla.dev.apps.firefox/o9FXYPnZu5A) patch works.
Component: Untriaged → Build Config
QA Contact: untriaged → build.config
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 736961
You need to log in before you can comment on or make changes to this bug.