Last Comment Bug 736961 - xpidl-parser/header.py delete itself
: xpidl-parser/header.py delete itself
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Linux
: -- normal with 1 vote (vote)
: mozilla15
Assigned To: Landry Breuil (:gaston)
:
Mentors:
: 735624 761900 (view as bug list)
Depends on: 754625
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 03:09 PDT by Jan Horak
Modified: 2012-06-26 09:50 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed patch (688 bytes, patch)
2012-03-19 03:17 PDT, Jan Horak
khuey: review-
Details | Diff | Review
use separate cachedir for all idl-parser calls (9.04 KB, patch)
2012-05-10 05:39 PDT, Landry Breuil (:gaston)
khuey: review+
Details | Diff | Review
use separate cachedir for all idl-parser calls (aurora backport) (9.04 KB, patch)
2012-05-11 01:37 PDT, Landry Breuil (:gaston)
no flags Details | Diff | Review
use separate cachedir for all idl-parser calls (beta backport) (5.53 KB, patch)
2012-05-11 01:40 PDT, Landry Breuil (:gaston)
no flags Details | Diff | Review

Description Jan Horak 2012-03-19 03:09:35 PDT
After changeset http://hg.mozilla.org/mozilla-central/rev/466c118c3e44 landed
header.py, xpidl.py and typelib.py is deleted when running 'make' in 'xpcom/idl-parser' subdir.

header.py was run by following command:
/usr/bin/python2.7 ../../config/pythonpath.py \
  -I../../other-licenses/ply \
  -I../../xpcom/idl-parser \
  ../../xpcom/idl-parser/header.py --cachedir=. --regen

This breaks building trunk tree in linux right now.
Comment 1 Jan Horak 2012-03-19 03:14:01 PDT
Setting --cachedir=. to --cachedir=cache fix this issue.
Comment 2 Jan Horak 2012-03-19 03:17:08 PDT
Created attachment 607102 [details] [diff] [review]
proposed patch
Comment 3 Takanori MATSUURA 2012-03-19 07:07:36 PDT
*** Bug 735624 has been marked as a duplicate of this bug. ***
Comment 4 Benjamin Smedberg [:bsmedberg] 2012-03-19 08:07:58 PDT
Comment on attachment 607102 [details] [diff] [review]
proposed patch

Yeah, the "no bug" checkin broke srcdir builds in a rather silly way. However, I recommend that you should never do srcdir build, please use an objdir.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-03-19 08:28:35 PDT
Comment on attachment 607102 [details] [diff] [review]
proposed patch

The cachedir here, the cachedir in config/rules.mk and js/src/config/rules.mk, and the cachedir used in various places in js/xpconnect/src/Makefile.in must be the same.
Comment 6 Jan Horak 2012-03-20 07:21:03 PDT
My patch doesn't work with objdir so my fix is rather wrong.
Comment 7 Takanori MATSUURA 2012-03-21 05:05:07 PDT
BTW, the latest ply-3.4 still "stupid"?
ply bundled with m-c is ply-3.3.
Comment 8 Chamal 2012-03-26 19:59:10 PDT
Is there a workaround to build firefox, until this bug gets fixed? :)
Comment 9 Jan Horak 2012-03-26 23:14:00 PDT
(In reply to Chamal from comment #8)
> Is there a workaround to build firefox, until this bug gets fixed? :)
By adding:
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-dir
to your mozconfig all object will be put into obj-dir and compilation will go smooth.
Comment 10 Landry Breuil (:gaston) 2012-05-10 01:06:29 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> Comment on attachment 607102 [details] [diff] [review]
> proposed patch
> 
> The cachedir here, the cachedir in config/rules.mk and
> js/src/config/rules.mk, and the cachedir used in various places in
> js/xpconnect/src/Makefile.in must be the same.

And in addition to that some paths around needs to be adjusted if 'cache' is added to cachedir, as for example xpidlex.py (at least) ends up under that dir.
Comment 11 Landry Breuil (:gaston) 2012-05-10 05:39:08 PDT
Created attachment 622693 [details] [diff] [review]
use separate cachedir for all idl-parser calls

This patches adresses comment #5 and allows me to build with objdir set and objdir=. (i think the latter mimics what happens with an src build). Not sure a clobber is needed. Kyle, do you think it's worth a try run ? Once it's r+ed and commited i'll ask for beta/aurora approval.
Comment 12 Landry Breuil (:gaston) 2012-05-10 13:36:48 PDT
https://tbpl.mozilla.org/?tree=Try&rev=a098af1a9683 just to be on the safe side.
Comment 13 Landry Breuil (:gaston) 2012-05-10 23:21:27 PDT
All green on try, setting checkin-needed
Comment 14 Landry Breuil (:gaston) 2012-05-11 01:37:49 PDT
Created attachment 623065 [details] [diff] [review]
use separate cachedir for all idl-parser calls (aurora backport)

[Approval Request Comment]
Regression caused by (bug #): No bug, blame khuey
User impact if declined: failure to build from source tarball without objdir
Testing completed (on m-c, etc.): in this bug
Risk to taking this patch (and alternatives if risky): other failures ?
String changes made by this patch: none
Comment 15 Landry Breuil (:gaston) 2012-05-11 01:40:56 PDT
Created attachment 623068 [details] [diff] [review]
use separate cachedir for all idl-parser calls (beta backport)

[Approval Request Comment]
Regression caused by (bug #): no bug, blame khuey
User impact if declined: failure to build from source tarball without separate objdir
Testing completed (on m-c, etc.): in this bug
Risk to taking this patch (and alternatives if risky): other build failures ?
String changes made by this patch: none

Other notes: this patch is not a hg changeset against mozilla-beta branch, but a patchset against 13.0b2 tarball. It allows me to build it using ./configure/make (so, without objdir), otherwise it fails with :

gmake[6]: Entering directory `/usr/obj/firefox-13.0beta2/mozilla-beta/xpcom/typelib/xpidl'
gmake[6]: *** No rule to make target `../../../xpcom/idl-parser/xpidl.py', needed by `libs'.  Stop.
Comment 16 Daniel Holbert [:dholbert] (largely AFK until June 28) 2012-05-11 11:18:13 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/eae1858ccc6d
Comment 17 Matt Brubeck (:mbrubeck) 2012-05-12 08:59:30 PDT
https://hg.mozilla.org/mozilla-central/rev/eae1858ccc6d
Comment 18 Landry Breuil (:gaston) 2012-05-14 02:50:54 PDT
Comment on attachment 623068 [details] [diff] [review]
use separate cachedir for all idl-parser calls (beta backport)

Unsetting approval for aurora/beta since it broke sdk builds (see bug #754625)
Comment 19 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-26 09:50:19 PDT
*** Bug 761900 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.