Closed Bug 761938 Opened 9 years ago Closed 2 years ago

Sync does not sync browser button locations and layout.

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 943182

People

(Reporter: adamhell, Unassigned)

Details

(Whiteboard: [sync-engine-addition])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120531155942

Steps to reproduce:

I customized the toolbar by a button to another location.


Actual results:

After syncing, the button location change did not update on other computers after syncing.


Expected results:

the button locations and preferences should have been synced.

IE things like button location, using large or small icons, and using labels under buttons.

This is somewhat related to https://bugzilla.mozilla.org/show_bug.cgi?id=626870

The behavior in the above bug would be moot if resetting the UI on one computer would reset it on all computers.
Thanks for the input, Adam.

I'm not sure this is on the radar for things we want to sync -- it wouldn't make sense to sync UI customizations between my 11" laptop and my 30" desktop screen, for example. Sync mainly concerns itself with browser data, not browser UI.

Thoughts, other folks?
Component: Firefox Sync: UI → Firefox Sync: Backend
QA Contact: sync-ui → sync-backend
Whiteboard: [sync-engine-addition]
Hello!

I believe that syncing the UI would be most useful. Richard is making a point here, but I believe there should be the option to sync the UI layout. Besides, the syncing is already split into categories (Addons, bookmarks, passwords, etc). If someone would like to leave out the UI layout he may have the option to do so.

I use two 15'' laptops, one desktop with 24'' display and a netbook, some of them with multiple OSs installed. I would like to have my UI layout synced as making the modifications manually is very time consuming and annoying. As for the netbook, I would like to have the option to not have layout synced, as Richard suggests.
 So, just to keep this idea alive, I'd like to add that it would be really nice to finally get layout synced, especially considering new customization options for FF57 nightly.
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox

Thanks for reporting this, and apologies that this went untriaged for seven (!) years! This looks like a dupe of bug 943182, so I'll go ahead and close this (and bug 1562434) in favor of that. Unfortunately, our team has been pretty swamped—while it's something we'd like to do, I can't give a timeline for when we might fix it. :-(

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 943182
You need to log in before you can comment on or make changes to this bug.