Last Comment Bug 761990 - On Windows the "Feedback" button's dropdown arrow overlaps the label
: On Windows the "Feedback" button's dropdown arrow overlaps the label
Status: RESOLVED FIXED
[qa+]
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 14 Branch
: x86 Windows XP
: -- normal (vote)
: Firefox 16
Assigned To: Dão Gottwald [:dao]
:
Mentors:
: 769845 (view as bug list)
Depends on:
Blocks: 735691
  Show dependency treegraph
 
Reported: 2012-06-06 04:48 PDT by Simona B [:simonab]
Modified: 2012-07-27 06:26 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
verified


Attachments
Screenshot of the "Feedback" button. (47.51 KB, image/jpeg)
2012-06-06 04:48 PDT, Simona B [:simonab]
no flags Details
patch (1.13 KB, patch)
2012-06-20 14:41 PDT, Dão Gottwald [:dao]
jaws: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Simona B [:simonab] 2012-06-06 04:48:20 PDT
Created attachment 630509 [details]
Screenshot of the "Feedback" button.

Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0

On Firefox 14 beta 6 the down arrow of the feedback button overlaps over the text. Also the button doesn't get highlighted when hovering the mouse over it.
The "Feedback" button is not properly displayed on Windows only. Looks fine on Mac and Ubuntu.
Comment 1 Alex Keybl [:akeybl] 2012-06-06 15:59:11 PDT
Can we test nightly updates with the Test Pilot add-on installed to try to find a regression window? Adding qawanted.
Comment 2 XtC4UaLL [:xtc4uall] 2012-06-10 07:37:05 PDT
(In reply to Alex Keybl [:akeybl] from comment #1)
Using the stand-alone Add-on I get no Feedback Button at all (neither in the Customization Palette) using Nightly Builds.

Btw, the Button and Hover-Effect is okay in Icons + Text Mode and small Icons Mode.
Comment 3 juan becerra [:juanb] 2012-06-12 13:36:01 PDT
I'll get some eyes on this.
Comment 4 Simona B [:simonab] 2012-06-13 05:28:02 PDT
I couldn't find the regression window on the Nightly branch because I couldn't get the 'Feedback' button (even with the Test Pilot add-on installed). 
Tried on the Aurora branch:

Regression range
Last good:
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120424 Firefox/13.0a2
http://hg.mozilla.org/releases/mozilla-aurora/rev/480c0fe7f591

First bad:
Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20120425 Firefox/14.0a2
http://hg.mozilla.org/releases/mozilla-aurora/rev/777c0bd7dd5d

push log
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=480c0fe7f591&tochange=777c0bd7dd5d
Comment 5 Simona B [:simonab] 2012-06-13 05:44:29 PDT
(In reply to XtC4UaLL [:xtc4uall] from comment #2)
> (In reply to Alex Keybl [:akeybl] from comment #1)
> Using the stand-alone Add-on I get no Feedback Button at all (neither in the
> Customization Palette) using Nightly Builds.
> 
> Btw, the Button and Hover-Effect is okay in Icons + Text Mode and small
> Icons Mode.

I can confirm that the overlap doesn't occur and the Hover-Effect is ok if the check-box 'Use Small Icons' is enabled in the Customize Toolbar dialog, regardless of the selected show type (Icons and text, Icons or Text).

The 'Feedback' button is not displayed properly only if the selected show type is 'Icons' and the check-box 'Use Small Icons' is disabled.
Comment 6 Simona B [:simonab] 2012-06-13 06:39:58 PDT
Issue is reproducible only on the Default Theme.
Comment 7 Alex Keybl [:akeybl] 2012-06-14 09:28:04 PDT
It's very weird to me that Bug 748475 is somehow implicated based upon comment 4. I'm including a couple folks who may be able to help investigate on the Firefox side, as well as on the add-on side.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-15 17:39:32 PDT
(In reply to Alex Keybl [:akeybl] from comment #7)
> It's very weird to me that Bug 748475 is somehow implicated based upon
> comment 4.

I don't see why comment 4 would suggest that. There are many other bugs in that range that are more likely to cause this than that bug.

http://hg.mozilla.org/releases/mozilla-aurora/rev/09750e764b6a may have had some unintended side effects, for example.

There are also a million gfx changes in that range, though most of those might be android-only.
Comment 9 Jared Wein [:jaws] (please needinfo? me) 2012-06-15 17:57:34 PDT
My gut guess is that bug 734373 is the cause for this.

I've seen my Cheevos addon acting funky (point total not clickable) after this patch landed but I have just planned to change how my button works so as to continue to make the text clickable.
Comment 10 Alex Keybl [:akeybl] 2012-06-19 10:30:52 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #8)
> (In reply to Alex Keybl [:akeybl] from comment #7)
> > It's very weird to me that Bug 748475 is somehow implicated based upon
> > comment 4.
> 
> I don't see why comment 4 would suggest that. There are many other bugs in
> that range that are more likely to cause this than that bug.

You're correct - the pushlog must have come up with only Bug 748475 for some reason. Sending over to Dao to investigate - I think a good first step would be to try to back out bug 734373 on a try build.
Comment 11 Dão Gottwald [:dao] 2012-06-19 11:20:01 PDT
There are two ways to address this: The Feedback add-on could stop using the toolbarbutton-1 class if it wants to customize the button style, or we could hack around text being forcefully displayed in buttons with the toolbarbutton-1 class while in icons-only mode.
Comment 12 Dão Gottwald [:dao] 2012-06-20 14:41:42 PDT
Created attachment 635072 [details] [diff] [review]
patch
Comment 13 Dão Gottwald [:dao] 2012-06-20 14:42:36 PDT
(In reply to Dão Gottwald [:dao] from comment #11)
> [...] or we could
> hack around text being forcefully displayed in buttons with the
> toolbarbutton-1 class while in icons-only mode.

The attached patch does that.
Comment 14 Gregg Lind (User Advocacy - Heartbeat - Test Pilot) 2012-06-21 11:23:36 PDT
This bug somehow missed me, but I am on it now.  I have a huge patch waiting to land, and I will get this figured out by tomorrow morning, and review what has happened so far.
Comment 15 Jared Wein [:jaws] (please needinfo? me) 2012-06-21 14:08:19 PDT
I tried installing the Test Pilot add-on and am unable to get a feedback button on my toolbar in Nightly (the same as comment #2).

Dao, can you let me know how you tested this patch?
Comment 16 Dão Gottwald [:dao] 2012-06-21 14:15:19 PDT
https://addons.mozilla.org/en-US/firefox/addon/proxy-selector/ provides a similar toolbar button which you can use for testing.
Comment 17 Jared Wein [:jaws] (please needinfo? me) 2012-06-21 14:55:28 PDT
I applied the patch and installed the proxy-selector add-on. When I added the Proxy Selector Button to the toolbar, all I see is the dropdown arrow:
http://screencast.com/t/zDqaVJXh
Comment 18 Dão Gottwald [:dao] 2012-06-21 20:22:11 PDT
The add-on provides multiple buttons. Just add them all. If none has a label, try opening a new window. Over here one of the buttons gets a "System Proxy" label.
Comment 19 Jared Wein [:jaws] (please needinfo? me) 2012-06-23 00:34:03 PDT
Comment on attachment 635072 [details] [diff] [review]
patch

Review of attachment 635072 [details] [diff] [review]:
-----------------------------------------------------------------

I added both the button and the dropdown but still get no visible label with the Proxy Selector add-on. This is on a different machine that I tested with for comment #17, but the same results. I opened new windows and restarted the browser but none of those attempts had any affect.

I then used DOM Inspector and saw that there was no label attribute set for the #mproxy-element-button. I set a label attribute (xbl:inherits=value=label on the nested <label>) and the text appeared. There's probably a bug with the Proxy Selector add-on, but that's not what this bug (#761990) is about.

Nonetheless, with the inserted text, the button looks correct but is missing the hover state and pressed state. That doesn't appear to be a cause of this bug and could be something again specific to the Proxy Selector add-on.

TL;DR, this patch looks good and should hopefully fix the text layout for the Feedback button.
Comment 20 Alex Keybl [:akeybl] 2012-06-23 18:22:08 PDT
Comment on attachment 635072 [details] [diff] [review]
patch

[Triage Comment]
We need this now so that we get the Feedback button back, in preparation for landing bug 686335 on Aurora/Beta.
Comment 21 Benjamin Smedberg [:bsmedberg] 2012-06-23 19:44:18 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/76748dfdf4ef
Comment 23 Ryan VanderMeulen [:RyanVM] 2012-06-24 20:08:07 PDT
https://hg.mozilla.org/mozilla-central/rev/c0f602b18c29
Comment 24 Gregg Lind (User Advocacy - Heartbeat - Test Pilot) 2012-06-25 08:31:12 PDT
I know this one is closed, but if anyone in this thread wants to give a tutorial in how to fix problems like this (especially working from OSX), that would be amazing :).  I know that I have a very hard time tracking down bugs on windows side, with my available tools (a window vm, the binary builds of aurora).
Comment 25 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-25 09:37:38 PDT
Looks fine to me in Firefox 14.0b9, marking verified.
Comment 26 Asa Dotzler [:asa] 2012-06-26 21:40:26 PDT
(In reply to Gregg Lind (User Research - Test Pilot) from comment #24)
> I know this one is closed, but if anyone in this thread wants to give a
> tutorial in how to fix problems like this (especially working from OSX),
> that would be amazing :).  I know that I have a very hard time tracking down
> bugs on windows side, with my available tools (a window vm, the binary
> builds of aurora).

Not sure it's enough, but I use the DOM Inspector to poke around Firefox chrome to find and test fixes for UI bits. https://addons.mozilla.org/en-US/firefox/addon/dom-inspector-6622/ Also, I'm sure there's a better tool but I'm oldschool like that ;)
Comment 27 Simona B [:simonab] 2012-06-29 00:26:00 PDT
Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0

The 'Feedback' button still does not get highlighted when hovering the mouse over it
- this happens when the selected show type is 'Icons' and the check-box 'Use Small Icons' is disabled.

The hover effect is ok in all the others customized combinations between 'Use Small Icons' and Show types (Icons and text, Icons or Text).
Comment 28 Jared Wein [:jaws] (please needinfo? me) 2012-06-29 11:47:23 PDT
(In reply to Simona B [QA] from comment #27)
> Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
> 
> The 'Feedback' button still does not get highlighted when hovering the mouse
> over it
> - this happens when the selected show type is 'Icons' and the check-box 'Use
> Small Icons' is disabled.

Is there a bug on file for this yet? If not, can you file one for this Simona?
Comment 29 XtC4UaLL [:xtc4uall] 2012-06-30 12:01:10 PDT
*** Bug 769845 has been marked as a duplicate of this bug. ***
Comment 30 Simona B [:simonab] 2012-07-02 09:07:40 PDT
(In reply to Jared Wein [:jaws] from comment #28
> Is there a bug on file for this yet? If not, can you file one for this
> Simona?

Filed Bug 770207.
Comment 31 Simona B [:simonab] 2012-07-27 06:26:29 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0

Verified on Windows 7 and Windows XP using Firefox 15 beta 2 that the "Feedback" button's dropdown arrow doesn't overlaps the label.

Note You need to log in before you can comment on or make changes to this bug.