The default bug view has changed. See this FAQ.

crash in nsFileStreamBase::MaybeOpen , Startup crash with WebMail Notifier

RESOLVED FIXED in mozilla16

Status

()

Core
XPCOM
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Alice0775 White, Assigned: darktrojan)

Tracking

({crash, regression, topcrash})

16 Branch
mozilla16
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

fix
1.60 KB, patch
Ben Turner (not reading bugmail, use the needinfo flag!)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-6f65bec3-398a-49c9-8966-b98182120606 .
============================================================= 
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/6338a8988917
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120606030528

Startup crash with WebMail Notifier https://addons.mozilla.org/ja/firefox/addon/webmail-notifier/


Steps to Reproduce:

1. Start Browser with new profile
2. Install WebMail Notifier https://addons.mozilla.org/ja/firefox/addon/webmail-notifier/
3. Restart

Actual Results:  
  Crashes

Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/a567f52fa0d8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120605163217
Crashes:
http://hg.mozilla.org/mozilla-central/rev/a15d75939cd5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120605191018
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a567f52fa0d8&tochange=a15d75939cd5

Triggered by:
a15d75939cd5	Geoff Lankow — Bug 749930 - Replace uses of nsILocalFile with nsIFile (compiled code only); r=bsmedberg
(Reporter)

Comment 1

5 years ago
Windows7 : bp-5cd8598f-4a12-41c9-bbb0-238cd2120606
Ubuntu10.04: bp-96d030ba-31e3-4449-9ab2-a50922120606
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
This used to use do_QueryInterface to make it null safe. Now that has been removed.
Crash Signature: [@ nsFileStreamBase::MaybeOpen(nsIFile*, int, int, bool)] → [@ nsFileStreamBase::MaybeOpen(nsIFile*, int, int, bool)] [@ nsFileStreamBase::MaybeOpen]
Crash Signature: [@ nsFileStreamBase::MaybeOpen(nsIFile*, int, int, bool)] [@ nsFileStreamBase::MaybeOpen] → [@ nsFileStreamBase::MaybeOpen(nsIFile*, int, int, bool)] [@ nsFileStreamBase::MaybeOpen] [@ nsFileStreamBase::DoOpen ]

Comment 3

5 years ago
There are about 150 crashes an hour.
tracking-firefox16: --- → ?
Keywords: topcrash

Updated

5 years ago
Crash Signature: [@ nsFileStreamBase::MaybeOpen(nsIFile*, int, int, bool)] [@ nsFileStreamBase::MaybeOpen] [@ nsFileStreamBase::DoOpen ] → [@ nsFileStreamBase::MaybeOpen(nsIFile*, int, int, bool)] [@ nsFileStreamBase::MaybeOpen] [@ nsFileStreamBase::DoOpen()] [@ nsFileStreamBase::DoOpen]
Hardware: x86 → All
(Assignee)

Comment 4

5 years ago
Created attachment 630754 [details] [diff] [review]
fix

Also cleans up a stray nsresult.
Attachment #630754 - Flags: review?(bent.mozilla)
Comment on attachment 630754 [details] [diff] [review]
fix

The old code returned NS_ERROR_UNEXPECTED if the QI failed. Who knows if anyone depends on it, but please leave it that way.

r=me with that change.
Attachment #630754 - Flags: review?(bent.mozilla) → review+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c779db92fef2
Assignee: nobody → geoff
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
Duplicate of this bug: 762257

Updated

5 years ago
Duplicate of this bug: 762355
tracking-firefox16: ? → ---
You need to log in before you can comment on or make changes to this bug.