warwar.gif animated GIF halts after after ~10 seconds

VERIFIED FIXED in M11

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: elig, Assigned: pnunn)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
* TITLE/SUMMARY
warwar.gif animated GIF halts after after ~10 seconds

[adapted from old BugSplat bug #87155]

* STEPS TO REPRODUCE
0) Launch Apprunner
1) View http://www.prometheus-music.com/gecko/warwar.gif [snarfed from http://
www.gifanimations.com/images1/warwar.gif]

* RESULT
 - What happened

After about 10 seconds of animation, the animation halts about 4 seconds after
the rightwards travelling lightning bolt, and remains frozen at that frame. The
frame at which it halts differs from execution to execution, but it's always
around that space.

The throbber & progress bar continue to animate [even after 90 minutes.]

 - What was expected

Behavior equivalent to Communicator 4.x and IE 5.


* REGRESSION

 - Occurs On
        Mac OS Apprunner (6.1.99 AM optimized build)
        Linux Apprunner (6.2.99 AM optimized build)
        Win32 Apprunner (6.4.99 AM optimized build)


 - Doesn't Occur On
        Communicator 4.6 RTM (Mac OS 99124 & Win32 99127)
        Internet Explorer 5 RTM (Win32)


* CONFIGURATIONS TESTED

- [Mac] Power Mac 8500/120 (233 Mhz 604e), 64 MB RAM (VM on; 1 MB of VM used),
1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 Mhz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 Mhz P2), 96 MB RAM.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
I came across something really similar to this at http://www.javascript.com. It
looks to me as though animated gif's are not looping. Could this have been
broken in an attempt to fix bug #5030, in which they hit the server each time
they loop?

This is on 1999070308 on Win '98.
(Assignee)

Comment 2

20 years ago
I hate this. A new bug has cropped up that
causes a crash (access violation) before this
bug can be addressed.
I'll enter a new bug and make this one dependent on it.
-pn
(Assignee)

Updated

20 years ago
Depends on: 11761
Target Milestone: M9 → M10
(Assignee)

Comment 3

20 years ago
The new bug is described in bug#11761.
-pn
(Assignee)

Comment 4

20 years ago
This animated gif is displaying fine now on nt.
I'll be testing the other platforms.
-pn
(Assignee)

Updated

20 years ago
Target Milestone: M10 → M11
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

20 years ago
*** This bug has been marked as a duplicate of 1031 ***
(Reporter)

Comment 6

20 years ago
Umm...what in particular is the common bug? In this case, it's not crashing after
a full iteration, but I (thought) was crashing after a particular, and
potentially corrupted frame.
(Assignee)

Updated

20 years ago
Status: RESOLVED → REOPENED
(Assignee)

Comment 7

20 years ago
odd. This worked yesterday. After yesterday's changes
it stops working.
I'll reopen.
-pn

Updated

20 years ago
Resolution: DUPLICATE → ---

Comment 8

20 years ago
Clearing DUPLICATE resolution due to reopen.
(Assignee)

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

20 years ago
hey. I really fixed it this time.
really.
-pn
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

20 years ago
Verified fixed on Mac OS [8.6], Win32 [NT 4.0 SP3], Linux [Red Hat 6.0/GNOME],
using 1999092208 builds.

Linux crashes after a minute, but that's another bug.
You need to log in before you can comment on or make changes to this bug.