Closed Bug 1031 Opened 22 years ago Closed 20 years ago

Animation stops

Categories

(Core Graveyard :: GFX, defect, P2)

x86
Windows 95
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: marni894, Assigned: pnunn)

References

()

Details

Attachments

(1 file)

The animation displayed on the page should be rotating infinitly. It does not
with the NGLayout win32 19981008 nigly build.

Tested on my AMD K6 with 64MB RAM, 1024x768 in 24-bits true colour.
*** Bug 1030 has been marked as a duplicate of this bug. ***
Assignee: michaelp → pnunn
Status: ASSIGNED → NEW
i put breaks in every case of the switch at the bottom of nsImageRequest.cpp
and at a certain point i just stop getting notifications before the image is
really done. it appears to be a problem internal to the imagelib or netlib.
i've also seen the problem under NT and with different color depths so none of
that seems to matter.
Status: NEW → ASSIGNED
Sounds like a cache (probably image cache not net cache) problem.
I'll look into it.
-pn
Still takes place on 1.27.99 build; checked Win32 and Mac OS 8.5.
Setting all current Open/Normal to M4.
QA Contact: 1698
[adding self as QA contact]
Target Milestone: M4 → M5
pnunn's not here for the m4 endgame. moving to m5
Assignee: pnunn → gagan
Status: ASSIGNED → NEW
I'm still seeing this bug. I get a running list of HandleEvent 322,300,323
and the stack is coming from PR_Sleep, NET_ProcessNet.
It is starting to sound like a netlib related bug. Gagan? could
you take a look at this?
thanks, pn.
Deffered till Necko lands...
Deferring till Necko lands...
Per DP's suggestion marking these till M8. Though Necko lands with M7, we will
be able to verify it for M8.
I'm moving this to target M9, Necko will be enabled somewhere during late M8 or
early M9.  We will need to get on this and it cannot be postponed past the M9
milestone.
Assignee: gagan → pnunn
Status: ASSIGNED → NEW
This looks more like an imagelib problem. Pam could you verify this? (with
Necko) Thx.
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
the test url no longer exists.
I tested another page of animated gifs and they continue
animating.
I'm marking worksforme.
-pn
Someone thought it was a good idea to install DOS on hda. He did backup hdb
first.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
ok. I rechecked it (now I have downloaded the image so I'll have it
always.) and the image loops infinitely. (ok. so I didn't check it
for _infinite_, but it definitely loops many many times.

I noticed a slight pause at the beginning of each loop. I will address
that issue else where.
-pn
It does not work for me with build 1999080508. The logo takes one spin and then
stops. There is never a document done message and the throbber never stops.
Visiting pages after visiting ng3.html never yields a document done message,
although they all seems to load ok. Looking directly at the image
(puma.pugo.org/moz/98.doitspin.gif) shows a few frames before apprunner freezes.
I do get a document done this time.
Tested on my AMD K6 with 64MB RAM, 1152x864 24bits graphic, Windows 98
(4.10.1998) with no network patches that I am aware of (not even IE5).
Status: RESOLVED → REOPENED
Target Milestone: M9 → M11
Thanks for the extra info. It helps.

This might be related to a low memory condition.
I'm reopening it, but setting the milestone to m11.
-pn
Resolution: WORKSFORME → ---
*** Bug 7622 has been marked as a duplicate of this bug. ***
I thought I saved a copy of this image. The test url no
longer works. Anyone got a copy of it?
-pn
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
ok.
I just fixed a certain class of gif images and
this image may fit into that class...but I can't
find a test image to check.

We may have to close this bug as invalid (or something)
if we can't verify the fix.
-pn
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Re-opening, on 1999.09.28 8:00 AM builds. Image animation halts after ~10-20
seconds on all platforms, leaving Win32/Mac displaying the image URL, and Linux
crashed.
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → DUPLICATE
This is a duplicate of 14181.
I'm working on it.
-pn

*** This bug has been marked as a duplicate of 14181 ***
Status: RESOLVED → VERIFIED
Rubber-stamping as duplicate, with a note to self to double-check this issue when
verifying 14181.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Re-opening. While 14181 is fixed, this animation ceases after about 1 minute on
Mac, 3 minutes on Linux, and 4 minutes on Win32. (using 233-266 Mhz G3 & P2
systems.)
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → DUPLICATE
I'm marking this as duplicate as #6409 has more info in the
description field.
-p

*** This bug has been marked as a duplicate of 6409 ***
Status: RESOLVED → VERIFIED
Rubber-stamping verified as duplicate; left note in 6409 to confirm that this is
fixed (and all other dupes) when verifying it.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Re-opening; this is still occuring on the 2000011310 Mac OS build. (and the image
file has no fixed iterations specified)
Since reopened, moving from M11 to M13....but will this be fixed by tonight?  If
not, please move to M14, and elig please supply a release note for M13.
Target Milestone: M11 → M13
Target Milestone: M13 → M15
Eli,

Is this happening only on Mac? Are windows and linux ok?

Neeti
Target Milestone: M15 → M14
Still occurs on all platforms, using the 1.27.00 builds.
*** Bug 24540 has been marked as a duplicate of this bug. ***
[Note to self: be sure to verify duplicates of this bug upon its resolution.]
I think this bug is a side effect of another odd
interaction with necko that I am tracing down in
other bugs. I'm not marking it as a dupe, to keep
the test case on my radar. I am pushing it out to
m15 so I can focus on the bugs I think are the original
case of the problem.
-pn
Target Milestone: M14 → M15
I have been running this animation for more than 24 hrs and it has not stopped 
on linux, mac and NT.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Verified fixed on 3.28.00 Win32/Mac OS/Linux builds. After 10 minutes, I'm not
seeing any adverse effects. (Since Neeti has run it for 24 hours, I'll leave it
at that.)

Wrote 33742 ("Can't switch applications if displaying animated GIF") as part of
verifying this bug.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.