Last Comment Bug 762206 - Use nsScriptErrorEvent when firing error events on window objects
: Use nsScriptErrorEvent when firing error events on window objects
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
Mentors:
Depends on:
Blocks: 726378
  Show dependency treegraph
 
Reported: 2012-06-06 12:49 PDT by Ben Turner (not reading bugmail, use the needinfo flag!)
Modified: 2012-06-29 11:53 PDT (History)
3 users (show)
khuey: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (56.15 KB, patch)
2012-06-27 08:59 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
jonas: review+
Details | Diff | Splinter Review

Description Ben Turner (not reading bugmail, use the needinfo flag!) 2012-06-06 12:49:38 PDT
We fire a plain Event at them now, but that doesn't unwrap properly when hitting window.onerror. The fix is to use nsScriptErrorEvent.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-27 08:59:09 PDT
Created attachment 637147 [details] [diff] [review]
Patch
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-28 08:00:08 PDT
Comment on attachment 637147 [details] [diff] [review]
Patch

Review of attachment 637147 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with that fixed

::: dom/indexedDB/IDBObjectStore.cpp
@@ +1464,5 @@
>    if (!IsWriteAllowed()) {
>      return NS_ERROR_DOM_INDEXEDDB_READ_ONLY_ERR;
>    }
>  
> +  nsRefPtr<IDBRequest> request = GenerateRequest(this, nsnull);

Why null here?
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-28 08:12:25 PDT
Because that function is only called in the parent process when doing IPC indexedDB, so there's no script information to get.
Comment 4 Jonas Sicking (:sicking) No longer reading bugmail consistently 2012-06-29 06:13:56 PDT
Bent explained why things work the way they do. Nothing to see here, move along. r+ stands.
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-29 11:53:38 PDT
https://hg.mozilla.org/mozilla-central/rev/939191463ed4

Note You need to log in before you can comment on or make changes to this bug.