Body of message is empty if specific encoding is used inside the body

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
6 years ago
8 months ago

People

(Reporter: Olafur Gudmundsson, Unassigned)

Tracking

({testcase-wanted})

17 Branch
x86_64
Windows 7
testcase-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Opera/9.80 (Windows NT 6.1; WOW64; U; Edition United States Local; en) Presto/2.10.229 Version/11.64

Steps to reproduce:

I replied to a message from a colleague and wrote lots of comments on his message.



Actual results:

My reply had an empty body, when I checked my send folder the body was empty there as well. 
When editing the message instead of showing my colleague last name as a Hoenes I see a black diamond with a ? inside it. 
(Same thing happened with version 12, but I do not recall this happening before) 


Expected results:

The emails should have gone out.
After some trial and error the issue is when firefox sees my colleague last name in a message body upon send (not during edit and save) it truncates the message. 
When I reply to a message the name is pulled out the From: field.
Here is the From field in question 
   --- 
      From: Alfred =?hp-roman8?B?SM5uZXM=?= <ah@TR-Sys.de>

The hp-roman8 encoding seems to give Firefox problems, I know he should not be using it.

Updated

6 years ago
Summary: Body of message is empty if certain encoding is used inside the body → Body of message is empty if specific encoding is used inside the body

Comment 1

6 years ago
Olafur, 
1. can you reproduce this problem?
2. can you attach ("Add an attachment") sample message to the bug report please
Keywords: testcase-wanted

Updated

6 years ago
Whiteboard: [closeme 2012-07-08]

Comment 2

6 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-07-08]

Comment 3

5 years ago
I'm seeing this exact same problem.

On Windows 7 I just installed davmail to access MS Exchange server with imap and smtp. Seems to work perfectly.

Then installed Thunderbird 17.0.2 and connected it to the davmail server with imap, smtp and ldap. Reading inbox and all saved messages works well.

But replying to some messages in my sent messages folder results in empty message bodies being sent. A few important messages seem to trigger this. The messages were created using Outlook but content seems to be a few pages of text which I included in the reply. The reply turns out empty to recipients and also in the sent messages local mailbox.

How should I debug this further? I can't share these mails but can provide header details.

Updated

5 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
Version: 13 → 17

Comment 4

9 months ago
Is this still present in latest Thunderbird version?
Flags: needinfo?(ogud)
Flags: needinfo?(mikko.rapeli)
Whiteboard: [closeme 2017-05-15]

Comment 5

8 months ago
Resolved per whiteboard
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago8 months ago
Flags: needinfo?(ogud)
Flags: needinfo?(mikko.rapeli)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-05-15]
You need to log in before you can comment on or make changes to this bug.