Prompts to save unmodified message forward draft

RESOLVED FIXED in Thunderbird 20.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Jonathan Kamens, Assigned: Magnus Melin)

Tracking

({regression})

13 Branch
Thunderbird 20.0
regression
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird14-, thunderbird15-, thunderbird16+, thunderbird17+, thunderbird19 fixed, thunderbird-esr1718+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
If I click the Forward button on a message, and then immediately try to close the window, TB asks me if I want to save it.

I'm fairly certain this is new behavior. If I haven't modified the draft after clicking the Forward button, then it shouldn't be prompting me, and I don't think it has in the past.

I'm marking this as a regression. Feel free to remove the keyword if I'm wrong about the previous behavior, but I don't think I am.

Comment 1

5 years ago
TB Daily 13.0a1 build from March 3 doesn't ask on close.
TB 13.0 beta 1 (April 25) *does* ask to save as draft.

Also applies to Linux x86_64, composing in HTML mode.
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted
tracking-thunderbird14: --- → ?
tracking-thunderbird14: ? → -
tracking-thunderbird15: --- → +
tracking-thunderbird15: + → -
tracking-thunderbird16: --- → +
tracking-thunderbird17: --- → +
(Assignee)

Comment 2

5 years ago
Regression window http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-03-21&enddate=2012-03-22. 

Bug 736055 looks like the most likely cause, or possibly bug 650776.
Keywords: regressionwindow-wanted
Hmm, I'm pretty sure there's some sort of hack or work around to "reset" the editor when we start up the compose window, I'm hoping someone might be able to remember where that is.

Comment 4

5 years ago
Well, the typical sequence goes like this (error checking removed for sanity)

m_editor->EnableUndo(false);
/* do stuff here */
m_editor->EnableUndo(true);
SetBodyModified(false);

SetBodyModified(false) is a wrapper around m_editor->ResetModificationCount();
tracking-thunderbird18: --- → +
tracking-thunderbird-esr17: --- → 18+
(Assignee)

Comment 5

5 years ago
I've got a fix for this, just need to improve the tests for it.
Assignee: nobody → mkmelin+mozilla
(Assignee)

Comment 6

5 years ago
Created attachment 684934 [details] [diff] [review]
proposed fix
Attachment #684934 - Flags: review?(mconley)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

5 years ago
Created attachment 684935 [details] [diff] [review]
proposed fix, v2

Sorry, forgot a qrefresh... this is the final version
Attachment #684934 - Attachment is obsolete: true
Attachment #684934 - Flags: review?(mconley)
Attachment #684935 - Flags: review?(mconley)
(Assignee)

Updated

5 years ago
Blocks: 736055
Comment on attachment 684935 [details] [diff] [review]
proposed fix, v2

Review of attachment 684935 [details] [diff] [review]:
-----------------------------------------------------------------

I'm good with this. Thanks Magnus!
Attachment #684935 - Flags: review?(mconley) → review+
(Assignee)

Comment 9

4 years ago
http://hg.mozilla.org/comm-central/rev/65f054d50891 -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 20.0
(Assignee)

Comment 10

4 years ago
Comment on attachment 684935 [details] [diff] [review]
proposed fix, v2

Review of attachment 684935 [details] [diff] [review]:
-----------------------------------------------------------------

Do we want this for esr?
Attachment #684935 - Flags: approval-comm-esr17?
Comment on attachment 684935 [details] [diff] [review]
proposed fix, v2

[Triage Comment]
Yes, I think we should take it for ESR. We'll also land on aurora ready for the next beta.
Attachment #684935 - Flags: approval-comm-esr17?
Attachment #684935 - Flags: approval-comm-esr17+
Attachment #684935 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/988edf8b927b
status-thunderbird19: --- → fixed
tracking-thunderbird18: + → ---
https://hg.mozilla.org/releases/comm-esr17/rev/3546a1cdce58
status-thunderbird-esr17: --- → fixed
You need to log in before you can comment on or make changes to this bug.