Last Comment Bug 762891 - IonMonkey: Fix ss-fannkuch phi specialization
: IonMonkey: Fix ss-fannkuch phi specialization
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-06-08 06:54 PDT by Jan de Mooij [:jandem]
Modified: 2012-06-09 04:58 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.91 KB, patch)
2012-06-08 07:52 PDT, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-06-08 06:54:50 PDT
Another ss-fannkuch problem. There's a bunch of LValueToInt32 instructions caused by suboptimal phi specialization in some edge cases.
Comment 1 Jan de Mooij [:jandem] 2012-06-08 07:52:11 PDT
Created attachment 631391 [details] [diff] [review]
Patch

GuessPhiType tries to guess the type of the phi based on the operand types. If all operands are phis we still have to visit, GuessPhiType returns MIRType_None.

The patch ensures we never propagate MIRType_None to other phis. We have to wait until we know one of the operand types and then we can propagate the type.

This + bug 762887 should make ss-fannkuch a bit faster, but especially x86 needs more work.
Comment 2 Jan de Mooij [:jandem] 2012-06-09 04:58:14 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/beabf74b228d

Note You need to log in before you can comment on or make changes to this bug.