Last Comment Bug 763014 - crash in PresShell::HandleEventInternal
: crash in PresShell::HandleEventInternal
Status: VERIFIED FIXED
: crash, regression, reproducible, topcrash
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: 16 Branch
: All All
-- critical (vote)
: mozilla16
Assigned To: Olli Pettay [:smaug]
:
: Andrew Overholt [:overholt]
Mentors:
: 763379 771424 (view as bug list)
Depends on:
Blocks: 761572
  Show dependency treegraph
 
Reported: 2012-06-08 12:30 PDT by Jason Smith [:jsmith]
Modified: 2012-08-07 02:22 PDT (History)
14 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified


Attachments
WIP (1.27 KB, patch)
2012-06-10 03:45 PDT, Olli Pettay [:smaug]
mats: review+
gavin.sharp: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image Jason Smith [:jsmith] 2012-06-08 12:30:18 PDT
This bug was filed from the Socorro interface and is 
report bp-dc3575ac-70a4-4df5-bd0f-f31332120608 .
============================================================= 

Steps:

1. Startup Nightly
2. Double-click the top portion of the firefox window

Result - Crash, reproducible.
Comment 1 User image Jason Smith [:jsmith] 2012-06-08 12:32:24 PDT
What developer would be the right person to look at a a click-event based bug with the top window (resizing the firefox window)? What bugzilla component does this belong in?
Comment 2 User image IU 2012-06-08 13:23:28 PDT
Regression range:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=30fc3d3e10d3&tochange=332ed5402ccf

Looks like bug 761572

Crashing Thread
Frame 	Module 	Signature 	Source
0 	xul.dll 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:6408
1 	xul.dll 	PresShell::HandleEventWithTarget 	layout/base/nsPresShell.cpp:6149
2 	xul.dll 	nsEventStateManager::CheckForAndDispatchClick 	content/events/src/nsEventStateManager.cpp:4411
3 	xul.dll 	nsEventStateManager::PostHandleEvent 	content/events/src/nsEventStateManager.cpp:3181
Comment 3 User image Marcia Knous [:marcia - use ni] 2012-06-08 13:53:41 PDT
I can reproduce this with a clean profile using the latest nightly on Windows. Jason mentioned he had a few extensions, so I checked with a clean profile just to make sure.
Comment 5 User image Logan Rosen [:Logan] 2012-06-08 20:04:43 PDT
I can't reproduce this with a clean profile on Windows 7 with the latest 20120608 nightly build.
Comment 6 User image Alice0775 White 2012-06-08 21:10:56 PDT
I can reproduce with clean/new profile bp-70c0e66f-1d67-43ad-8d0c-927a42120609

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120608081921

Crash when double click top/left/right/bottom window border if disabled Menubar.
Crash when double click Titlebar and left/right/bottom window border if enabled Menubar.
Comment 7 User image Logan Rosen [:Logan] 2012-06-08 21:16:06 PDT
Oh, yep, reproduced with that more specific summary. Thanks Alice!
Comment 8 User image Scoobidiver (away) 2012-06-09 00:46:15 PDT
It's #1 top crasher in today's build with about 35 crashes per hour.
Comment 9 User image IU 2012-06-09 07:15:24 PDT
Why does everyone keep setting version to 16 Branch?  The bug causing this landed on Trunk only; therefore, only Trunk is affected.
Comment 10 User image Scoobidiver (away) 2012-06-09 08:09:13 PDT
(In reply to IU from comment #9)
> Why does everyone keep setting version to 16 Branch?  The bug causing this
> landed on Trunk only; therefore, only Trunk is affected.
The trunk version moves every six weeks, so if the bug is fixed lately, how do you know you must uplift the patch to Aurora or even Beta?
The version where it first appeared AND the regression keyword tells you which version is or will be affected.
Comment 11 User image Jet Villegas (:jet) 2012-06-09 11:03:38 PDT
To tn for the backout or repair
Comment 12 User image Timothy Nikkel (:tnikkel) 2012-06-09 16:55:43 PDT
I'm not working on this right now.
Comment 13 User image IU 2012-06-09 17:00:49 PDT
Since roc is away til the 19th, how about backing out Bug 761572 till he gets back?
Comment 14 User image Olli Pettay [:smaug] 2012-06-10 03:45:04 PDT
Created attachment 631730 [details] [diff] [review]
WIP

https://tbpl.mozilla.org/?tree=Try&rev=d4d67b932886

Could anyone test the tryserver builds.
They will be in http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/
Look for d4d67b932886
Comment 15 User image Olli Pettay [:smaug] 2012-06-10 07:36:36 PDT
Builds are here http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/opettay@mozilla.com-d4d67b932886/

(I don't know how to reproduce this bug on Linux, so any with Windows, please test.)
Comment 16 User image IU 2012-06-10 08:24:54 PDT
(In reply to Olli Pettay [:smaug] from comment #15)
> (I don't know how to reproduce this bug on Linux, so any with Windows,
> please test.)

That fixes the crash for me
Comment 17 User image Jason Smith [:jsmith] 2012-06-10 13:09:50 PDT
(In reply to IU from comment #16)
> (In reply to Olli Pettay [:smaug] from comment #15)
> > (I don't know how to reproduce this bug on Linux, so any with Windows,
> > please test.)
> 
> That fixes the crash for me

Same with me.
Comment 18 User image Mats Palmgren (:mats) 2012-06-10 14:32:44 PDT
Comment on attachment 631730 [details] [diff] [review]
WIP

r=mats
Comment 19 User image Olli Pettay [:smaug] 2012-06-10 14:46:51 PDT
https://hg.mozilla.org/mozilla-central/rev/f6242d0169f0
Comment 20 User image Scoobidiver (away) 2012-06-11 03:22:37 PDT
*** Bug 763379 has been marked as a duplicate of this bug. ***
Comment 21 User image Mats Palmgren (:mats) 2012-06-11 15:17:03 PDT
Comment on attachment 631730 [details] [diff] [review]
WIP

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 761572
User impact if declined: crash, we need this on aurora when bug 761572 lands there
Testing completed (on m-c, etc.): on m-c since 2012-06-10
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Comment 22 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-14 13:40:12 PDT
Comment on attachment 631730 [details] [diff] [review]
WIP

Mats, can you land this on aurora along with bug 761572?
Comment 24 User image Alice0775 White 2012-07-05 23:38:13 PDT
*** Bug 771424 has been marked as a duplicate of this bug. ***
Comment 25 User image Paul Silaghi, QA [:pauly] 2012-08-07 02:22:46 PDT
(In reply to Alice0775 White from comment #6)
> I can reproduce with clean/new profile
> bp-70c0e66f-1d67-43ad-8d0c-927a42120609
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
> ID:20120608081921
> 
> Crash when double click top/left/right/bottom window border if disabled
> Menubar.
> Crash when double click Titlebar and left/right/bottom window border if
> enabled Menubar.

Able to see the crash on Nightly 20120608081921.
Verified fixed on FF 15b3 on Win 7/64, Ubuntu 12.04 and Mac OS X 10.6.

Note You need to log in before you can comment on or make changes to this bug.