Fallback to built-in decoders when gst is enabled but does not support codec

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
P5
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: MSal, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
When building with gstreamer enabled. Opus support relies on the required Opus gst plugin being installed.

If Opus support should be made available in all setups. A fallback to the built-in libopus should be provided.
If we do this, we should fall back for any supported format gstreamer can't decode.
Indeed. Everything what is supported internally should be used when GStreamer is enabled but cannot decode.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Summary: Fallback to built-in libopus when gst is enabled and the required Opus gst plugin is not installed → Fallback to built-in decoders when gst is enabled but does not support codec
Duplicate of this bug: 776374
Component: Audio/Video → Audio/Video: Playback
Priority: -- → P5
gstreamer is going in bug 1234092
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.