java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$FilePickerResultHandler.handleActivityResult(GeckoApp.java)

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

({crash})

14 Branch
Firefox 16
All
Android
crash
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 wontfix, firefox15 fixed, firefox16 fixed, blocking-fennec1.0 -)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

There is a crash in 14.0b6 on this line:
http://hg.mozilla.org/releases/mozilla-beta/file/7054a9e24f11/mobile/android/base/GeckoApp.java#l2726

Crash report at bp-5200426d-13e8-4297-9e19-42b8c2120609.

This bug was spawned off https://bugzilla.mozilla.org/show_bug.cgi?id=758854#c11
Created attachment 631668 [details] [diff] [review]
Patch
Attachment #631668 - Flags: review?(blassey.bugs)

Updated

5 years ago
Severity: normal → critical
Keywords: crash
Whiteboard: [native-crash]
Attachment #631668 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/9c11efe87662
blocking-fennec1.0: --- → ?
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → fixed
Target Milestone: --- → Firefox 16
https://hg.mozilla.org/mozilla-central/rev/9c11efe87662
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED

Updated

5 years ago
Crash Signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$FilePickerResultHandler.handleActivityResult(GeckoApp.java) ]
blocking-fennec1.0: ? → -
Comment on attachment 631668 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 741284
User impact if declined: Potentially a crash when using a filepicker and not picking a file. The crash might only happen when using a 3rd-party file picker.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): mobile-only, low risk
String or UUID changes made by this patch: none

Nom'ing for both aurora and beta since it's a really safe patch. However, it's a rare crash, so might only be worth uplifting to aurora.
Attachment #631668 - Flags: approval-mozilla-beta?
Attachment #631668 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 631668 [details] [diff] [review]
Patch

[Triage Comment]
Since this is a rare crash, let's only land on Aurora.
Attachment #631668 - Flags: approval-mozilla-beta?
Attachment #631668 - Flags: approval-mozilla-beta-
Attachment #631668 - Flags: approval-mozilla-aurora?
Attachment #631668 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/440a35cc1ebc
status-firefox14: affected → wontfix
status-firefox15: affected → fixed
You need to log in before you can comment on or make changes to this bug.