Last Comment Bug 763365 - Launching an installed web application with no supported version of Firefox installed for web apps results in a not so useful error message to the user
: Launching an installed web application with no supported version of Firefox i...
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Web Apps (show other bugs)
: unspecified
: All Linux
: P3 normal
: Firefox 16
Assigned To: Marco Castelluccio [:marco]
: Jason Smith [:jsmith]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 18:48 PDT by Jason Smith [:jsmith]
Modified: 2016-02-04 15:00 PST (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (1.24 KB, patch)
2012-07-03 15:34 PDT, Marco Castelluccio [:marco]
myk: review+
Details | Diff | Splinter Review

Description Jason Smith [:jsmith] 2012-06-10 18:48:58 PDT
Steps:

1. Install a Nightly build with support for linux web apps
2. Launch it and install a web application
3. Launch and close that web application
4. Uninstall that Nightly build and ensure that no build in the system has support for linux web apps
5. Launch the web application

Expected:

A "useful" error message should be reported indicating to the user that they need to have a Firefox build of FF 15 or higher to be able to launch web applications on Linux.

Actual:

A not-so-useful error message is thrown to the user - "Couldn't find application.ini file." This isn't good, as we really should be throwing useful error messages at the user.
Comment 1 Marco Castelluccio [:marco] 2012-06-11 03:07:52 PDT
Jason, what's the error message in the Windows and Mac version?
Comment 2 Jason Smith [:jsmith] 2012-06-11 07:45:44 PDT
(In reply to Marco Castelluccio from comment #1)
> Jason, what's the error message in the Windows and Mac version?

On Windows:

WebappRT

This app requires that Firefox version 14 or above is installed. Firefox 14+ has not been detected.

Note - The version number here is incorrect here, but you get the idea. Should say 15 instead of 14 (which I'll file a bug on that now...)
Comment 3 Marco Castelluccio [:marco] 2012-06-13 09:06:47 PDT
(In reply to Jason Smith [:jsmith] from comment #2)
> (In reply to Marco Castelluccio from comment #1)
> > Jason, what's the error message in the Windows and Mac version?
> 
> On Windows:
> 
> WebappRT
> 
> This app requires that Firefox version 14 or above is installed. Firefox 14+
> has not been detected.
> 
> Note - The version number here is incorrect here, but you get the idea.
> Should say 15 instead of 14 (which I'll file a bug on that now...)

What do you think of "Couldn't find application.ini file. Have you uninstalled or moved Firefox to another directory?"
Comment 4 Jason Smith [:jsmith] 2012-06-13 09:51:20 PDT
(In reply to Marco Castelluccio from comment #3)
> (In reply to Jason Smith [:jsmith] from comment #2)
> > (In reply to Marco Castelluccio from comment #1)
> > > Jason, what's the error message in the Windows and Mac version?
> > 
> > On Windows:
> > 
> > WebappRT
> > 
> > This app requires that Firefox version 14 or above is installed. Firefox 14+
> > has not been detected.
> > 
> > Note - The version number here is incorrect here, but you get the idea.
> > Should say 15 instead of 14 (which I'll file a bug on that now...)
> 
> What do you think of "Couldn't find application.ini file. Have you
> uninstalled or moved Firefox to another directory?"

I'd just go with the same message that Windows uses.
Comment 5 Marco Castelluccio [:marco] 2012-06-13 18:03:01 PDT
CCing Myk as he said we should find a better way to report these problems (on Linux, Win and Mac).
Comment 6 Myk Melez [:myk] [@mykmelez] 2012-06-20 10:10:26 PDT
Indeed, we should find a better way.  But that's a longer term project, and it shouldn't prevent us from making iterative improvements to the messages in the meantime.  So let's keep this bug focused on bringing the Linux message up to par with the Windows and Mac ones.
Comment 7 Marco Castelluccio [:marco] 2012-07-03 15:34:14 PDT
Created attachment 638891 [details] [diff] [review]
Patch
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-05 18:28:52 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/962af4981b64

Note You need to log in before you can comment on or make changes to this bug.