crash in nsHttpConnection::OnReadSegment @ icf with McAfee filter

RESOLVED DUPLICATE of bug 671468

Status

()

Core
Networking: HTTP
--
critical
RESOLVED DUPLICATE of bug 671468
6 years ago
3 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash})

14 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
It's #97 top browser crasher in 14.0b6.
The stack is different from the one in bug 726114.

Here are correlations per module:
icf.dll@0x1fc0|EXCEPTION_ACCESS_VIOLATION_READ (24 crashes)
    100% (24/24) vs.   0% (70/23847) ICF.dll(McAfee filter 6.0.244.0)

Signature 	icf.dll@0x1fc0 More Reports Search
UUID	ffdc7860-da63-4248-8e4c-963b82120610
Date Processed	2012-06-10 19:20:22
Uptime	3029
Last Crash	5.4 days before submission
Install Age	50.5 minutes since version was first installed.
Install Time	2012-06-10 18:29:31
Product	Firefox
Version	14.0
Build ID	20120605113340
Release Channel	beta
OS	Windows NT
OS Version	6.0.6002 Service Pack 2
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 23 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x1c923000
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x06e0, AdapterSubsysID: 00000000, AdapterDriverVersion: 8.15.11.8627
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- 
EMCheckCompatibility	True	
Total Virtual Memory	4294836224
Available Virtual Memory	3689705472
System Memory Use Percentage	42
Available Page File	10043154432
Available Physical Memory	3699445760

Frame 	Module 	Signature 	Source
0 	ICF.dll 	ICF.dll@0x1fc0 	
1 	ICF.dll 	ICF.dll@0x13608 	
2 	ntdll.dll 	RtlEnterCriticalSection 	
3 	ws2_32.dll 	WahReferenceContextByHandle 	
4 	ws2_32.dll 	DSOCKET::GetCountedDSocketFromSocketNoExport 	
5 	ICF.dll 	ICF.dll@0x39daf 	
6 	ICF.dll 	ICF.dll@0x1535f 	
7 	ICF.dll 	ICF.dll@0x19a1f 	
8 	ICF.dll 	ICF.dll@0x2398f 	
9 	nspr4.dll 	_MD_CURRENT_THREAD 	nsprpub/pr/src/md/windows/w95thred.c:308
10 	nspr4.dll 	_MD_CURRENT_THREAD 	nsprpub/pr/src/md/windows/w95thred.c:308
11 	mozglue.dll 	arena_chunk_tree_dirty_remove 	memory/jemalloc/jemalloc.c:3088
12 	mozglue.dll 	arena_malloc_large 	memory/jemalloc/jemalloc.c:4153
13 	nspr4.dll 	PR_ExitMonitor 	nsprpub/pr/src/threads/prmon.c:132
14 	xul.dll 	nsPipeEvents::~nsPipeEvents 	xpcom/io/nsPipe3.cpp:621
15 	ws2_32.dll 	send 	
16 	nspr4.dll 	SocketWrite 	nsprpub/pr/src/io/prsocket.c:701
17 	xul.dll 	nsSocketOutputStream::Write 	netwerk/base/src/nsSocketTransport2.cpp:587
18 	xul.dll 	nsHttpConnection::OnReadSegment 	netwerk/protocol/http/nsHttpConnection.cpp:1190
19 	xul.dll 	nsHttpPipeline::ReadFromPipe 	netwerk/protocol/http/nsHttpPipeline.cpp:682
20 	xul.dll 	nsPipeInputStream::ReadSegments 	xpcom/io/nsPipe3.cpp:799
21 	xul.dll 	nsHttpPipeline::ReadSegments 	netwerk/protocol/http/nsHttpPipeline.cpp:726
22 	xul.dll 	nsHttpConnection::OnSocketWritable 	netwerk/protocol/http/nsHttpConnection.cpp:1251
23 	xul.dll 	nsHttpConnection::OnOutputStreamReady 	netwerk/protocol/http/nsHttpConnection.cpp:1530
24 	xul.dll 	nsHttpConnection::Activate 	netwerk/protocol/http/nsHttpConnection.cpp:396
25 	xul.dll 	nsHttpConnectionMgr::DispatchTransaction 	netwerk/protocol/http/nsHttpConnectionMgr.cpp:1512
26 	xul.dll 	nsHttpConnectionMgr::nsHalfOpenSocket::OnOutputStreamReady 	netwerk/protocol/http/nsHttpConnectionMgr.cpp:2481
27 	xul.dll 	nsSocketOutputStream::OnSocketReady 	netwerk/base/src/nsSocketTransport2.cpp:525
28 	xul.dll 	nsSocketTransport::OnSocketReady 	netwerk/base/src/nsSocketTransport2.cpp:1568
29 	xul.dll 	nsSocketTransportService::DoPollIteration 	netwerk/base/src/nsSocketTransportService2.cpp:762
30 	xul.dll 	nsSocketTransportService::Run 	netwerk/base/src/nsSocketTransportService2.cpp:645
31 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:656
32 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:289
33 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
34 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
35 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
36 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
37 	kernel32.dll 	BaseThreadInitThunk 	
38 	ntdll.dll 	__RtlUserThreadStart 	
39 	ntdll.dll 	_RtlUserThreadStart

More reports at:
https://crash-stats.mozilla.com/report/list?signature=icf.dll%400x1fc0
Depends on: 671468
I think this is a dup of 671468.. The pipeline changes in FF14 have changed the stack a little bit, but the underlying pattern is still the same. not a new issue.

Comment 2

6 years ago
On my system, the ICF.dll (Internet Content Filter) is the Safe Eyes DLL from InternetSafety.com and *NOT* a McAfee product!  I am getting multiple crashes per week for this one issue.  ICF.dll version is 6,0,244,0

(Oh rats - I just opened InternetSafety.com and Firefox crashed again!)

Comment 3

6 years ago
(In reply to Bill Barto from comment #2)
> On my system, the ICF.dll (Internet Content Filter) is the Safe Eyes DLL
> from InternetSafety.com and *NOT* a McAfee product!  I am getting multiple
> crashes per week for this one issue.  ICF.dll version is 6,0,244,0

I see that Safe Eyes actually is a McAfee product now.  Sorry for any confusion. -Bill
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671468
You need to log in before you can comment on or make changes to this bug.