Closed Bug 671468 Opened 9 years ago Closed 4 years ago

Firefox crash @ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) (Correlation to Спутник @Mail.Ru and Yandex.Bar)

Categories

(Core :: Networking: HTTP, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1222933
Tracking Status
firefox10 + ---
firefox11 + ---

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Seen while reviewing 5.0 and 6.0 crash stats. https://crash-stats.mozilla.com/report/list?signature=nsSocketOutputStream::Write%28char%20const*,%20unsigned%20int,%20unsigned%20int*%29 to the report which are across all versions up to 7.0a2.

Top addon correlation is the Yandex bar: 24% (17/71) vs.   4% (1774/43809) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
https://crash-stats.mozilla.com/report/index/23395b1d-bc4a-4b82-a3b9-1443f2110713

Frame 	Module 	Signature [Expand] 	Source
0 		@0x7d5bd40 	
1 	xul.dll 	nsSocketOutputStream::Write 	netwerk/base/src/nsSocketTransport2.cpp:576
2 	xul.dll 	nsHttpConnection::OnReadSegment 	netwerk/protocol/http/nsHttpConnection.cpp:557
3 	xul.dll 	nsHttpTransaction::ReadRequestSegment 	netwerk/protocol/http/nsHttpTransaction.cpp:444
4 	xul.dll 	nsStringInputStream::ReadSegments 	xpcom/io/nsStringStream.cpp:284
5 	xul.dll 	nsHttpTransaction::ReadSegments 	netwerk/protocol/http/nsHttpTransaction.cpp:469
6 	xul.dll 	nsHttpConnection::OnSocketWritable 	netwerk/protocol/http/nsHttpConnection.cpp:593
7 	xul.dll 	nsHttpConnection::OnOutputStreamReady 	netwerk/protocol/http/nsHttpConnection.cpp:805
8 	xul.dll 	nsSocketOutputStream::OnSocketReady 	netwerk/base/src/nsSocketTransport2.cpp:515
9 	xul.dll 	nsSocketTransport::OnSocketReady 	netwerk/base/src/nsSocketTransport2.cpp:1588
10 	xul.dll 	nsSocketTransportService::DoPollIteration 	netwerk/base/src/nsSocketTransportService2.cpp:682
11 	xul.dll 	nsSocketTransportService::OnProcessNextEvent 	netwerk/base/src/nsSocketTransportService2.cpp:546
12 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:582
13 	xul.dll 	NS_ProcessPendingEvents_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:200
14 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:250
15 	xul.dll 	nsSocketTransportService::Run 	netwerk/base/src/nsSocketTransportService2.cpp:589
16 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
17 	xul.dll 	nsRunnable::Release 	obj-firefox/xpcom/build/nsThreadUtils.cpp:55
18 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
19 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
20 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
21 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
22 	kernel32.dll 	BaseThreadStart
Any reason we know that this is networking:websockets, and not HTTP?
Component: Networking: WebSockets → Networking: HTTP
QA Contact: networking.websockets → networking.http
Jason: Sorry, I filed it in the incorrect component.

(In reply to comment #1)
> Any reason we know that this is networking:websockets, and not HTTP?
Correlations show:

66% (35/53) vs.   4% (1301/30457) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}
58% (31/53) vs.   5% (1443/30457) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)

Similar issue was just filed in Bug 706686 with correlations to the same two items.
2801 crashes in 9.0.1 in the last week.
It's #8 top browser crasher in 9.0.1.
Keywords: topcrash
Summary: Firefox crash @ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) Firefox crash @ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) → Firefox crash @ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) (Correlation to Спутник @Mail.Ru and Yandex.Bar) Firefox crash @ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) (Correlation to Спутник @Ma…
Tracking for 10 and 11. Adding qawanted to try to get STR. From https://bugzilla.mozilla.org/show_bug.cgi?id=671468#c4 it looks like we should start with mail.ru and Yandex (possibly a localization-related issue?).
Keywords: qawanted
Sending over to Anthony to find somebody to try to get STR.
Assignee: nobody → anthony.s.hughes
Any correlation to bug 715725, filed yesterday by a volunteer tester.
(In reply to Marcia Knous [:marcia] from comment #4)
> 66% (35/53) vs.   4% (1301/30457) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}
This is Java Console, just FYI.

> 58% (31/53) vs.   5% (1443/30457) yasearch@yandex.ru (Yandex.Bar,
> https://addons.mozilla.org/addon/3495)
This points to an old version of YandexBar (4.2.2) which is not compatible with 9.0.1

That said, using Java Console 6.0.30 and YandexBar 4.2.2 on Firefox 9.0.1 en-US WinXP, I've been unable to reproduce this. I've gone to mail.ru and been clicking around (unfortunately flying blind since I don't understand russian).
One other thing I noticed, the Yandex Toolbar that results from installing the incompatible add-on is completely empty (it's just a grey box with no buttons).
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #11)
> One other thing I noticed, the Yandex Toolbar that results from installing
> the incompatible add-on is completely empty (it's just a grey box with no
> buttons).

Updating to the compatible version, 5.2.3, has corrected my toolbar issues.
As of yet have been unable to reproduce this crash, either with Firefox 9.0.1 en-US or Firefox 9.0.1 ru. However, none of my testing has occurred with authenticated sessions as I don't have a Yandex account nor do I have sufficient understanding of Russian to be able to fill out the registration form.
latest correlations for 9.0.1: Looks as if we can install

Спутник @Mail.Ru
2.4.0.49
true
{37964A3C-4EE8-47b1-8321-34DE2C39BA4D} we may have better luck reproducing it.

nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)|EXCEPTION_ACCESS_VIOLATION_READ (539 crashes)

     91% (490/539) vs.   6% (3137/52250) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}
     62% (334/539) vs.   7% (3799/52250) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
     42% (228/539) vs.  10% (5267/52250) jqs@sun.com (Java Quick Starter, http://java.sun.com/javase/downloads/)
     15% (81/539) vs.   2% (1044/52250) {19503e42-ca3c-4c27-b1e2-9cdb2170ee34} (FlashGot, https://addons.mozilla.org/addon/220)
     14% (73/539) vs.   2% (1206/52250) {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389} (Download Statusbar, https://addons.mozilla.org/addon/26)
     12% (67/539) vs.   1% (659/52250) elemhidehelper@adblockplus.org (Adblock Plus: Element Hiding Helper, https://addons.mozilla.org/addon/4364)
     11% (58/539) vs.   1% (335/52250) {54BB9F3F-07E5-486c-9B39-C7398B99391C} (Text Link, https://addons.mozilla.org/addon/1939)
     10% (56/539) vs.   1% (483/52250) {3d7eb24f-2740-49df-8937-200b1cc08f8a} (Flashblock, https://addons.mozilla.org/addon/433)
     14% (75/539) vs.   5% (2514/52250) {20a82645-c095-46ed-80e3-08825760534b} (Microsoft .NET Framework Assistant, http://www.windowsclient.net/)
     10% (55/539) vs.   1% (746/52250) {dc572301-7619-498c-a57d-39143191b318} (Tab Mix Plus, https://addons.mozilla.org/addon/1122)
     19% (103/539) vs.  10% (5415/52250) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
      8% (45/539) vs.   0% (220/52250) {cd617375-6743-4ee8-bac4-fbf10f35729e} (RightToClick, https://addons.mozilla.org/addon/12572)
      9% (51/539) vs.   2% (978/52250) {1018e4d6-728f-4b20-ad56-37578a4de76b} (Flagfox, https://addons.mozilla.org/addon/5791)
     10% (53/539) vs.   3% (1313/52250) {e4a8a97b-f2ed-450b-b12d-ee082ba24781} (Greasemonkey, https://addons.mozilla.org/addon/748)
      8% (43/539) vs.   1% (358/52250) rambler_toolbar@rambler.ru (Rambler-Assistant for Firefox, https://addons.mozilla.org/addon/6360)
      8% (41/539) vs.   0% (247/52250) {582195F5-92E7-40a0-A127-DB71295901D7} (Gmail Manager, https://addons.mozilla.org/addon/1320)
      7% (37/539) vs.   1% (268/52250) SkipScreen@SkipScreen (SkipScreen, https://addons.mozilla.org/addon/11243)
      7% (38/539) vs.   1% (370/52250) dmremote@westbyte.com
      7% (38/539) vs.   1% (397/52250) dmpluginff@westbyte.com
      8% (43/539) vs.   2% (963/52250) {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7} (WOT, https://addons.mozilla.org/addon/3456)
      6% (33/539) vs.   1% (334/52250) dmbarff@westbyte.com
      6% (31/539) vs.   1% (357/52250) smarterwiki@wikiatic.com (FastestFox - Browse Faster, https://addons.mozilla.org/addon/9825)
The version currently available from http://sputnik.mail.ru/ seems to be 2.5.2.21. Am wondering if users upgrade to that version that it will remedy the crash.
(In reply to Marcia Knous [:marcia] from comment #15)
> The version currently available from http://sputnik.mail.ru/ seems to be
> 2.5.2.21. Am wondering if users upgrade to that version that it will remedy
> the crash.

Would it be possible to reach out to some users who reported crashes?
CCing Kev.

Kevin, could you reach out to Yandex to see if there is something on their end?
cc'ing Yandex Bar maintainer. Danil, can you please take a look?
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #16)
> (In reply to Marcia Knous [:marcia] from comment #15)
> > The version currently available from http://sputnik.mail.ru/ seems to be
> > 2.5.2.21. Am wondering if users upgrade to that version that it will remedy
> > the crash.
> 
> Would it be possible to reach out to some users who reported crashes?

CC'ing Cheng. Of course the users will be speaking Russian though, soooo ;)
This signature is #7 in 9.* at 28 crashes per million users in yesterday's data.
This is still sitting pretty high on on the top crash list for 9.0.1. This doesn't block 10 but we should more aggressively try outreach since it's still a top crash. Can we get a hold of someone at Yandex to help?
Kev reached out to Yandex about these issues yesterday morning.
FWIW, beside Russian there are some comments in Indonesian language.
Crash Signature: [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) ] → [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)]
This is #12 in 10.0.2 topcrashes and #15 on 11.0b3 right now, could we look into that?
Adding another signature I am seeing showing up in 10.0.2 - [@ PR_GetHostByAddr ].

Correlations to this signature:

76% (52/68) vs.   6% (3577/60364) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}
51% (35/68) vs.   8% (4571/60364) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
Crash Signature: [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] → [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ PR_GetHostByAddr ]
(In reply to Alex Keybl [:akeybl] from comment #22)
> Kev reached out to Yandex about these issues yesterday morning.

Any response yet? It's been a couple of days.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #26)
> (In reply to Alex Keybl [:akeybl] from comment #22)
> > Kev reached out to Yandex about these issues yesterday morning.
> 
> Any response yet? It's been a couple of days.

I'm one of Yandex.Bar developers. What actually can we do to help you fix this problem?
Max: I haven't been able to reproduce the issue by installing the toolbar. Has anyone on your side been able to reproduce the crash?

(In reply to Max from comment #27)
> (In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #26)
> > (In reply to Alex Keybl [:akeybl] from comment #22)
> > > Kev reached out to Yandex about these issues yesterday morning.
> > 
> > Any response yet? It's been a couple of days.
> 
> I'm one of Yandex.Bar developers. What actually can we do to help you fix
> this problem?
Marcia: First of all testing should be done on the latest addon version (6.5), which is used by the absolute majority of our users. It can be found here: http://bar.yandex.com/firefox/. BTW, it has english locale.
I couldn't reproduce this problem either. Although, we didn't do much specific testing, because the addon is in the QA process almost continuously, and we haven't seen such random crashes lately.

(In reply to Marcia Knous [:marcia] from comment #28)
> Max: I haven't been able to reproduce the issue by installing the toolbar.
> Has anyone on your side been able to reproduce the crash?
Recent Yandex Bar versions seem less affected according to 10.0.2 correlations:
     51% (184/359) vs.   6% (3532/61524) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}
          0% (1/359) vs.   0% (2/61524) 2.5.2.8
          0% (1/359) vs.   0% (19/61524) 2.5.2.20
         50% (179/359) vs.   5% (3371/61524) 2.5.2.32
          1% (3/359) vs.   0% (104/61524) 2.5.2.42
     32% (115/359) vs.   7% (4524/61524) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
          0% (1/359) vs.   0% (3/61524) 5.2.3
          0% (1/359) vs.   0% (1/61524) 5.2.4
          0% (1/359) vs.   0% (8/61524) 5.4
         29% (105/359) vs.   6% (3540/61524) 6.5.0
          1% (3/359) vs.   0% (89/61524) 6.5.1
          1% (4/359) vs.   1% (855/61524) 6.6
I don't quite understand this table. Which version causes most crashes then?
(In reply to Max from comment #31)
> I don't quite understand this table. Which version causes most crashes then?
The one that is the most installed, but it's not the crashiest:
* Спутник @Mail.Ru:
2.5.2.32: one crash every 19 days
2.5.2.42: one crash every 34 days
* Yandex Bar:
6.5.0: one crash every 33 days
6.5.1: one crash every 30 days
6.6: one crash every 213 days

Do you have an automatic update feature so that we can blocklist old versions?
(In reply to Scoobidiver from comment #32)
> (In reply to Max from comment #31)
> Do you have an automatic update feature so that we can blocklist old
> versions?

We use Fx addons update system. But there are users who prefer older versions of Yandex.Bar and/or Firefox for some reasons. The oldest YB version compatible with Fx-9.0 is 6.1. It was released in the late October 2011 - not so long ago.
So which versions do you suggest to ban? Which are the most crashy?
(In reply to Max from comment #33)
> So which versions do you suggest to ban?
The problem is that correlated doesn't mean caused by. JavaQuick Starter is for instance correlated to crashes on Windows XP, Yandex Bar is correlated to Russian users.
> Which are the most crashy?
Versions 6.5.0 and 6.5.1 are the crashiest one, but those who automatically upgrade their add-ons have less risk to crash, independently from the YB version.
(In reply to Scoobidiver from comment #34)
> (In reply to Max from comment #33)
Then I don't see a reason to ban at all. If there were exact versions causing stable crashes, banning them could help somehow. Banning 6.5, 6.6 is not an option - these are simply the most installed versions. I suppose the statistical correlation is caused only by the popularity of addon, not the problems in its code. We do not use binary libraries, only the interpreted code. Besides, as I can see, there are plenty of crash reports from systems without YB installed, so the crashes reason itself is definitely in the browser core.
Tested this on Firefox Nightly (13) with version 6.5 of yandex toolbar located here: http://bar.yandex.com/firefox/. Tried login, used the search engine, accessing various utilities with Yandex (e.g. mail), and clicked some of the other buttons on the toolbar. Results - I did not see a crash occur.
(In reply to Max from comment #35)
> Besides, as I can see, there are plenty of crash reports from systems
> without YB installed, so the crashes reason itself is definitely in the
> browser core.

Given that suspicion, sending over to our engineers to provide their insight. Honza - do you agree that this is an in-product issue instead of a Yandex issue? What can we do to get to the bottom of this bug without STR?
Assignee: anthony.s.hughes → honzab.moz
Josh - can we find somebody to take a look at this bug? We're trying to confirm Max's suspicion in comment#35 that this is a problem in our product.
Assignee: honzab.moz → joshmoz
Keywords: qawanted
I can look at this tomorrow, just a ping would be sufficient ;)
Assignee: joshmoz → honzab.moz
(In reply to Honza Bambas (:mayhemer) from comment #39)
> I can look at this tomorrow, just a ping would be sufficient ;)

I realized you may not be the right person to take a look at this (forgot my reasoning for sending to you in the first place). Thanks for taking a look!
Definitely not related to Yandex.

I more think this is geographically oriented.  Some page invokes some events that lead to this crash in this (unrelated) code.

Do we have access to URL of a visited web page from crash reports?  It may be interesting to check on that.

At the moment I unfortunately don't have any suspicion what this could be.

I can even see reports from 3.0.

I remember some duplicate bugs of this one, too quit mysterious, w/o any obvious clues to narrow the cause down.
Keywords: needURLs
$ gunzip --stdout /data/security_group/crash_urls/20120307-crashdata.csv.gz | awk -W compat -F\t '$1 ~ /nsSocketOutputStream::Write/ {print $2}' | sort | uniq -c | sort -nr|more
    124 \N
     59 
     53 about:blank
     16 http://www.facebook.com/
     14 http://www.google.ru/
     13 http://vk.com/feed
     11 http://www.odnoklassniki.ru/
      7 http://www.google.com.ua/
      7 https://www.facebook.com/
      7 about:home
      6 jar:file:///C:/Program%20Files/Mozilla%20Firefox/omni.jar!/chrome/browser/content/browser/aboutSessionRestore.xhtml
      6 http://www.google.com.eg/
      5 jar:file:///C:/Program%20Files/Mozilla%20Firefox/omni.jar!/chrome/browser/content/browser/aboutHome.xhtml
      5 http://www.odnoklassniki.ru/game/nl
      5 http://vk.com/im
      5 https://mail.google.com/mail/?shva=1#inbox
      5 http://164.100.112.65/netnrega/demand_new.aspx
      4 http://www.odnoklassniki.ru/game/zm
      4 http://www.odnoklassniki.ru/?ffsputnik=1
      4 http://www.google.com.ua/search?q=%D0%B2+%D0%B0%D0%B2%D0%B0%D1%80%D0%B8%D0%B8+%D0%BF%D0%BE%D0%B3%D0%B8%D0%B1+%D0%B3%D0%BE%D0%BB%D0%BE%D0%B2%D0%B0+%D1%81%D0%B5%D0%BB%D1%8C+%D1%81%D0%BE%D0%B2%D0%B5%D1%82%D0%B0+%D0%9A%D0%B8%D1%97%D0%B2%D1%81%D1%8C%D0
BA%D0%B
      4 http://www.google.com/
      4 http://vk.com/friends
      4 http://video.yandex.ru/#search?text=%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%20%D0%BA%D1%83%D0%BB%D0%B8%D0%BD%D0%B0%D1%80%D0%B8%D1%8F%20%D1%80%D1%84&where=all&filmId=39358244-11-12&p=2
      4 https://mail.yandex.ru/neo2/#inbox
      3 wyciwyg://1/https://mail.google.com/mail/?ui=2&view=bsp&ver=ohhl4rw8mbn4
      3 http://yandex.ua/yandsearch?p=1&text=12+%D0%B3%D1%80%D1%83%D0%B4%D0%BD%D1%8F+2007+%D1%80%D1%96%D0%BA+%D0%B0%D0%B2%D0%B0%D1%80%D1%96%D1%8F&lr=143&tld=ua
      3 http://www.yandex.ru/
      3 http://www.speedtest.net/
      3 http://vk.com/feed?section=posts
      3 https://mail.google.com/mail/u/0/?shva=1#inbox
      3 http://internet.yandex.ru/
      3 http://en-us.start3.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official
      3 http://164.100.112.65/netnrega/workalloc.aspx
      2 wyciwyg://5/https://mail.google.com/mail/?ui=2&view=bsp&ver=ohhl4rw8mbn4
      2 "javascript:"""""
      2 http://yandex.ua/yandsearch?text=%D0%91%D1%96%D0%BB%D0%B0+%D0%A6%D0%B5%D1%80%D0%BA%D0%B2%D0%B0+%D0%94%D0%A2%D0%9F+12.12.2007+%D1%80%D1%96%D0%BA+&clid=46510&tld=ua&lr=143
      2 http://yandex.ru/yandsearch?text=%D1%81%D0%B0%D0%BB%D0%B0%D1%82+%D1%86%D0%B0%D1%80%D0%B8%D1%86%D0%B0+%D0%B2%D0%BE%D1%81%D1%82%D0%BE%D0%BA%D0%B0&lr=213
      2 http://yandex.ru/yandsearch?text=%D0%BE%D1%80%D0%B3%D0%B0%D0%BD%D0%B8%D0%B7%D0%B0%D1%86%D0%B8%D1%8F+%D1%81%D0%B5%D1%80%D0%B2%D0%B8%D1%81%D0%B0+%D0%BF%D0%BE+%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B8+%D0%93%D0%91%D0%9E&clid=37000&lr=48
      2 http://yandex.ru/yandsearch?text=%D0%BC%D0%B0%D0%B3%D0%B0%D0%B7%D0%B8%D0%BD+%D0%BC%D0%B5%D0%B3%D0%B0+%D0%B2+%D0%BC%D0%BE%D1%81%D0%BA%D0%B2%D0%B5+%D1%82%D0%B5%D0%BF%D0%BB%D1%8B%D0%B9+%D1%81%D1%82%D0%B0%D0%BD&clid=48648&lr=213
      2 http://yandex.ru/yandsearch?p=1&text=%D1%80%D0%B5%D0%BB%D0%B5&clid=46510&lr=191
      2 http://yandex.ru/yandsearch?p=1&text=%D0%BB%D0%B8%D1%82%D1%83%D1%80%D0%B3%D0%B8%D1%8F.+%22%D0%9E+%D1%82%D0%B5%D0%B1%D0%B5+%D1%80%D0%B0%D0%B4%D1%83%D0%B5%D1%82%D1%81%D1%8F%22.%D0%B3%D1%80%D0%B5%D1%87%D0%B5%D1%81%D0%BA%D0%B8%D0%B9+%D1%80%D0%B0%D1%81
D0%BF%D
      2 http://www.web.de/
      2 http://www.skylancers.net/addNew11.aspx
      2 http://www.odnoklassniki.ua/guests
      2 http://www.odnoklassniki.ru/profile/334146485099
      2 http://www.lmw.co.in/espares/QuotesPage.aspx
      2 http://www.google.com.pk/
      2 http://www.google.co.in/
      2 http://www.google.cl/
      2 http://www.footballded.com/
      2 http://www.fast-torrent.ru/video/search/B/12.html
      2 http://www.facebook.com/logout.php
      2 http://www.facebook.com/index.php?stype=lo&lh=Ac-BHeOp1FjH3L6i
      2 http://www.esetnod32.ru/.download/
      2 http://vk.com/mail
      2 http://vk.com/al_index.php?act=auth_frame
      2 http://video.yandex.ru/#search?text=%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE%20%D0%BA%D1%83%D0%BB%D0%B8%D0%BD%D0%B0%D1%80%D0%B8%D1%8F%20%D1%80%D1%84&where=all&filmId=11945052-07-12&p=2
      2 https://www.miniprix.ro/produse/departament-haine-dama/tag/pagina-4
      2 https://www.facebook.com/?ref=tn_tnmn
      2 https://www.facebook.com/login.php?login_attempt=1
      2 https://twitter.com/#!/
      2 http://speedtest.net/
      2 https://mail.yandex.ru/neo2/
      2 https://login.vk.com/
      2 https://live.fonbet.com/livebets/?locale=ru
      2 http://forum.worldoftanks.ru/index.php?/topic/303325-%D0%B2%D0%B5%D1%81%D1%82%D0%BD%D0%B8%D0%BA-%D0%B0%D0%B4%D0%BC%D0%B8%D0%BD%D0%B8%D1%81%D1%82%D1%80%D0%B0%D1%86%D0%B8%D0%B8-%D0%BE%D1%82%D0%B2%D0%B5%D1%82%D1%8B-%D0%BD%D0%B0-%D0%BF%D0%BE%D0%BF%D1%
3%D0%BB
      2 http://firefox.yandex.ru/
      2 http://facebook.com/
      2 http://bar.sovremennik.info/manga/menu/55/
      2 http://192.168.1.5/sql-ledger/is.pl
      2 http://10.1.1.99:8080/Reports.aspx
      2 about:sync-progress
      2 about:sessionrestore

...and there's a *ton* of URLs with only one hit, a lot of those are starting in one of http://yandex.ua/yandsearch? http://www.odnoklassniki.ru/ http://www.google.ru (and other google.foo) http://www.facebook.com/ http://vk.com/ http://go.mail.ru/ http://clck.yandex.ru/redir/ but also a lot of individual others. I don't think we can make out any URL correlation there.
Keywords: needURLs
Adding qawanted now that we have URLs.
Keywords: qawanted
Crash Signature: [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ PR_GetHostByAddr ] → unsigned int, unsigned int*) ] [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ PR_GetHostByAddr ] [@ PR_GetHostByAddr | nsSocketOutputStream…
Depends on: 716345
Duplicate of this bug: 740315
Whiteboard: [startupcrash]
This stays constantly at high ranks. #9 in yesterday's data for 12.*

Any chance someone can find out what's going on there?
I have spent a time trying to figure this out, but this is very random and not easily reproducible.

Did fix of bug 700493 help in some way when now landed on Nightly?
(In reply to Scoobidiver from comment #47)
> (In reply to Honza Bambas (:mayhemer) from comment #46)
> > Did fix of bug 700493 help in some way when now landed on Nightly?
> It's almost the same thing.
I've changed my mind. Indeed, before the fix of bug 700493 there were about 20 crashes per buildID and after there are about 40 crashes per build ID.
Blocks: 700493
No longer blocks: 700493
This is still in the top 10 for Fx 12.
beware that as of FF14 the stack for this is going to change a little bit (see any of 763398 763395  763392 763386  763385 763261 763393), but there is no reason to think the basic problem has changed.

Also see bug 763261.. pretty much the same stack but correlated heavily to the korean ime. can that help the qawanted team try an STR? Or for that matter a number of other net dlls come  up on the above referenced bugs.
I'm thinking out loud here, but most of the linked bugs have known network filters attached to them (yandex, cafe filter, etc..).. a while back (ff7 iirc) we raised our total connection limit to 256 from 30. There was an identified problem that some buggy filters had with numbers > 64 (again iirc), and we managed to do a startup test for the cases we knew about (and in those cases reduce the limit back to 64).

I wonder if we're seeing another variation of that here. A reproduction would be useful for testing that hypothesis :)

We definitely don't want to just crank the number down across the board - raising it was addressing a provable bottleneck.

and of course the problem might have nothing to do with this, but I wanted to stick it in the bug.
It's #63 top browser crasher w/o hangs in 17.0 and #52 in 18.0b1 so no longer a top crasher.
Keywords: topcrash
Crash Signature: [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)] [@ PR_GetHostByAddr ] [@ PR_GetHostByAddr | nsSocketOutputStream::Write(char const* → [@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) ] [@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) ] [@ PR_GetHostByAddr ] [@ PR_GetHostByAddr | nsSocketOutputStream::Write(char const*
It's #20 top browser crasher in 19.0.2.

Here are recent correlations:
  nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)|EXCEPTION_ACCESS_VIOLATION_READ (225 crashes)
     53% (119/225) vs.   3% (4093/139851) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D} (Спутник @Mail.Ru)
     28% (62/225) vs.   4% (5457/139851) vb@yandex.ru
     26% (59/225) vs.   4% (5409/139851) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
Keywords: topcrash
Whiteboard: [startupcrash]
It's now #29 crasher in 20.0.1, #57 in 21.0b3 so no longer a top crasher.
Keywords: topcrash
Removing keyword since qa already answered this.

There are no crashes in Socorro with these signatures more recent than Firefox 20:
[@ strstr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) ]
[@ PR_GetHostByAddr ]
[@ PR_GetHostByAddr | nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*)

[@ nsSocketOutputStream::Write(char const*, unsigned int, unsigned int*) ] still bears some crashes on Firefox 26, 27 and 28 (none for 29), the reports I went through didn't send to Yandex anymore:
https://crash-stats.mozilla.com/report/list?range_unit=days&range_value=28&signature=nsSocketOutputStream%3A%3AWrite%28char+const%2A%2C+unsigned+int%2C+unsigned+int%2A%29
Keywords: qawanted
Assignee: honzab.moz → nobody
Still.. this a relatively high rate...
Seems to be a thread from sumo with this crash along with other kinds; https://support.mozilla.org/en-US/questions/1008829
Crash Signature: , unsigned int, unsigned int*) ] → , unsigned int, unsigned int*) ] [@ nsSocketOutputStream::Write ] [@ strstr | nsSocketOutputStream::Write ] [@ PR_GetHostByAddr | nsSocketOutputStream::Write ]
currently in firefox 43.0b1 this is one of the top crashers and seems to be correlated in part to a library hooked into firefox by "Ad Muncher":

nsSocketOutputStream::Write|EXCEPTION_ACCESS_VIOLATION_READ (218 crashes)
59% (129/218) vs.   1% (160/15924) AM32-34121.dll
(In reply to philipp from comment #58)
> currently in firefox 43.0b1 this is one of the top crashers and seems to be
> correlated in part to a library hooked into firefox by "Ad Muncher":
> 
> nsSocketOutputStream::Write|EXCEPTION_ACCESS_VIOLATION_READ (218 crashes)
> 59% (129/218) vs.   1% (160/15924) AM32-34121.dll

Yes, we should break that out into its own bug as it's both different DLLs being correlated and different Firefox versions affected. Let's leave this bug for mail.ru/Yandex-correlated crashes like that. Filed bug 1222933 for the 43.0b1 issue with Ad Muncher.
Duplicate of this bug: 763398
Duplicate of this bug: 763393
Duplicate of this bug: 763392
Duplicate of this bug: 763386
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222933
You need to log in before you can comment on or make changes to this bug.