Flash crash F1398665248_____________________________

RESOLVED DUPLICATE of bug 763237

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED DUPLICATE of bug 763237
6 years ago
2 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash, topcrash})

unspecified
x86
Windows 7
crash, topcrash

Firefox Tracking Flags

(firefox13-, firefox14-)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-18a96cca-5d75-47bd-ba07-b72032120610 .
============================================================= 

Seems this is a trending issue with the latest flash release. 

Crashing Thread
Frame 	Module 	Signature 	Source
0 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x2ff5e7 	
1 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31d31d 	
2 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x30f10c 	
3 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3177d4 	
4 	ntdll.dll 	RtlFreeHeap 	
5 	ntdll.dll 	RtlpTpWaitRundown 	
6 	ntdll.dll 	RtlDeregisterWaitEx 	
7 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31d45e 	
8 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x319a7f 	
9 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3106b8 	
10 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3242b9 	
11 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x323e0d 	
12 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31b6dd 	
13 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31b3d5 	
14 	ntdll.dll 	RtlInitializeCriticalSectionEx 	
15 	ntdll.dll 	RtlAllocateMemoryBlockLookaside 	
16 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31dc5f 	
17 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x670a84 	
18 	ntdll.dll 	RtlInitializeCriticalSectionAndSpinCount 	
19 	KERNELBASE.dll 	InitializeCriticalSectionAndSpinCount 	
20 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31c907 	
21 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3190da 	
22 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3194e2 	
23 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x7bd65f

Comment 1

6 years ago
It's #21 top crasher in 13.0 and #4 plugin crasher.
Keywords: topcrash
Summary: crash in npswf32_11_3_300_257 → crash in npswf32_11_3_300_257.dll@0x2ff5e7
I just uploaded symbols for this flash version a little bit ago, so the signature here will change (and might merge into an existing signature).

Comment 3

6 years ago
@ted would i need to enter a bug for socorro to reprocess them?  thanks...
Yes, you need to file a bug under Socorro : Database. You can assign it to :jberkus.
Actually, I'll file it for you.
Depends on: 763620
I'm pretty sure (from looking at the symbols) that this will wind up as [@ F1398665248_____________________________ ].
And yes, loading the report in comment 0 confirms that.

Comment 8

6 years ago
This crash is a *browser* crash, not a plugin crash.
Crash Signature: [@ npswf32_11_3_300_257.dll@0x2ff5e7] → [@ npswf32_11_3_300_257.dll@0x2ff5e7] [@ F1398665248_____________________________ ]
Summary: crash in npswf32_11_3_300_257.dll@0x2ff5e7 → Flash crash F1398665248_____________________________

Comment 9

6 years ago
I believe this is probably the same as bug 763237.

Updated

6 years ago
tracking-firefox13: --- → +
tracking-firefox14: --- → +
Stack from https://crash-stats.mozilla.com/report/index/c5fd5a09-8c11-482b-a9f1-410172120611 :
ChildEBP RetAddr  
WARNING: Frame IP not in any known module. Following frames may be wrong.
0b23f8e8 6002f5ec 0x6
0b23fb28 6004980d NPSWF32_11_3_300_257!F1133371925_____________________+0x9c [F_1017111218___________________________________________________________________________________________ @ 266]
0b23fb30 6004b83c NPSWF32_11_3_300_257!F_167100653___________________________________+0xd [F_156286729_________________________________________________________________ @ 107]
0b23fbf4 6004cd86 NPSWF32_11_3_300_257!F_1977390894________+0x14c [F_156286729_________________________________________________________________ @ 488]
0b23fc38 600542ba NPSWF32_11_3_300_257!F_1579173356_______+0x246 [F_156286729_________________________________________________________________ @ 698]
0b23fc68 60053e0e NPSWF32_11_3_300_257!F1496068391______________________+0x5a [F_1130177034____________________________________________________________________ @ 204]
0b23fc88 6004b6de NPSWF32_11_3_300_257!F_396694577______________+0x3e [F_1006288550___________________________________________________________________ @ 80]
0b23fd34 6004c908 NPSWF32_11_3_300_257!F_1139049974____________+0x9e [F_156286729_________________________________________________________________ @ 453]
0b23fd50 600490db NPSWF32_11_3_300_257!F_596758739_____+0x58 [F_156286729_________________________________________________________________ @ 351]
0b23fd58 600494e3 NPSWF32_11_3_300_257!F1873479986______+0xb [F281136709______________________________________________________________________ @ 129]
0b23feb0 6004dc7b NPSWF32_11_3_300_257!F_1527808672____________+0xd3 [F281136709______________________________________________________________________ @ 167]
0b23febc 76ccd309 NPSWF32_11_3_300_257!F_1385070178___________________________+0x1b [F495244578___________________________________________________________________________________ @ 38]
0b23fec8 76e81603 kernel32!BaseThreadInitThunk+0xe
0b23ff08 76e815d6 ntdll!__RtlUserThreadStart+0x23
0b23ff20 00000000 ntdll!_RtlUserThreadStart+0x1b
Addon and module correlations for this signature from today's manual report:

npswf32_11_3_300_257.dll@0x2ff5e7|EXCEPTION_ACCESS_VIOLATION_READ (603 crashes)
     15% (88/603) vs.   9% (5738/62111) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)

npswf32_11_3_300_257.dll@0x2ff5e7|EXCEPTION_ACCESS_VIOLATION_READ (603 crashes)
    100% (603/603) vs.  11% (6849/62111) NPSWF32_11_3_300_257.dll
    100% (603/603) vs.  32% (19922/62111) dsound.dll
     92% (556/603) vs.  33% (20379/62111) plugin-container.exe
    100% (603/603) vs.  41% (25542/62111) comdlg32.dll
     91% (549/603) vs.  41% (25547/62111) profapi.dll
     99% (597/603) vs.  49% (30658/62111) apphelp.dll
    100% (603/603) vs.  51% (31726/62111) AudioSes.dll
    100% (603/603) vs.  51% (31850/62111) MMDevAPI.dll
     91% (549/603) vs.  43% (26756/62111) devobj.dll
     91% (549/603) vs.  43% (26757/62111) sechost.dll
     91% (549/603) vs.  43% (26757/62111) CRYPTBASE.dll
     91% (549/603) vs.  43% (26757/62111) KERNELBASE.dll
    100% (603/603) vs.  52% (32358/62111) powrprof.dll
     91% (549/603) vs.  44% (27196/62111) cfgmgr32.dll
    100% (603/603) vs.  53% (32990/62111) winnsi.dll
    100% (603/603) vs.  53% (32990/62111) nsi.dll
    100% (603/603) vs.  53% (32993/62111) IPHLPAPI.DLL
    100% (603/603) vs.  53% (32998/62111) dwmapi.dll
     91% (550/603) vs.  49% (30532/62111) propsys.dll
    100% (603/603) vs.  64% (39691/62111) winspool.drv
     98% (592/603) vs.  63% (38966/62111) lpk.dll
    100% (603/603) vs.  65% (40453/62111) iertutil.dll
    100% (603/603) vs.  67% (41467/62111) urlmon.dll
    100% (603/603) vs.  67% (41703/62111) msctf.dll
     62% (375/603) vs.  31% (19358/62111) sspicli.dll
     85% (510/603) vs.  60% (37066/62111) normaliz.dll
    100% (603/603) vs.  77% (47948/62111) wininet.dll
     90% (540/603) vs.  71% (44335/62111) icm32.dll
    100% (603/603) vs.  93% (57489/62111) mscms.dll
    100% (603/603) vs.  94% (58682/62111) userenv.dll

Comment 12

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #9)
> I believe this is probably the same as bug 763237.

Yes, it is, as reprocessing shows.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763237

Updated

6 years ago
tracking-firefox13: + → -
tracking-firefox14: + → -

Comment 13

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.