Last Comment Bug 763237 - [adbe 3221904] Firefox crash in F1398665248_____________________________
: [adbe 3221904] Firefox crash in F1398665248_____________________________
Status: RESOLVED DUPLICATE of bug 775646
[flash-11.3]
: crash, reproducible, topcrash
Product: External Software Affecting Firefox
Classification: Components
Component: Flash (Adobe) (show other bugs)
: unspecified
: x86 All
: -- critical with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 763444 769131 (view as bug list)
Depends on: 763746
Blocks: 532972 F1398665248
  Show dependency treegraph
 
Reported: 2012-06-09 16:23 PDT by Marcia Knous [:marcia - use ni]
Modified: 2016-04-28 10:07 PDT (History)
50 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
-
-
affected
unaffected


Attachments
testcase (701 bytes, text/html)
2012-06-22 07:45 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description Marcia Knous [:marcia - use ni] 2012-06-09 16:23:20 PDT
This bug was filed from the Socorro interface and is 
report bp-c05ee491-950b-447a-9de4-8147e2120609 .
============================================================= 

Seen while looking at crash stats. We have a large spike on Firefox 13 as well as beta since this shipped the other day - https://crash-stats.mozilla.com/report/list?signature=npswf32_11_3_300_257.dll@0x2ff5eb links to the crashes.

rame 	Module 	Signature 	Source
0 		@0x8b388a4d 	
1 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x2ff5eb 	
2 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31d31d 	
3 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x30f10c 	
4 	ntdll.dll 	RtlFreeHeap 	
5 	ntdll.dll 	RtlDeregisterWaitEx 	
6 	ntdll.dll 	WinSqmSetIfMaxDWORD 	
7 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x319a7f 	
8 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3106b8 	
9 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3242b9 	
10 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x323e0d 	
11 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31b6dd 	
12 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31b3d5 	
13 	ntdll.dll 	RtlInitializeCriticalSectionEx 	
14 	ntdll.dll 	RtlAllocateMemoryBlockLookaside 	
15 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31dc5f 	
16 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x670a84 	
17 	ntdll.dll 	RtlInitializeCriticalSectionAndSpinCount 	
18 	KERNELBASE.dll 	InitializeCriticalSectionAndSpinCount 	
19 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x31c907 	
20 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3190da 	
21 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x3194e2 	
22 	NPSWF32_11_3_300_257.dll 	NPSWF32_11_3_300_257.dll@0x7bd65f
Comment 1 Marcia Knous [:marcia - use ni] 2012-06-09 16:28:48 PDT
There are mentions in the comment of "Adobe Flash 11.3 R300 stopped working" and that crashes are frequent.
Comment 2 Jim Jeffery not reading bug-mail 1/2/11 2012-06-09 16:52:40 PDT
For testing purposes I was advised of this thread for testing a tweak to turn off Protected-mode:

http://forums.adobe.com/thread/1018071?tstart=0

Also, for the moment I'm testing with IPC 'Off' - perhaps a conflict with IPC and their PM ?
Comment 3 Jim Jeffery not reading bug-mail 1/2/11 2012-06-09 18:35:13 PDT
More testing is probably required, and I'm using hourly builds, so I need to grab a Nightly.  I'm crashing on shutdown with IPC 'off' and I'm seeing lots of Ghost/Zombie compartments in about:compartments on Youtube using Flash.  I purposely for the time being opted out of HTML5 to test this Flash issue. 

MSNBC consumes a lot of CPU with IPC 'off'.  Even though looking at the task manager in Win7 x64 the Plugin-container shows little to no activity or memory use with the new Flash plugin I was thinking it was not being used, but it must be doing something as the CPU usage and crashes were not happening, only 'silent' Flash plugin crashes in background only noted by looking in about:crashes and in the Activity Monitor in Win7.

More testing tomorrow afternoon when I get off work.
Comment 4 Marcia Knous [:marcia - use ni] 2012-06-09 20:39:50 PDT
Addon and module correlations for FF13:

npswf32_11_3_300_257.dll@0x2ff5eb|EXCEPTION_ACCESS_VIOLATION_EXEC (436 crashes)
    100% (436/436) vs.   1% (1179/86607) NPSWF32_11_3_300_257.dll
    100% (436/436) vs.  27% (23146/86607) dsound.dll
    100% (436/436) vs.  37% (32175/86607) comdlg32.dll
     87% (380/436) vs.  29% (24776/86607) plugin-container.exe
     99% (433/436) vs.  43% (37140/86607) apphelp.dll
    100% (435/436) vs.  44% (37796/86607) AudioSes.dll
    100% (435/436) vs.  44% (38127/86607) MMDevAPI.dll
    100% (436/436) vs.  45% (39125/86607) powrprof.dll
    100% (436/436) vs.  46% (39936/86607) nsi.dll
    100% (436/436) vs.  46% (39937/86607) winnsi.dll
    100% (436/436) vs.  46% (39953/86607) IPHLPAPI.DLL
    100% (436/436) vs.  46% (39956/86607) dwmapi.dll
     85% (369/436) vs.  35% (30612/86607) profapi.dll
     85% (369/436) vs.  37% (32433/86607) devobj.dll
     85% (369/436) vs.  37% (32435/86607) sechost.dll
     85% (369/436) vs.  37% (32435/86607) CRYPTBASE.dll
     85% (369/436) vs.  37% (32435/86607) KERNELBASE.dll
     85% (369/436) vs.  38% (33230/86607) cfgmgr32.dll
     87% (379/436) vs.  43% (37308/86607) propsys.dll
    100% (434/436) vs.  57% (49623/86607) lpk.dll
    100% (436/436) vs.  62% (53684/86607) msctf.dll
    100% (436/436) vs.  62% (53797/86607) winspool.drv
    100% (436/436) vs.  64% (55190/86607) iertutil.dll
    100% (436/436) vs.  66% (56820/86607) urlmon.dll
     86% (376/436) vs.  59% (51242/86607) normaliz.dll
    100% (436/436) vs.  77% (67072/86607) wininet.dll
     49% (215/436) vs.  27% (23780/86607) sspicli.dll
     89% (388/436) vs.  68% (59233/86607) icm32.dll
    100% (436/436) vs.  92% (79392/86607) mscms.dll
     15% (66/436) vs.   8% (7212/86607) AudioEng.dll
    100% (436/436) vs.  94% (81295/86607) userenv.dll

npswf32_11_3_300_257.dll@0x2ff5eb|EXCEPTION_ACCESS_VIOLATION_EXEC (436 crashes)
     18% (77/436) vs.   8% (6882/86607) {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Adblock Plus, https://addons.mozilla.org/addon/1865)
Comment 5 Kohei Yoshino [:kohei] 2012-06-09 22:08:40 PDT
The latest Flash version looks like problematic... People are saying that they can no longer play videos and/or input Japanese characters with IME.
Comment 6 Scoobidiver (away) 2012-06-10 00:29:12 PDT
It's #9 top crasher and #1 top plugin crasher in 13.0.
85% of crashes happen on Windows 7 and 14% on Vista.
Comment 7 Marcia Knous [:marcia - use ni] 2012-06-10 12:30:11 PDT
A quick crash stats query shows almost 14K crashes across all Firefox versions in the last week.
Comment 8 Alex Keybl [:akeybl] 2012-06-10 16:48:13 PDT
We should get URLs to help in reproducing.
Comment 9 Alex Keybl [:akeybl] 2012-06-10 16:49:12 PDT
(In reply to Kohei Yoshino from comment #5)
> The latest Flash version looks like problematic... People are saying that
> they can no longer play videos and/or input Japanese characters with IME.

Please file a separate bug (and CC me) if you're seeing this behavior in Firefox, and no other browsers.
Comment 10 Marcia Knous [:marcia - use ni] 2012-06-10 22:56:12 PDT
Here are some URLs:

62 	about:blank
15 	http://www.facebook.com/
11 	https://www.facebook.com/?ref=tn_tnmn
10 	https://www.facebook.com/
8 	http://ox-d.adobe.com/w/1.0/afr?auid=216719&cb=INSERT_RANDOM_NUMBER_HERE
6 	http://www.google.de/
4 	http://www.facebook.com/?ref=tn_tnmn
4 	chrome://fvd.speeddial/content/fvd_about_blank.html
4 	http://lifenews.ru/news/94178
4 	about:addons
4 	about:newtab
4 	http://get.adobe.com/de/flashplayer/completion/aih/?exitcode=0
3 	http://get.adobe.com/es/flashplayer/completion/aih/?exitcode=0
3 	http://www.odnoklassniki.ru/profile/525271350185
3 	https://apps.facebook.com/kingdomsofcamelot/?s=308
3 	https://twitter.com/#!/
3 	http://e.mail.ru/cgi-bin/msglist
3 	http://www.youtube.com/
3 	http://www.ebay.com.au/sch/i.html?rt=nc&LH_PrefLoc=1&_nkw=Memory%20Foam%20Travel
2 	http://edge.jeetyetmedia.com/160x600_home_www_facebook_com_left.htm?
2 	http://www.facebook.com/?ref=logo
2 	http://www.dresden-mails.de/index.php
2 	http://www.nowvideo.eu/video/814fe5sonx9yv
2 	http://get.adobe.com/de/reader/completion/aih/?exitcode=0
2 	http://tvist.sibnet.ru/channels/
2 	http://www.plotek.pl/plotek/1,78649,11900343,Polka_nie_wygrala_niemieckiego_Top_
2 	http://entretenimiento.terra.com.co/globalSTATIC/atm/2/core/_tpl/advertising.htm
2 	http://www.gyakorikerdesek.hu/
2 	https://www.socialappspot.com/gfba2/Banners/2.aspx?t=1&lng=de&hints=Ja+Oder+Nein
2 	http://www.wer-kennt-wen.de/start
2 	https://www.frankfurter-sparkasse.de/module/tx_entry/rewrite.php?IFLBSERVERID=IF
2 	https://www.facebook.com/?ref=logo
2 	http://ask.fm/account/wall
2 	http://rpx.azet.sk/
2 	https://apps.facebook.com/hidden-chronicles/?src=xpromo&crt=city&adn=zbarPromoId
2 	http://www.odnoklassniki.ru/
2 	http://themes.astonshell.com/aston2/page2.html
2 	http://index.hu/
2 	http://www.yahoo.co.jp/
2 	http://de.twitch.tv/
2 	http://www.zedge.net/ringtones/0-2-16/
2 	http://vk.com/videos-62180
2 	http://www.isnichwahr.de/
2 	http://ox-d.adobe.com/w/1.0/afr?auid=217843&cb=INSERT_RANDOM_NUMBER_HERE
2 	http://www.deunghyun.es.kr/index/index.do
2 	http://vk.com/darya_kolycheva
2 	http://vk.com/videos-62180?z=video-62180_163477270%2Fclub62180
2 	http://www.youtube.com/watch?v=DMLyR3o2vR4
2 	http://www.binnews.in/index.php?country=fr
2 	http://bazoocam.org/
2 	http://live.nicovideo.jp/recent?tab=common
2 	http://get.adobe.com/flashplayer/completion/aih/?exitcode=0
2 	chrome://superstart/content/index.html
2 	http://www.livejasmin.com/perfinfo.php?performerid=000MARYXXX&tags=mature&liveja
2 	https://apps.facebook.com/onthefarm/index.php?ref=tab
2 	about:home
2 	http://www.tvn24.pl/
2 	http://www.twitch.tv/directory/following
2 	http://www.draugiem.lv/gallery/
2 	http://nk.pl/profile/aplikacje
2 	https://www.facebook.com/lists/253003068077964
2 	http://my.msn.com/#
2 	http://uwants.com/
2 	http://www.uwants.com/forumdisplay.php?fid=7
2 	http://www.t-online.de/
2 	http://beeg.com/
Comment 11 Kohei Yoshino [:kohei] 2012-06-11 03:33:59 PDT
Adobe's bug: https://bugbase.adobe.com/index.cfm?event=bug&id=3210091
Comment 12 smadayag 2012-06-11 11:57:04 PDT
someone posted this is not reproducible on Firefox 15/16 with recent content and container patches.  since we are not able to reproduce on our end, can someone confirm or deny this is the case?  thanks...
Comment 13 Marcia Knous [:marcia - use ni] 2012-06-11 12:29:18 PDT
Sal - QA doesn't yet have a set of reproducible STR on 13/14 but we are working on it now. I have hit one crash on a Win 7 machine but it was a different stack. 

If someone experiencing this crash has STR please post them to this bug ASAP.

(In reply to smadayag from comment #12)
> someone posted this is not reproducible on Firefox 15/16 with recent content
> and container patches.  since we are not able to reproduce on our end, can
> someone confirm or deny this is the case?  thanks...
Comment 14 Marcia Knous [:marcia - use ni] 2012-06-11 12:31:10 PDT
Also in looking at the signature summary, I do see some crashes in this stack on 15 and 16, although not high volume.
Comment 15 Jim Jeffery not reading bug-mail 1/2/11 2012-06-11 13:10:58 PDT
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #3)
> More testing is probably required, and I'm using hourly builds, so I need to
> grab a Nightly.  I'm crashing on shutdown with IPC 'off' and I'm seeing lots
> of Ghost/Zombie compartments in about:compartments on Youtube using Flash. 
> I purposely for the time being opted out of HTML5 to test this Flash issue. 
> 
> MSNBC consumes a lot of CPU with IPC 'off'.  Even though looking at the task
> manager in Win7 x64 the Plugin-container shows little to no activity or
> memory use with the new Flash plugin I was thinking it was not being used,
> but it must be doing something as the CPU usage and crashes were not
> happening, only 'silent' Flash plugin crashes in background only noted by
> looking in about:crashes and in the Activity Monitor in Win7.
> 
> More testing tomorrow afternoon when I get off work.

I suspect the high cpu and zombie compartments with 'ipc' = off is a totally different bug.  I've been playing lots of Youtube vids, news vids from CNN & MSNBC since turning 'ipc' back on, and strangely enough where before I was seeing the flash-plugin crashing 'silently' or on shut-down has gone away, I've not seen the plugin crash now in almost 2 days.

I could find no concrete way to 'make it crash' on demand with a workable STR, it would just out of the blue - silently crash.  Surely toggling IPC on/off wouldn't have made a difference ?
Comment 16 Benjamin Smedberg [:bsmedberg] 2012-06-11 15:43:39 PDT
I believe that this is the same as bug 763444, and may be only or mainly experienced by people who have disabled IPC plugins in about:config.
Comment 17 Marcia Knous [:marcia - use ni] 2012-06-11 16:50:50 PDT
Adding tracking flags just in case, as this is the larger volume crasher.
Comment 18 Jeromie Clark 2012-06-11 17:19:48 PDT
We're tracking a couple issues with Protected Mode, not all of which are related. 

We can eliminate the IME issue as a possible clue:

Users are reporting that IME does not work because Flash Player is running as a low privilege process, and can no longer invoke the IME DLL itself.  We'll probably need to collaborate to design a new mechanism for invoking IME.

For those of you that are interested, techincal details on the new Flash Player Protected Mode implementation are here: http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html

We've tracked down the root cause of one broadly-reported issue in the field that may be contributing to this crash today: 

1.) RealPlayer's Browser Record Plug-In appears to cause Flash Player with Protected Mode to become unstable.  In most instances, this manifests as content not loading, and the player occasionally crashing on exit.  Removing RealPlayer and restarting Firefox seems to resolve this.
Comment 19 Marcia Knous [:marcia - use ni] 2012-06-11 18:23:53 PDT
As a side note, I crashed today using the latest Mac nightly when I left some tabs open with 11_3_300_257 flash playing. I did not get the Mozilla Crash Reporter but the Apple crash reporter came up. So it may be that Mac users are hitting this crash but we are not getting the crash reports. I do have an older version of the Real Player plugin installed on this 10.7.4 machine.
Comment 20 Jeromie Clark 2012-06-11 18:30:07 PDT
Protected Mode only works on Win Vista+ at this point, so that's probably not the root-cause of the crash you saw on Mac.  

The RealPlayer Browser Record Plugin does some weird stuff where they try to hook into Flash Player so that they can intercept and save out streaming video, which has caused a number of headaches over the years.  It appears to be particularly problematic with Protected Mode.
Comment 21 Robert Kaiser 2012-06-11 20:27:54 PDT
(In reply to Marcia Knous [:marcia] from comment #0)
> This bug was filed from the Socorro interface and is 
> report bp-c05ee491-950b-447a-9de4-8147e2120609 .

After reprocessing, this now has the signature F1398665248_____________________________.
Comment 22 Robert Kaiser 2012-06-11 20:28:14 PDT
*** Bug 763444 has been marked as a duplicate of this bug. ***
Comment 23 Virgil Dicu [:virgil] [QA] 2012-06-12 07:16:39 PDT
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0
https://crash-stats.mozilla.com/report/index/bp-7cc4a8fe-d336-4aab-ae1a-256092120612
https://crash-stats.mozilla.com/report/index/458eff62-e5d8-4d53-b0b7-4ebb62120612
https://crash-stats.mozilla.com/report/index/bp-f2e205bd-e02c-44ed-b0be-0d2182120612

Received several Adobe plugin crashes with Firefox 13, Windows 7, x86 and version 11.3.300.257, but no Firefox crashes.
STR:
0. (Have Flash version 11.3.300.257 installed)
1. Start Firefox with a clean profile.
2. Open several tabs loaded with Flash content

When having miniclip, facebook games and youtube all opened/refreshed, I quickly got a Windows message:"Adobe Flash player stopped working" after which all plugin instances would crash.

Attempted with Protected mode on/off. Could only manage to reproduce the plugin crash with Protected mode on(default).
Comment 24 Marcia Knous [:marcia - use ni] 2012-06-12 08:23:08 PDT
An advanced query now shows this is now the top crash in Firefox 13 after the empty signature.
Comment 25 Robert Kaiser 2012-06-12 10:49:08 PDT
Next to this crashing in the browser process and not a plugin process, another quite interesting detail of this crash is that it exclusively happens in Windows 7 and Vista, possibly also Windows 8 (currently displayed as "Windows Unknown"), see the Signature Summary tab in https://crash-stats.mozilla.com/report/list?signature=F1398665248_____________________________
Comment 26 Jeromie Clark 2012-06-12 12:42:05 PDT
@kairo - Flash Player Protected Mode is only supported in Windows Vista and higher.  This is expected, and consistent with virgil's observation that the issue only reproduces with ProtectedMode enabled.

We are actively investigating this crash, and will update the bug as we know more.  If you find easier/more consistent reproduction steps, we'd be extremely grateful, but Virgil's observations are already super helpful.

Thanks!
Comment 27 smadayag 2012-06-12 13:22:10 PDT
(In reply to Marcia Knous [:marcia] from comment #24)
> An advanced query now shows this is now the top crash in Firefox 13 after
> the empty signature.

i am able to repro the @empty signature.  it there a bug associated with it, so i can put the STR in?
Comment 28 smadayag 2012-06-12 13:25:50 PDT
actually, crash-stats states it is a corrupt dump.  the STR may apply to this issue.

Steps to Reproduce: Install Flash 11.3.300.257
1. launch a new firefox session
2. navigate to miniclip.com
3. launch the upper 6 games in new tabs.  (eg.  i control/command-clicked Robotsvs/Gemaica/8 Ball/Euro Soccer/Club Penguin/Bullfrog Poker)
4. let them load - as they are loading i'm clicking each tab to see their progress
5. when loading is complete, go to the Gemaica tab and attempt to start the game
-at this point we crash
Comment 29 Ted Mielczarek [:ted.mielczarek] 2012-06-12 14:00:55 PDT
Corrupt dumps usually indicate OOM or heap corruption. If you can reproduce this with a debugger attached you should be able to get an actual stack.
Comment 30 Scoobidiver (away) 2012-06-12 14:01:23 PDT
With the STR in comment 28, Nightly crashes for me: bp-40819762-2484-43b6-8eab-9eb712120612.
Comment 31 Robert Kaiser 2012-06-12 14:46:05 PDT
(In reply to smadayag from comment #27)
> i am able to repro the @empty signature.  it there a bug associated with it,
> so i can put the STR in?

That empty signature sums up all the crashes that come with a corrupt dump due to OOM or heap corruption. If you have a specific reproducible case, please file a new bug for that one.
Comment 32 Jim Jeffery not reading bug-mail 1/2/11 2012-06-12 15:51:48 PDT
(In reply to Scoobidiver from comment #30)
> With the STR in comment 28, Nightly crashes for me:
> bp-40819762-2484-43b6-8eab-9eb712120612.

If I'm looking at your c-r correctly, it appears your running a build from 2012-06-08.  
Can you update to today's build and repeat the STR ? 
I'm using the very latest hourly here and I don't crash with those STR's.

I read somwhere, would have to go digging around, but someone said there was a couple of recent IPC patches that landed, I'm thinking they maybe have landed on the 8th post nightly, or maybe on the 9th post Nightly.  I've not had any crashes here since the 9th, no silent fails, no browser crashes, no warnings about Sorry- Flash-crashed.  

Looking here I see that most fails on 16.0a1 stopped on the 9th:
https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A16.0a1&query_search=signature&query_type=contains&query=F1398665248_____________________________&reason_type=contains&date=06%2F09%2F2012%2019%3A05%3A38&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=F1398665248_____________________________
Comment 33 Scoobidiver (away) 2012-06-12 23:21:01 PDT
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #32)
> If I'm looking at your c-r correctly, it appears your running a build from
> 2012-06-08.  
It's the latest French Nightly build.
With the latest en-US Nightly build, here is the crash report: bp-52108bb7-5a9b-49d8-aab1-ecc242120613

> Looking here I see that most fails on 16.0a1 stopped on the 9th
Your query contains the date (06/09/2012 19:05:38). Here is a basic query: https://crash-stats.mozilla.com/report/list?version=Firefox%3A16.0a1&signature=F1398665248_____________________________
There are about 50 crashes per build since the release of Flash 11.3.
Comment 34 Gary Kwong [:gkw] [:nth10sd] 2012-06-13 00:18:56 PDT
> That empty signature sums up all the crashes that come with a corrupt dump
> due to OOM or heap corruption. If you have a specific reproducible case,
> please file a new bug for that one.

Chinese users also report intermittent issues similar to this one, but we are first trying to narrow down the STR, platforms, OSes, FF versions, hardware and sites involved.
Comment 35 Arthur K. 2012-06-13 10:07:02 PDT
Does this bug negate what is being said here: http://forums.adobe.com/message/4478247?tstart=0 ?
Comment 36 Benjamin Smedberg [:bsmedberg] 2012-06-13 10:13:46 PDT
I believe that is a different crash, I have some evidence that the crash on shutdown is bug 747683, and not nearly as serious in general.
Comment 37 Scoobidiver (away) 2012-06-13 10:17:22 PDT
(In reply to Arthur K. from comment #35)
> http://forums.adobe.com/message/4478247?tstart=0
It's bug 763276.
Comment 38 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-14 16:58:45 PDT
Testing with Firefox 13.0.1 on Windows 7 64-bit with steps in comment 28:
 * Flash 11.2 -> no crash
 * Flash 11.3 -> no crash
 * Flash 11.4 -> no crash
Comment 39 Jeromie Clark 2012-06-14 18:12:46 PDT
This fixes the silent crash I was observing when restarting Firefox after adding/removing an Add-On with an active Flash Player tab open.
Comment 40 Benjamin Smedberg [:bsmedberg] 2012-06-14 22:14:01 PDT
Jeromie, I believe the silent crash is bug 747683 and I'm also 99.99% sure that it is entirely unrelated to this bug.
Comment 41 Mart Rootamm 2012-06-14 23:05:08 PDT
First I was having the plugin-container crash (end-of-process caused by Windows), which was cited as a measure by Data Execution Prevention, whereas DEP has been set only for "essential Windows programs and services." (This is most likely because the plugin is at "C:\Windows\System32\Macromed\Flash")

Then I copied the offending Flash DLL into the Firefox plugins folder at C:\Program Files\Mozilla Firefox:

At some point I had trouble loading or reloading an IMDb page (as one of many tabs), then a short hang (ish, but no CPU spike) or slowdown as plugin-container.exe was started, then after a minute or two had a Firefox error of a script loading too slowly, and that was with loading the Flashblock extension:

"Script: chrome://flashblock/content/flashblock.xml:59"

After that, the page would behave normally, until I would reload.
Disabling Flash helps.

Extensions:
* NoScript 2.4.6 /various domains allowed/disallowed
* Flashblock 1.5.15a1

Disabled extensions:
* AVG Do Not Track 12.0.0.2166
* AVG Safe Search 12.0.0.2163 (because incompatible)
* DivX Plus Web Player HTML5 <video> 2.1.2.145
* Microsoft .NET Framework Assistant 0.0.0

Plugins:
* Adobe Acrobat 8.3.1.289 (nppdf32.dll)
* Java Deployment Toolkit 6.0.290.11 (npdeployJava1.dll)
* Java(TM) Platfor SE 6 U29 6.0.290.11 (npjp2.dll)
* Microsoft Windows Media Player Firefox Plugin 1.0.0.8 (np-mswmp.dll)
* Picasa 3.1.0.0 (npPicasa3.dll)
* QuickTime Plug-in 7.7.2.0 (npqtplugin.dll, npqtplugin[2-7].dll)
* Shockwave Flash 11.3.300.257 (when not disabled)
* Shockwave Director 11.5.9.620 (np32dsw.dll)
* Silverlight Plug-in 60.61118.0 (npctrl.dll)
* Windows Presentation Foundation 3.5.30729.1 (NPWPF.dll)
* VLC Multimedia Plug-in 1.0.5.0 (npvlc.dll)

Disabled plugins:
* DivX Plus Web Player 2.2.0.52
* DivX VOD Helper Plug-in 1.1.0.6
* Facebook Plugin 1.0.3.0
* Google Talk Plugin 2.9.10.7526
* Google Talk Plugin Video Accelerator 0.1.44.15
* Google Update 1.3.21.111
* iTunes Application Detector 1.0.1.1

(Note that RealPlayer's Browser Record Plug-In is not in the list.)
Comment 42 Mart Rootamm 2012-06-14 23:06:06 PDT
Oh, and Firefox version is 13.0.
Comment 43 Scoobidiver (away) 2012-06-14 23:50:05 PDT
(In reply to Mart Rootamm from comment #41)
> First I was having the plugin-container crash (end-of-process caused by
> Windows)
It's bug 763276.

> At some point I had trouble loading or reloading an IMDb page (as one of
> many tabs), then a short hang (ish, but no CPU spike) or slowdown as
> plugin-container.exe was started, then after a minute or two had a Firefox
> error of a script loading too slowly, and that was with loading the
> Flashblock extension: 
> "Script: chrome://flashblock/content/flashblock.xml:59" 
> After that, the page would behave normally, until I would reload.
If you are able to reproduce this behavior in 13.0.1 (see ftp://ftp.mozilla.org/pub/firefox/nightly/13.0.1-candidates/build1/win32/), file a new bug as it's unrelated to this Flash crash.
Comment 44 Mart Rootamm 2012-06-15 03:48:37 PDT
@Scoobidiver

> If you are able to reproduce this behavior in 13.0.1 (see 
> ftp://ftp.mozilla.org/pub/firefox/nightly/13.0.1-candidates/build1/win32/), file 
> a new bug as it's unrelated to this Flash crash.

Here's hoping. Installed 13.0.1-candidate; so far no crashes related to plugin-container.exe; I've confirmed the candidate working ok in a bit longer comment at bug 763276.
Comment 45 Marcia Knous [:marcia - use ni] 2012-06-15 13:02:56 PDT
I looked a little more deeply at the module correlation reports now that we have more data. 6.1.7600.16385 seems to be more heavily represented in the module correlation data which maps to http://drivers.softpedia.com/get/MOTHERBOARD/Intel/MSI-Wind-Top-AE2420-Intel-Chipset-Driver-61760016385.shtml.
Comment 46 Marcia Knous [:marcia - use ni] 2012-06-15 14:54:43 PDT
Update: We do have a reproducible test case in house that is occurring in a Virtual Box Win 7 setup, so for now at least we have made some progress on reproducing this by just loading a youtube.com video and going full screen. But AFAIK we have not been able to reproduce it easily on any hardware we have.
Comment 47 Gary Kwong [:gkw] [:nth10sd] 2012-06-16 05:16:39 PDT
> Chinese users also report intermittent issues similar to this one, but we
> are first trying to narrow down the STR, platforms, OSes, FF versions,
> hardware and sites involved.

Just wanted to update that we don't have reliable STR for Chinese sites either, unfortunately..
Comment 48 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-06-16 09:21:16 PDT
I'm hitting this crash quite often too on my Toshiba Satellite L505D-S5983.
Latest case where I encountered this.
Listening to online radio here: http://radioplayer.omroep.nl/radio1/
I was on http://slashdot.org/ and saw a Flash advertisement there, then tried to go to http://news.google.com and then the Flash player crashed:
https://crash-stats.mozilla.com/report/index/bp-41677bc0-71ab-4f38-8e96-b2a972120616

I get the impression that it is more likely to happen on slower hardware perhaps.
Comment 49 Bob Clary [:bc:] 2012-06-18 09:16:44 PDT
I can reproduce on Beta/14, Aurora/15, Nightly/16 on Windows 7 32bit with:

1. load http://mp3.zing.vn/album/Zing-Collection-Xin-Loi-Various-Artists/ZWZAIU8U.html
2. shutdown
3. check about:crashes to see the crash report

I can also get this in a debug build.
Comment 51 Alex Keybl [:akeybl] 2012-06-20 16:29:12 PDT
This isn't Firefox's fault. Given that, there's no action for us to take. Untracking for upcoming releases.
Comment 52 Kohei Yoshino [:kohei] 2012-06-21 03:25:43 PDT
Flash Player 11.3.300.262 is out:
http://www.adobe.com/software/flash/about/
Comment 53 Scoobidiver (away) 2012-06-21 04:29:40 PDT
With FP 11.3.300.262, I can no longer reproduce the crash with the STR in comment 28.

Nevertheless, they still exists:
https://crash-stats.mozilla.com/report/list?signature=npswf32_11_3_300_262.dll%400x2ff26b
https://crash-stats.mozilla.com/report/list?signature=npswf32_11_3_300_262.dll%400x2ff267
Comment 54 Jeromie Clark 2012-06-21 10:50:32 PDT
Our investigation indicates that this signature is generated for a number of distinct issues, including any time Firefox detects a hang and terminates the player's process.

We'll be working with the crash reporting team to figure out what needs to happen to identify unique issues, and in the meantime are looking for STRs that continue to result in this crash.
Comment 55 Benjamin Smedberg [:bsmedberg] 2012-06-21 12:05:46 PDT
This signature should never or almost-never occur when Firefox detects a hang and terminates the Flash process: those have a signature prefix of "hang |", among other things.

Data from bug 767046 shows that this signature is the crash signature for 95% of Flash crashes on Vista/Win7, so it's definitely a generic crash.
Comment 56 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-06-22 07:45:21 PDT
Created attachment 635741 [details]
testcase

I think I can reproduce it with this testcase and these steps to reproduce:
- Right-click in the first black bordered box, the Flash context menu comes up
- Wait 5 seconds when a new window opens up (in a new tab)
- Then click somewhere else to dismiss the Flash context menu

I got for instance this crash report:
https://crash-stats.mozilla.com/report/index/bp-2659f621-5231-43c6-acee-0f2392120622
Comment 57 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-22 09:51:32 PDT
Using Martijn's testcase, I can reproduce a Windows level plug-in crash (Adobe Flash Player 11.3 r300 has stopped working) with the following stack information:

  Problem Event Name:	APPCRASH
  Application Name:	FlashPlayerPlugin_11_3_300_262.exe
  Application Version:	11.3.300.262
  Application Timestamp:	4fe20fae
  Fault Module Name:	NPSWF32_11_3_300_262.dll
  Fault Module Version:	11.3.300.262
  Fault Module Timestamp:	4fe21212
  Exception Code:	c0000005
  Exception Offset:	001ef807
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

I get the same using Flash 11.4.400.171. Disabling protected mode does not resolve this crash.
Comment 58 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-22 11:04:45 PDT
Follow-up to comment 57, it actually resulted in some hang reports to crash-stats:
https://crash-stats.mozilla.com/report/index/d01e16bf-36b3-4b12-ba3c-2f5bc2120622
Comment 59 Jim Jeffery not reading bug-mail 1/2/11 2012-06-22 13:39:36 PDT
Test case seems to not work for me.
I get a pop-up:  grayed out 'Movie not loaded' and on next line: About Adobe Flash Player 11,3,300,262... clicking that open an Adobe page.  

No new window/tab opens at all on right-click of left hand box, same with right-box.

Opening the test case and doing nothing I see this in Console2:
Warning: Scripts may not close windows that were not opened by script.
Source file: https://bug763237.bugzilla.mozilla.org/attachment.cgi?id=635741
Line: 19
Comment 60 Jim Jeffery not reading bug-mail 1/2/11 2012-06-22 13:40:38 PDT
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #59)
> Test case seems to not work for me.
> I get a pop-up:  grayed out 'Movie not loaded' and on next line: About Adobe
> Flash Player 11,3,300,262... clicking that open an Adobe page.  
> 
> No new window/tab opens at all on right-click of left hand box, same with
> right-box.
> 
> Opening the test case and doing nothing I see this in Console2:
> Warning: Scripts may not close windows that were not opened by script.
> Source file: https://bug763237.bugzilla.mozilla.org/attachment.cgi?id=635741
> Line: 19

Win7 x64 latest hourly build bases on cset: 
https://hg.mozilla.org/mozilla-central/rev/93439ef24979
Comment 61 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-22 14:09:30 PDT
You might need to disable the Firefox pop-up blocker for this test to work properly.
Comment 62 Jim Jeffery not reading bug-mail 1/2/11 2012-06-22 14:27:24 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #61)
> You might need to disable the Firefox pop-up blocker for this test to work
> properly.

Yes, had to override the pop-up blocking.  If I just left the 'test case' run it kept opening tab after tab.. I assume is expected. 

Here is the crash report: 
https://crash-stats.mozilla.com/report/index/9740ffba-4b2d-4e62-9799-79af02120622
Comment 63 Jason Smith [:jsmith] 2012-06-22 15:10:16 PDT
Confirmed that Martijn's test case indeeds works to reproduce this crash on FF 14 Beta. Removing qawanted.
Comment 64 Jason Smith [:jsmith] 2012-06-22 15:13:16 PDT
(In reply to Jason Smith [:jsmith] from comment #63)
> Confirmed that Martijn's test case indeeds works to reproduce this crash on
> FF 14 Beta. Removing qawanted.

My crash report:

https://crash-stats.mozilla.com/report/index/bp-f1e73895-e627-4b1f-a5f1-cec9e2120622
Comment 65 Jeromie Clark 2012-06-22 17:30:30 PDT
I'm tracking Martijn's crash as a separate issue on our side.  It has a different root-cause than the issue we've addressed in 11.3.300.262.

https://bugbase.adobe.com/index.cfm?event=bug&id=3221904
Comment 66 Matthias Versen [:Matti] 2012-06-23 16:03:34 PDT
I can near always get a Flash crash using this steps:
1) load http://www.ardmediathek.de/das-erste/reportage-dokumentation/spielerberater?documentId=10891402#
2) switch to fullscreen: click on the right icon on the bar that comes up if the video starts and click on "Zum Vollbildmodus"
3) crash

If you don't crash pause the video, switch back to normal, start it again and switch back too fullscreen.

Environment: Windows 7/32bit,  NPSWF32_11_3_300_262.dll, Seamonkey trunk and Firefox13.0.1
crash ID: bp-8974798f-b34f-49ce-a368-2caed2120623
Comment 67 jdgoodrichjr 2012-06-24 23:59:23 PDT
Just now, I was watching several Flash videos (dbz.tv, DBZ, #s 15x-172). However, I've noticed the same failures happening on YouTube (the other major Flash-video site I utilize). I've also submitted a crash report [https://crash-stats.mozilla.com/report/index/bp-0583c702-aea1-400c-aa65-30c2e2120623], which I believe was based on a YouTube/Flash failure.

I've noticed my crashes (on a Windows 7 x64 Business laptop - HP 6910p: C2D_T8100/2GiB DDR2/120_SATA2) are inconsistent, but most of them cannot be caught by Firefox (by the way, version 13.0.1; Flash 11.3.300.257, updated on the 19th) for submission/report, but Windows does catch a good chunk, if I don't hard reset first. Yes, a hard reset, because I get **** enough at the computer's failings to not wait for the Ctrl+Shi[f]t+Esc "trick":

When I first started dealing with the main issue of crashes I have encountered, I usually Ctrl+Alt+Del, but doing it twice is useless (not setup to reboot on second, if the option is even available?); I started using CAD to open the Task Manager; but then I realized CSE does that, so I just used it instead. Now, even after I'd expect the TM to be "top" window, it sometimes never showed up as such. Although, I noticed, if I spammed it enough (or so this "spamming" helps relieve a little frustration), Windows would realized that DWM f**ked up, and restart it automatically. I've not been patient enough to just let it sit there, to figure out if Windows will detect the failure of DWM and restart it without the spamming, and I doubt I'll ever gain the requisite patience.

After experiencing the bug/issue again, and rereading the bug report thread, I recalled that the bug only occurs on Vista+ (or something to that effect). Since the above linked crash report is tagged/related to this bug, I thought about it for a second, and then I realized that DWM was first released on Vista, and has been continuously used ever since. Flash, videos... DWM.

I don't know if there is a correlation, or even if this post is helpful. I thought I'd just mention it instead of just taking the more or less "passive" route of yelling obscenities that the neighbors might overhear.

I've got a number of Application Errors and App Hangs in the Windows Event Log (for extra information), and I've also recorded, via my unsteady hand and an Olympus FE4030 digital camera, a video of the DWM crash in action with some choice language as live commentary from me. I'll work on putting it on YouTube for the time being, maybe it will help with understanding the crash?

If you need any more information from me, let me know, and I'll try to accommodate as best as possible.
Comment 68 Scoobidiver (away) 2012-06-25 00:21:20 PDT
jdgoodrichjr, please update to Flash 11.3.300.262 that has fixed some crashes with this crash signature (adbe 3210091).
Comment 69 John Kitz 2012-06-28 04:04:43 PDT
Experiencing a crash of Adobe Flash Player 11.3 R300 quite frequent lately. Searched bugzilla and came across this bug. Already sent a crash report to Adobe. Additional information of the crash as follows:

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	FlashPlayerPlugin_11_3_300_257.exe
  Application Version:	11.3.300.257
  Application Timestamp:	4fc82063
  Fault Module Name:	NPSWF32_11_3_300_257.dll
  Fault Module Version:	11.3.300.257
  Fault Module Timestamp:	4fc821fc
  Exception Code:	c0000005
  Exception Offset:	0016b4a9
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1043
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Mostly happens when closing a tab containing "http://www.rtl.nl/financien/rtlz/vandaag/". Could this be linked to flash based advertisements?
Comment 70 John Kitz 2012-06-28 04:06:50 PDT
I'm using FF 13.0.1.
Comment 71 John Kitz 2012-06-28 04:35:35 PDT
Visited the adobe site and noticed a difference in the version for the Flash Player between Windows based systems running IE and FF, as follows:

Browser            Player version
Internet Explorer  11.3.300.257
Firefox            11.3.300.262

My system is running Flash .257 while I use FF. Flash on my system is configured to check for updates every 7 days, could it be that it won't automatically update to .262 since I also have IE installed, for access to the occasional site that won't render properly in FF?
Comment 72 Scoobidiver (away) 2012-06-28 04:53:07 PDT
(In reply to John Kitz from comment #69)
> Already sent a crash report to Adobe.
This kind of error is not sent or sent to MS that does nothing with that.
This bug track crashes with the F1398665248 signature in the crash report, more exactly crashes with the STR of comment 56.

(In reply to John Kitz from comment #71)
> Visited the adobe site and noticed a difference in the version for the Flash
> Player between Windows based systems running IE and FF
It is expected: http://www.adobe.com/software/flash/about/
Comment 73 jdgoodrichjr 2012-06-28 08:29:58 PDT
updates, yay! (happy, because more information helps; not happy, because i still get some crashing..)

this just happened on YouTube (going back on one tab's history of viewed videos, selecting the "oldest" on in the right-click back-button history thrice):

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	FlashPlayerPlugin_11_3_300_262.exe
  Application Version:	11.3.300.262
  Application Timestamp:	4fe20fae
  Fault Module Name:	NPSWF32_11_3_300_262.dll
  Fault Module Version:	11.3.300.262
  Fault Module Timestamp:	4fe21212
  Exception Code:	c0000005
  Exception Offset:	00490fb1
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

The plugin error box reports "No report available".

Prior to this, I had only DWM failure after upgrading to 262, but it has the same symptoms - locked video output but unlocked cursor drawing routines. This is the whole system not being able to respond to clicks, even the Windows key doesn't bring up the Start menu. However, Ctrl+Shift+Esc and Ctrl+Alt+Del work as expected. Coming back from CAD (via Cancel button) works as expected, but the video output is still in its "derp" state. Anything else, it's a no-go (until it recovers, which it did (after about 10-15 minutes, but the exact timing I cannot pin down yet).

Are there other tools to which I might employ to help with this bug? I don't know if the crash report (copied and pasted from the Windows crash dialog box -- this is the first time Windows reported that the Plugin failed, mind you) is related, but since it occurred while experiencing the same issues as before (with 257), I'm adding the information here. [Feel free to mark it as necessary, even if a different bug.]
Comment 74 John Kitz 2012-07-04 07:40:45 PDT
Received the .262 update today. Still had a couple of crashes stating "Adobe Flash Player 11.3 R300 stopped working" prior to that. Will await results in the coming days after the upgrade and update ticket as needed.
Comment 75 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-04 08:10:11 PDT
https://crash-stats.mozilla.com/report/index/bp-ec35d2e0-3d92-48ca-87c7-d95ed2120704
I get this crash with the testcase from this bug, using bsmedberg's special build from bug 769048.
Comment 76 Benjamin Smedberg [:bsmedberg] 2012-07-05 13:20:46 PDT
With the Flash crash reporting in place, I was eventually able to get https://crash-stats.mozilla.com/report/index/e133507b-feb6-4dd7-864b-559932120705 for this crash. Stack of that is

0 	NPSWF32_11_3_300_262.dll 	F776535889________________________________________________________ 	F_1807764268___________________________________________________:352
1 	NPSWF32_11_3_300_262.dll 	F1989942690_____________________________________________________________________ 	F_1807764268___________________________________________________:259
2 	NPSWF32_11_3_300_262.dll 	F913258907____________________________ 	F315223226___________________________________________:22077
3 	NPSWF32_11_3_300_262.dll 	F1546913566_____________________________________ 	F855043634__________________________________________________________________________:4362
4 	NPSWF32_11_3_300_262.dll 	F1187989989____________________________________________ 	F855043634__________________________________________________________________________:351
Comment 77 zlatinivanov 2012-07-06 08:18:50 PDT
Shockwave Flash 11.3.300.262 (aka 11.3 r300) crashes Firefox 13.0.1 constantly! Long unresponsive delays! Loads of coleagues are complaining about that! 

This is NOT ACCEPTABLE, most of the people don't know what is causing the problem but it stops people from doing their job. 

Mozilla needs to react NOW as masses are quickly moving to Chrome! 

OS: Win Server 2008 R2 64BIT, Intel Core2Duo E8400, Dell PC
Comment 78 Matthias Versen [:Matti] 2012-07-06 08:34:13 PDT
This bug is not about a Firefox crash but rather a flash crash.
This doesn't crash Firefox and you have to reload only the page with the crashed plugin. The crash itself can not be fixed by Mozilla, only by Adobe.
We know that this will cost us market share but that doesn't change anything.

Bugzilla is no support, feedback or discussion Forum. Please avoid it to add further offtopic comments
Comment 79 Scoobidiver (away) 2012-07-06 09:12:45 PDT
zlatinivanov, for a workaround, see http://support.mozilla.org/kb/flash-113-crashes
Comment 80 zlatinivanov 2012-07-06 14:50:32 PDT
My only concern is about a GOOD browser users diminishing, all because of a plugin. 

Take that plugin off the add-ons market, put a big message on all Mozilla pages, NAME and SHAME whosoever fault it is. 

And it is not about findding a workaround (thanks Scoobidiver) it is about the fact that the browser is not responding for a very long periods of time. Even if it is just a Plugin failing. It took a lot of Googling and I could not find a single tread why is this happening. This is how I ended here. 

How long wold you stay on a slow responding page? This is even worse the whole browser is not responding and sits in a way of other applications.
Comment 81 Scoobidiver (away) 2012-07-06 23:52:18 PDT
zlatinivanov, see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
Comment 82 Scoobidiver (away) 2012-07-07 00:03:16 PDT
*** Bug 769131 has been marked as a duplicate of this bug. ***
Comment 83 erpman1 2012-07-08 15:22:15 PDT
@zlatinivanov: please direct your complaints either at the mozillazine forums:
http://forums.mozillazine.org/viewforum.php?f=38
or in the Adobe flash forums page:
http://forums.adobe.com/community/flashplayer

your bickering here is almost pointless as you're blaming the wrong people.
Adobe is more to blame than Mozilla.  I'm using Flash 11.3.300.262 on my Vista and Win7 computers with Firefox 13.0.1 and I haven't gotten ANY crashes with the latest version of Flash.
Comment 84 Jim Jeffery not reading bug-mail 1/2/11 2012-07-11 05:11:51 PDT
I see that Adobe has a new Flash release: 11.3.300.265 

Any word on if this fixes the crash-issues ?  Nothing I see in the 'release info' posted here says anything about any crash-fixes: 

http://www.neowin.net/news/adobe-flash-player-113300265 
Direct links to download in the article.
Comment 85 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-07-11 09:27:09 PDT
Thanks for pointing this out Jim.

Those of you following along with this bug that were able to reproduce a crash, can you please go to get.adobe.com/flashplayer and update to Flash 11.3.300.265? Lets see if any of these crashes are resolved.
Comment 86 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-11 10:46:25 PDT
I'm still crashing with the attached testcase in this bug:
https://crash-stats.mozilla.com/report/index/48f88140-7c10-478b-96a4-2c63a2120711
Comment 87 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-11 10:47:06 PDT
I mean that the Flash plugin is crashing with it, not Firefox itself.
Comment 88 Paul Silaghi, QA [:pauly] 2012-07-12 00:40:01 PDT
FF 14b12 youtube crash with flash 11.3.300.265:
https://crash-stats.mozilla.com/report/index/152289e4-f516-4c76-9d77-48c632120712
Comment 89 Simona B [:simonab ] 2012-07-12 02:19:43 PDT
Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0

Flash 11.3.300.265 crashed for me also on Firefox 14 beta 12 (on Windows Vista), with the protected mode on default (on).

Steps to reproduce:
1. Load http://www.imdb.com/
2. Click on any available trailer 
3. While the trailer is playing right click on it and from the context menu select "Toggle Fullscreen" over and over again.

At some point a Windows message is get "Adobe Flash player stopped working" and Flash crashes.

https://crash-stats.mozilla.com/report/index/bp-13c0d234-4181-4013-821b-127bc2120712
Comment 90 Scoobidiver (away) 2012-07-15 12:22:35 PDT
*** Bug 774092 has been marked as a duplicate of this bug. ***
Comment 91 candaules 2012-07-15 12:37:18 PDT
Hi, is this crash the same?
https://crash-stats.mozilla.com/report/index/b242dc02-2f6d-4695-b527-7630e2120711
Comment 93 candaules 2012-07-15 14:51:36 PDT
but tese crashes happen ONLY with 8-10 tabs with YT!
otherwise, firefox/flash does never crash ;)
Comment 94 candaules 2012-07-16 07:03:09 PDT
we have to wait for FF15!!

Unfortunately, the crash logs being submitted by **Firefox 14 and below** are missing critical information to be useful. (so Adobe) 
FF15 will allow us to send a valid/complete crash report to the flash devs ;)
Comment 95 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-07-19 10:16:42 PDT
With a recent trunk build, I get this stack using the testcase and the str:
https://crash-stats.mozilla.com/report/index/bp-a6278e86-ec34-48d3-b786-30d432120718
0 	NPSWF32_11_3_300_265.dll 	F1989942690_____________________________________________________________________ 	F_280847721____________________________________________________:272
1 	NPSWF32_11_3_300_265.dll 	F913258907____________________________ 	F_1900438979_________________________________________:22077
2 	NPSWF32_11_3_300_265.dll 	F1546913566_____________________________________ 	F1157779535_________________________________________________________________________:4362
3 	NPSWF32_11_3_300_265.dll 	F1187989989____________________________________________ 	F1157779535_________________________________________________________________________:346
4 	user32.dll 	InternalCallWinProc 	
5 	user32.dll 	UserCallWinProcCheckWow 	
6 	user32.dll 	DispatchMessageWorker 	
7 	user32.dll 	DispatchMessageW 	
8 	FlashPlayerPlugin_11_3_300_265.exe 	F425467176_____________________________________________________ 	F_540393159_____________________________________________________________________:358
9 	FlashPlayerPlugin_11_3_300_265.exe 	F849276792______________________________ 	F_540393159_____________________________________________________________________:199
10 	FlashPlayerPlugin_11_3_300_265.exe 	F_1338064323______________________________________________ 	F1922230711_______________________________________________

Can someone from Adobe reproduce this?
Comment 96 Aaron Train [:aaronmt] 2012-07-19 10:31:21 PDT
With mw22's attached test-case, I get:

bp-d5439020-fe0a-4f2e-be1a-e4c5d2120719

Tested via, Nightly (07/19), Windows 7 (Flash 11.3.300.265)
Comment 97 Arthur K. 2012-07-19 13:26:12 PDT
Anyone test with 11.4.400.231 yet?
Comment 98 Arthur K. 2012-07-19 13:36:12 PDT
I tried to repro per comment 89 with 11.4.400.231 on 14.0.1 and it did not crash.
Comment 99 Arthur K. 2012-07-26 10:04:57 PDT
Anyone tested with Flash 11.3.300.268?
Comment 100 Scoobidiver (away) 2012-07-26 10:35:59 PDT
(In reply to Arthur K. from comment #99)
> Anyone tested with Flash 11.3.300.268?
The testcase that makes it crash with this crash signature is fixed with Flash 11.3.300.268.
Nevertheless, there are still plenty of crashes with this crash signature, not caused by this testcase.

*** This bug has been marked as a duplicate of bug 775646 ***
Comment 101 John Kitz 2012-07-26 11:16:58 PDT
(In reply to John Kitz from comment #74)
> Received the .262 update today. Still had a couple of crashes stating "Adobe
> Flash Player 11.3 R300 stopped working" prior to that. Will await results in
> the coming days after the upgrade and update ticket as needed.

Haven't had any Adobe Flash crashes since the 11.3.300.262 update during normal operation, so the pbm. would appear to be resolved. Haven't tried the test case though.
Comment 102 Jeromie Clark 2012-07-26 17:48:46 PDT
Flash Player 11.3.300.268 makes a number of changes and blind fixes to try and mitigate the majority of these problems.  We do know that crashes related to hardware acceleration and buggy drivers presents with this signature. 

Steps to Reproduce, and/or video card and driver information for users reporting crashes would be extremely helpful.  We can blacklist problematic cards and/or old driver versions that are experiencing crashes.
Comment 103 banakon 2012-08-02 06:06:25 PDT
Load this video
https://www.facebook.com/photo.php?v=1168972263383

swutch to other tabs.
return to this tab.
I become
https://crash-stats.mozilla.com/report/index/034cb1a6-e107-4ece-a57c-1236c2120802
Comment 105 Scoobidiver (away) 2012-08-02 06:11:37 PDT
(In reply to banakon from comment #103)
This bug is fixed. If you have reliable steps to reproduce, please file a new bug.
Comment 106 BMO Automation 2016-04-28 10:07:52 PDT
Version and milestone values are being reset to defaults as part of product refactoring.

Note You need to log in before you can comment on or make changes to this bug.