Last Comment Bug 763474 - Firefox win32 l10n builds broke since Jun 8th because Win2008R2 check not avail in NSIS 2.33
: Firefox win32 l10n builds broke since Jun 8th because Win2008R2 check not ava...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Brian R. Bondy [:bbondy]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 06:51 PDT by Alexander L. Slovesnik
Modified: 2012-06-13 15:46 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.41 KB, patch)
2012-06-11 13:55 PDT, Brian R. Bondy [:bbondy]
jmathies: review+
robert.strong.bugs: review+
Details | Diff | Splinter Review

Description Alexander L. Slovesnik 2012-06-11 06:51:29 PDT
Last win32 builds in http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/ are from Jun 8th. Tinderbox log ( http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-l10n/1339421691.1339421808.29680.gz ) shows following errors:

!insertmacro: macro "_And" requires 4 parameter(s), passed 2!
Error in script "installer.nsi" on line 923 -- aborting creation process
make[2]: Leaving directory `/e/builds/moz2_slave/m-cen-w32-l10n-ntly/build/mozilla-central/browser/installer/windows'
make[1]: Leaving directory `/e/builds/moz2_slave/m-cen-w32-l10n-ntly/build/mozilla-central/browser/locales'
make[2]: *** [l10ngen/setup.exe] Error 1
make[1]: *** [repackage-win32-installer] Error 2
make: *** [repackage-win32-installer-ru] Error 2
program finished with exit code 2

Perhaps it's caused by Bug 760671
Comment 1 Axel Hecht [pto-Aug-30][:Pike] 2012-06-11 12:13:06 PDT
Robert, any idea?
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2012-06-11 12:15:28 PDT
Let's add bbondy since he wrote the patch for Bug 760671
Comment 3 Brian R. Bondy [:bbondy] 2012-06-11 12:19:12 PDT
Is a different version of NSIS used? It sounds like AtMostWin2008R2 is not defined.
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2012-06-11 12:26:24 PDT
I bet it is using 2.33 which doesn't have 2008 defined. I bet it will need something similar to bug 668574 to add the capability to deal with 2008, etc.
Comment 5 Brian R. Bondy [:bbondy] 2012-06-11 12:47:17 PDT
Yup if it's using 2.33, I just verified and as Robert said, the latest it has is Vista.  I'll try to get a patch together today to fix this.
Comment 6 Nick Thomas [:nthomas] 2012-06-11 13:15:01 PDT
FYI, RelEng is going to be installing NSIS 2.46u because Thunderbird needs it, so it might be possible to switch mozilla-central over to that. Bug 762218 tracks getting it on all the slaves.
Comment 7 Brian R. Bondy [:bbondy] 2012-06-11 13:17:12 PDT
Is this happening really soon? if not I'll still write a patch for this.
Comment 8 Nick Thomas [:nthomas] 2012-06-11 13:20:41 PDT
Hmm, missed that it is unassigned so you should probably go ahead with a workaround in the meantime.
Comment 9 Brian R. Bondy [:bbondy] 2012-06-11 13:55:37 PDT
Created attachment 632012 [details] [diff] [review]
Patch v1

Tested by making a local nsi file and including override.nsh with the change inside this patch.
Comment 10 Brian R. Bondy [:bbondy] 2012-06-11 18:14:57 PDT
I tried this on win7, win2008r2, and win8 and the check works correctly on all.
Comment 11 Brian R. Bondy [:bbondy] 2012-06-13 06:35:45 PDT
Comment on attachment 632012 [details] [diff] [review]
Patch v1

Hey Jim, would you be able to pickup this review? I don't want to keep l10n builds broken for too long and rstrong is flooded with some critical reviews for app update and about 7 other patches I asked for review on for telemetry data.
Comment 12 Brian R. Bondy [:bbondy] 2012-06-13 06:40:25 PDT
try builds work with this patch also:
https://tbpl.mozilla.org/?tree=Try&rev=aad2c0eb66ed
Comment 13 Brian R. Bondy [:bbondy] 2012-06-13 09:15:34 PDT
Verified this locally by replacing my makensis 2.46 with 2.33 and doing an l10n -fr build.  Could reproduce before the patch and can't after the patch.
Comment 14 Brian R. Bondy [:bbondy] 2012-06-13 09:35:58 PDT
http://hg.mozilla.org/mozilla-central/rev/798d248adc84
Comment 15 Robert Strong [:rstrong] (use needinfo to contact me) 2012-06-13 15:46:50 PDT
Comment on attachment 632012 [details] [diff] [review]
Patch v1

Looks good!

Note You need to log in before you can comment on or make changes to this bug.