The default bug view has changed. See this FAQ.

[Windows] Launching a Web Application with no supported Firefox version installed shows incorrect Firefox version to user

VERIFIED FIXED in Firefox 16

Status

Firefox Graveyard
Web Apps
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: jsmith, Assigned: TimAbraldes)

Tracking

({regression})

unspecified
Firefox 16
x86_64
Windows 7
regression
Bug Flags:
in-moztrap +

Details

(Whiteboard: [qa!])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps:

1. Install a Web Application from Nightly
2. Uninstall Nightly
3. Launch the web application

Expected:

The error message should say for Windows:

WebappRT

This app requires that Firefox version 15 or above is installed. Firefox 15+ has not been detected.

Actual;

The error message on Windows actually says:

WebappRT

This app requires that Firefox version 14 or above is installed. Firefox 14+ has not been detected.
(Reporter)

Updated

5 years ago
Keywords: regression
Created attachment 632070 [details] [diff] [review]
Patch v1 - Initial patch. Changes string to say 15 instead of 14.
Assignee: nobody → tabraldes
Status: NEW → ASSIGNED
Attachment #632070 - Flags: review?(myk)
Attachment #632070 - Flags: review?(myk) → review+
(Reporter)

Comment 2

5 years ago
(In reply to Tim Abraldes from comment #1)
> Created attachment 632070 [details] [diff] [review]
> Patch v1 - Initial patch. Changes string to say 15 instead of 14.

Is this a windows only patch?
(In reply to Jason Smith [:jsmith] from comment #2)
> (In reply to Tim Abraldes from comment #1)
> > Created attachment 632070 [details] [diff] [review]
> > Patch v1 - Initial patch. Changes string to say 15 instead of 14.
> 
> Is this a windows only patch?

Yes, because the Mac implementation doesn't reference a Firefox version.
Comment on attachment 632070 [details] [diff] [review]
Patch v1 - Initial patch. Changes string to say 15 instead of 14.

https://hg.mozilla.org/integration/mozilla-inbound/rev/32b1c3c844c6
Attachment #632070 - Flags: checkin+
(Reporter)

Updated

5 years ago
Whiteboard: [qa+]
Target Milestone: --- → Firefox 16
https://hg.mozilla.org/mozilla-central/rev/32b1c3c844c6
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Flags: in-moztrap?(jsmith)
(Reporter)

Comment 6

5 years ago
Works on windows, busted on Mac. Looks like the patch here only supports windows, which probably explains why this isn't working on Mac. I see the following on Mac:

WebappRT Not Found

Failure to locate specified override runtime with signature 'org.mozilla.nightly'
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

5 years ago
Whiteboard: [qa+]
(Reporter)

Comment 7

5 years ago
Actually, this is probably not the right bug causing the bustage. Something else caused it...
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

5 years ago
Can someone explain why there isn't an equilvalent Mac patch here? And is the issue I'm hitting here related to this bug or something else?
(Reporter)

Updated

5 years ago
Whiteboard: [qa?]
As comment 3 says, the Mac error message doesn't specify a version. It's not clear to me what issue comment 6 is describing. Are you just pointing out that the Mac error message is more confusing? A separate bug can be filed on improving that.
Summary: [Mac & Windows] Launching a Web Application with no supported Firefox version installed shows incorrect Firefox version to user → [Windows] Launching a Web Application with no supported Firefox version installed shows incorrect Firefox version to user
(Reporter)

Comment 10

5 years ago
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #9)
> As comment 3 says, the Mac error message doesn't specify a version. It's not
> clear to me what issue comment 6 is describing. Are you just pointing out
> that the Mac error message is more confusing? A separate bug can be filed on
> improving that.

Oh my bad. Forgot to read at the comments above. Anyways.

I'll get a separate bug open about Mac. Marking as verified.
Status: RESOLVED → VERIFIED
Whiteboard: [qa?] → [qa!]
(Reporter)

Updated

5 years ago
QA Contact: jsmith
(Reporter)

Updated

5 years ago
Flags: in-moztrap?(jsmith) → in-moztrap+
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.