The default bug view has changed. See this FAQ.

Page reloads get treated as same-document location changes

RESOLVED FIXED in Firefox 14

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

unspecified
Firefox 16
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, firefox15 fixed, firefox16 fixed, blocking-fennec1.0 -, fennec15+)

Details

Attachments

(1 attachment)

Regression from bug 747883; the URL fixup stuff inadvertently treats page reloads as "spurious addition"s to the URL.
Created attachment 631962 [details] [diff] [review]
Make page reloads set !sameDocument
Attachment #631962 - Flags: review?(mark.finkle)
Also CC'ing ajuma in case he has any comments.
Noming this as it blocks bug 759678, which in turn could fix bug 721523, which is a blocker.
blocking-fennec1.0: --- → ?
Attachment #631962 - Flags: review?(mark.finkle) → review+
Not a blocker because bug 721523 is going to be wallpapered over AMO side, aiui. Would like, though (and feel free to approvalnom if appropriate).
tracking-fennec: --- → 15+
blocking-fennec1.0: ? → -
https://hg.mozilla.org/integration/mozilla-inbound/rev/bed9bdc78e8c
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → fixed
Target Milestone: --- → Firefox 16
https://hg.mozilla.org/mozilla-central/rev/bed9bdc78e8c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 631962 [details] [diff] [review]
Make page reloads set !sameDocument

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 747883
User impact if declined: on page reload, the page might jump around during load, since we don't suspend viewport updates and user interaction.
Testing completed (on m-c, etc.): on m-c for a day
Risk to taking this patch (and alternatives if risky): mobile-only. potential risk of either regressing bug 747883 or not fully fixing the issues described in "user impact if declined"
String or UUID changes made by this patch: none

Also note that the patch on bug 759678 will be ineffective for page reloads without this patch.
Attachment #631962 - Flags: approval-mozilla-beta?
Attachment #631962 - Flags: approval-mozilla-aurora?
Comment on attachment 631962 [details] [diff] [review]
Make page reloads set !sameDocument

Discussed in triage with kats - approved for b7. Go go go!
Attachment #631962 - Flags: approval-mozilla-beta?
Attachment #631962 - Flags: approval-mozilla-beta+
Attachment #631962 - Flags: approval-mozilla-aurora?
Attachment #631962 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ef143fb2db67
https://hg.mozilla.org/releases/mozilla-beta/rev/e49fb24c3476

and on the b7 relbranch:
https://hg.mozilla.org/releases/mozilla-beta/rev/7e41f8cab7c6
status-firefox14: affected → fixed
status-firefox15: affected → fixed
Verified on Firefox 14 beta 7 build 2
status-firefox14: fixed → verified
You need to log in before you can comment on or make changes to this bug.