Last Comment Bug 763718 - Restyle Popped Out Chat Windows
: Restyle Popped Out Chat Windows
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 770433
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 14:54 PDT by Jennifer Morrow [:Boriss] (UX)
Modified: 2013-12-27 14:21 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Mockup: Current Implementation vs Restyled Goal (672.60 KB, image/png)
2012-06-11 14:55 PDT, Jennifer Morrow [:Boriss] (UX)
no flags Details

Description Jennifer Morrow [:Boriss] (UX) 2012-06-11 14:54:59 PDT
The current SocialAPI chat windows display conversations in tabs and a status bar at the bottom.  Both of these should be removed.  The tabbed conversations are unnecessary and potentially create privacy concerns because they do not allow a single conversation to be hidden or minimized without being closed entirely.  Further, because of the size of an average chat window, only three or four tabs are easily viewable before the window would need to be resized. 

The status bar is also not necessary.  Currently it shows the domain which spawned the conversation and a progress bar.  The domain is not needed because if a user has installed a social network's sidebar, become engaged in a conversation, and is carrying on that conversation, there is little value in reminding them where it initially came from.  The only time when this information could be relevant would be if a user had installed multiple sidebars from multiple social networks, had more than one enabled at once, and then began two conversation with the same person in two different networks where that user had the same avatar.  This scenario is likely to be rare, and not worth adding a domain for.  The progress bar doesn't serve much purpose at all.

With a simple restyle, we can make the windows simple and follow the style of the sidebar itself per operating system (OSX shown in attachment).
Comment 1 Jennifer Morrow [:Boriss] (UX) 2012-06-11 14:55:59 PDT
Created attachment 632029 [details]
Mockup: Current Implementation vs Restyled Goal
Comment 2 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-06-27 22:51:28 PDT
FYI the status bar is there as a hookup primarily for security ui (the progress bar should be replaced with the name of the SSL cert provider), it was never intended to be the actual ui.  My anticipation was that some kind of security indicator would be requested so I wanted to get the code for it in place.  This has been requested via security review for the sidebar, which I see as a more difficult UI to add some kind of security indicator (bug 766622)
Comment 3 Dão Gottwald [:dao] 2012-07-23 18:02:35 PDT
Why is this corp. confidential?
Comment 4 Mark Hammond [:markh] 2012-07-23 18:08:49 PDT
(In reply to Dão Gottwald [:dao] from comment #3)
> Why is this corp. confidential?

I believe most of the bugs with UI mockups were marked confidential - but I'm not sure how long they should stay that way.
Comment 5 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-07-23 18:10:18 PDT
The mockup includes a reference to a specific third-party.
Comment 6 Asa Dotzler [:asa] 2012-08-23 15:44:57 PDT
fixed by 79686, I believe.
Comment 7 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2012-08-23 17:11:44 PDT
(In reply to Asa Dotzler [:asa] from comment #6)
> fixed by 79686, I believe.

IYTM bug 779686 :)

Note You need to log in before you can comment on or make changes to this bug.