Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 763865 - Layout tool is not positioned correctly when it is collapsed
: Layout tool is not positioned correctly when it is collapsed
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: Firefox 16
Assigned To: Nobody; OK to take it and work on it
: (Unavailable until Nov 1) Brian Grinstead [:bgrins]
Depends on:
Blocks: 747220
  Show dependency treegraph
Reported: 2012-06-12 02:47 PDT by Paul Silaghi, QA [:pauly]
Modified: 2012-07-02 07:26 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

layout-bad (368.28 KB, image/png)
2012-06-12 02:47 PDT, Paul Silaghi, QA [:pauly]
no flags Details
layout-good (378.23 KB, image/png)
2012-06-12 02:48 PDT, Paul Silaghi, QA [:pauly]
no flags Details
v1 (1.07 KB, patch)
2012-06-20 07:42 PDT, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
v2 (732 bytes, patch)
2012-06-21 02:09 PDT, Paul Rouget [:paul]
dcamp: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Paul Silaghi, QA [:pauly] 2012-06-12 02:47:44 PDT
Created attachment 632180 [details]

1. Open the Inspector
2. Click on "Style"

Actual results:
The Layout tool is collapsed too much - see layout-bad.png

Expected results:
Expanding and then collapsing again the tool fix the problem
Comment 1 Paul Silaghi, QA [:pauly] 2012-06-12 02:48:22 PDT
Created attachment 632181 [details]
Comment 2 Paul Rouget [:paul] 2012-06-12 03:04:19 PDT
Can you reproduce on Firefox Nightly?
Did it happen once or it happens every time?
Comment 3 Paul Rouget [:paul] 2012-06-12 03:08:15 PDT
I can't reproduce here. Can you reproduce on Mac and/or Linux?
Comment 4 Paul Silaghi, QA [:pauly] 2012-06-12 04:20:11 PDT
I can always reproduce it on all platforms. Same behavior on Nightly.
Comment 5 Paul Silaghi, QA [:pauly] 2012-06-12 04:31:19 PDT
In order to reproduce this, make sure the Layout tool didn't remain expanded from a previous use. It should be collapsed when opening the inspector/style, this happens only then.
Comment 6 Loic 2012-06-12 08:30:37 PDT
(In reply to Paul Rouget [:paul] from comment #3)
> I can't reproduce here. Can you reproduce on Mac and/or Linux?

My STR on Win 7 with Nightly:

1) Open about:home
2) Enable Web Developer > Responsive Mode (or Ctrl+Shift+M)
3) Enable Web Developer > Inspect (or Ctrl+Shift+I)

The footer of the layout tool is collapsed too much.
Click on a page element to inspect, the footer returns to its normal height.
Comment 7 Paul Rouget [:paul] 2012-06-20 07:42:38 PDT
Created attachment 634917 [details] [diff] [review]
Comment 8 Paul Rouget [:paul] 2012-06-20 08:08:21 PDT
Comment on attachment 634917 [details] [diff] [review]

That works. I would prefer to do that in CSS, but not sure how.
Comment 9 Dave Camp (:dcamp) 2012-06-20 15:48:11 PDT
What does this do, exactly?
Comment 10 Paul Rouget [:paul] 2012-06-21 02:09:27 PDT
(In reply to Dave Camp (:dcamp) from comment #9)
> What does this do, exactly?

This adds an inline element, forcing its parents to get the correct height.
But I guess we don't need to have the full height, only the correct position.
Comment 11 Paul Rouget [:paul] 2012-06-21 02:09:49 PDT
Created attachment 635226 [details] [diff] [review]
Comment 12 Paul Rouget [:paul] 2012-06-21 02:16:12 PDT
So apparently, using `vertical-align:top` works.

But I don't understand why there's a gap in the first place.
See (gap between the red line and the dotted line).
As soon as you add content to the span or use vertical-align:top, the gap disappears.
Comment 13 Paul Rouget [:paul] 2012-06-21 02:17:22 PDT
And we probably want to get that in Aurora as well.
Comment 14 Paul Rouget [:paul] 2012-06-25 02:47:07 PDT
Comment on attachment 635226 [details] [diff] [review]

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature
User impact if declined: layout view UI looks weird
Testing completed (on m-c, etc.): local
Risk to taking this patch (and alternatives if risky): One CSS line 
String or UUID changes made by this patch: no
Comment 16 Panos Astithas [:past] 2012-06-25 07:10:24 PDT
Comment 17 Paul Silaghi, QA [:pauly] 2012-06-26 07:50:49 PDT
Verified fixed on Nightly 16.0a1 (2012-06-26) on Win 7, Ubuntu 12.04 and Mac OS X 10.6.
Comment 18 Alex Keybl [:akeybl] 2012-06-26 11:17:14 PDT
Comment on attachment 635226 [details] [diff] [review]

[Triage Comment]
Looks super low risk. Approved for Aurora 15.
Comment 20 Paul Silaghi, QA [:pauly] 2012-07-02 07:26:30 PDT
Verified fixed on Aurora 15.0a2 (2012-07-01) on Win 7, Ubuntu 12.04 and Mac OS X 10.6.

Note You need to log in before you can comment on or make changes to this bug.