Profile migration uses the wrong bookmarks file

RESOLVED WONTFIX

Status

Core Graveyard
Profile: Migration
RESOLVED WONTFIX
18 years ago
2 years ago

People

(Reporter: Adam Lock, Unassigned)

Tracking

({relnote})

Trunk
relnote

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have editted several of my 4.x profiles to share the same bookmarks file. I
have done this by adding a line to prefs.js like this:

user_pref("browser.bookmark_location", "D:\\personal\\profiles\\Bookmark.htm");

This means that these profiles will load the specified bookmark file instead of
the one in the profile folder.

Mozilla's profile migration tool is not reading the "browser.bookmark_location"
pref when it migrates a profile. Instead it is just importing the bookmarks.html
contained in the profile directory even though it's not the one I specify in prefs.

Comment 1

17 years ago
*** Bug 84319 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Component: Profile Migration → Bookmarks
QA Contact: gbush → claudius

Comment 2

17 years ago
changing component/ QA contact
Migrator only copies the files as they exist in 4.x, it does not access the file 
after launch

Comment 3

17 years ago
that pref has been changed to "browser.bookmarks.file" for Mozilla. reassigning to Ben
since I presume he is the owner. CC'ing gerv since your patch(bug 31623) changed that
pref and cc waterson (sr'd that patch) for some sane comments as to why this was the right
thing to do and what the heck to do so I stop seeing bugs of this nature (bug 84319).

As i understand it, we're breaking everyone who specified an alternate location for their BM
file in 4.x AND in 4.x there was UI to make this change whereas in Moz one must hand edit
the prefs file.
Assignee: racham → ben
OS: Windows 2000 → All
Hardware: PC → All
I didn't want to change the pref name; however, keeping it the same means the 
pref is migrated and causes problems when people run 4.x and Mozilla at the same 
time. Please see bug 31623 for the discussion.

If opinion has changed, and we want the pref name changing back, it's a 2-line 
change - no problem.

BTW, the original pref name was browser.bookmark_file.

Gerv
More comments:

The reason we changed the pref name is that 4.x does not play nice if the two 
are running at the same time. You get "Bookmarks changed on disk" popups every 
five minutes - very annoying. And many users will not know what the problem is, 
or how to fix it.

Secondly, UI for this feature is on my todo list, albeit very low down. Should 
have something by the end of June, hopefully. When that's in place, people 
should be able to set this up much easier. We implemented the pref without the 
front end so that it was _possible_, rather than being impossible. This is 
definitely a good thing.

Gerv

Comment 6

17 years ago
*** Bug 85931 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
we need to relnote this <g>, i thought i already asked us to do that :(

first poor attempt at relnote text (if relnoter has time, relnoter should try 
from scratch):<q class="relnote" title="import bookmarks">
Netscape4 had a preference that specified the bookmark file location, it was 
'browser.bookmark_file' the new pref string is "browser.bookmarks.file".  If 
you have been using older mozilla versions or netscape6 then you should 
probably take the following steps:

run nc4, import your mozilla/netscape6 bookmarks. quit nc4. [if you have mail 
folders in both netscape4 and mozilla/netscape6 you will have a similar problem 
see a future relnote or send us a suggestion.]

find your mozilla/netscape6 profile, edit the prefs.js file to point to your 
netscape4 bookmark file. This should be as simple as changing or copying 
'browser.bookmark_file' to "browser.bookmarks.file"</q>

<q class="relnote offtopic draft" title="import mail">For the mail problem, 
create a new pop server (localhost).  enter blank information (username 
'imported' or 'netscape4') then change the mailbox folder in the mail accounts 
tab to point to your old netscape4 pop account.  You can now drag and drop 
between the accounts.</q>
Keywords: relnote
I don't understand your relnote, or why you need to go through all those steps. 
:-| How about:

<q class="relnote" title="import bookmarks">
Mozilla allows you to set an arbitrary file as your bookmarks file, although 
there is no UI for this feature yet. While Mozilla is not running, edit the 
prefs.js file in your profile directory, and add a line like this:
user_pref("browser.bookmarks.file", "file:///path/to/bookmark.htm");

Note that if you have an alternate bookmarks file set up in Netscape 4, this 
will not be picked up automatically by Mozilla, because sharing the file between 
the two browsers can cause problems.
</q>

Gerv
This is actually a migration bug. 
Assignee: ben → racham
Component: Bookmarks → Profile Migration
QA Contact: claudius → ktrina
mass re-assign.
Assignee: racham → sspitzer
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: ktrina → profile-migration
NS4.x profile migration is gone
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.